Problem Booting Original Pi

#1

Hi,

I have an original Raspberry Pi B that I am trying to get running. The PI boots fine off of other SD cards. I used the tutorial in the getting started page with the image that is listed there. I am formatting using OSX. After formatting I can mount everything just fine on my laptop but the PI gets to the raspberry logo and hangs. I tried redownloading the image and reflashing as well as a different SD card. Is the problem that my PI is too old?

Thanks for any advice.

0 Likes

#2

Please try reverting to stock kernel by getting it to run on RPi 2 or 3, and run this command:

sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel

After that, you should have the regular Raspberry Pi kernel, it may work on older Raspberry Pi boards. We only test the OS down to Raspberry Pi 2.

0 Likes

#3

Thanks! I went out and bought a PI 3 this afternoon in order to try this and it seems to have worked. I can boot the PI and load PD and it get sound. Thank you! I’ll move my main tinkering to the PI3 for now but I’d be happy to beta test on an original PI if there are any other users around who may find it useful.

1 Like

#4

It’s an interesting idea (and I still have two original RPi Bs on a shelf somewhere), but I think it would be seriously limited in what you could do with it by the performance of the single core CPU.

0 Likes