Patchbox Gets Corrupted on First Boot (Raspberry Pi 4 8GB)

I have a Raspberry Pi 4 with PiSound card. When I first boot up Patchbox OS, it gets to the login as expected. However:
-none of my usb keyboards work so I can’t login.
-if I restart the board (via a hard reset, because I have no other choice), it will no longer boot. The green light blinks once when first powered up, and then never turns on again.
-The only way to get it to boot to Patchbox OS is to reflash the OS. However, I get the same results every time: It boots once, and then fails to boot a second time.

My assumption is that the OS is getting corrupted somehow on the first boot. Here’s what I’ve tried so far:

  1. I thought that maybe the Patchbox OS was getting corrupted because I didn’t go through the initial setup. So I ssh’d into my Pi and was able to login and complete the initial Pathbox OS setup. However, when I restarted (via a command line reboot), it still failed to boot again.
  2. Raspian OS. This seems to work fine. usb keyboard works fine, and I can reboot as many times as I want.

I’m in the process of re-downloading the Patchbox OS image and am going to reflash with this re-downloaded image, just in case there was something wrong with the image itself. However the old download seemed to work fine on my old Raspberry Pi 2.

Which variation of Pi 4 do you have?

Raspberry Pi 4 Model B 8Gb memory.

It was released after Patchbox OS image was released, probably the real time kernel is too old for 8GB RPi. You can try installing the regular latest kernel on an earlier Raspberry Pi model, by running this command:

sudo apt install raspberrypi-kernel

Oh I see thanks! Do you have any idea if another release of Patchbox for the 8GB pi is coming soon?

And if I am going to install the non-realtime kernel, would it be just as good to install Raspian for now?

Thanks for the suggestion Giedrius!

I just got the pisound for my 8GB pi and am encountering the exact same behavior as androidhead described above (have cycled through reflashing a couple times).

I tried installing the regular latest kernel as suggested, but then encountered the same problem when rebooting.

I will stay tuned for next release of Patchbox but, meanwhile, is there anything else we would need to do for configuring or updating the non-realtime kernel?

Try to install all the latest updates from Raspbian’s apt as well, sudo apt update && sudo apt upgrade, in addition to switching to regular kernel.

Patchbox OS is just a customized image of Raspbian Lite. The regular kernel works quite well too. If installing updates and using regular kernel does not fix the issue, then you should go with Raspbian while we update the image.

Excellent, thanks Giedrius!

Any chance you guys tried updating all system packages before switching to Pi4 8GB?

I am a Linux noob so I haven’t tried that yet. But do you mean that we should try to update the packages BEFORE putting the sd card in the pi 4 8GB?

To confirm,

sudo apt install raspberrypi-kernel
sudo apt update
sudo apt upgrade

solved the problem for me. Thanks!

1 Like

Excellent! So flash the OS like normal, then run those commands after the first login?

Could someone try doing just sudo apt update && sudo apt upgrade without switching the kernel and let us know if it works.

I think it’d be safer to do it on an earlier system then Pi4 8GB, but it might work doing it on 8GB itself.

I got it working too! I didn’t try to omit kernel switching, but wanted to add some detail to the steps that need done for others who are as inexperienced as I am:

  1. Flash Patchbox to an SD card
  2. Put it in a Raspberry Pi that is NOT Raspberry Pi 4 8GB (I used a Raspberry Pi 2) & boot up & login.
  3. Run the following commands:
    sudo apt install raspberrypi-kernel
    sudo apt update
    sudo apt upgrade
  4. Put the SD card in your Raspberry Pi 4 8GB, and it should work

Later, I will try to omit kernel switching (presumably by omitting the “sudo apt install raspberrypi-kernel” command.

Thanks all!

1 Like

Ok, we’ve tried it ourselves now, looks like both things are necessary - updating the packages and switching to a newer mainline kernel. I’ve created a quick issue on Raspberry Pi’s kernel repository about updating rpi-4.19.y-rt branch with support for Pi 4 8GB. Once it’s done, we can rebuild the kernel and build a new Patchbox OS image, so it works out of the box with Pi 4 8GB.

3 Likes

I think it’d be safer to do it on an earlier system then Pi4 8GB, but it might work doing it on 8GB itself.

If anyone is in a pinch and only has a Pi 4 8GB handy, I can confirm that it works and can even work for a headless install

Again If you have an earlier Pi available I recommend androidhead’s instructions, but these worked for me in a pinch

  1. Flash an SD card with Patchbox OS

  2. Put the SD card into RPi 8GB and turn it on

  3. Log in via ssh (I did so via wifi to the Patchbox hotspot)

  4. Follow the config script as usual. If you are on Patchbox, you will need to switch to a wifi network that has internet access to download updates, but do not reboot. If you do accidentally, go back to step-1 and re-flash the card.

  5. Once you have internet access, run

    sudo apt install raspberrypi-kernel
    sudo apt update
    sudo apt upgrade

  6. If those install successfully, reboot your Pi and all should be good.

1 Like