[Beta] Patchbox OS image 2020-11-23

Hey guys! Here’s an updated Patchbox OS image, it should run out of the box with Pi 4 8GB model and Pi Zero models.

The biggest difference since the last release is that it now by default runs with stock kernel, and has a new kernel menu in patchbox utility to switch to the realtime kernel variation. This allows us to release updated images quicker as new Raspberry Pi models get released, as the realtime kernel branch always lags behind for many months since new hardware gets introduced.

image

Also, we can display a warning about installing the realtime kernel on not-yet-compatible systems, as well as make a full backup of the stock kernel, so it’s possible to recover a working state just by copying files from /boot/backup to /boot on the sd card using your PC.

Please let us know in case you hit any issues or have any feedback regarding this build.

Thank you!

I already have 2020-03-14 image installed, do I need to reflash?

No, there’s no reason to reflash this image on top of your existing Patchbox OS image install. It’d be enough to install the updates as normal:

sudo apt update && sudo apt upgrade

Downloads

  • Direct download
  • SHA-256: 569c4687fa3ff9876c0c32aa1aeaaf7cd1dd869c993fab229ed1df52d939f716

Default Passwords

User name patch
Password blokaslabs
WiFi SSID Patchbox
WiFi password blokaslabs

The WiFi hotspot is on by default.

6 Likes

Great seeing an update:

I noticed the previous patchbox image (maybe after apt-get update/upgrade) was running
Linux patchbox 4.19.71-rt24-v7l+ #1 SMP PREEMPT RT Wed Mar 11 17:15:58 EET 2020 armv7l GNU/Linux
I’m running this on a RPi 4B 8Gb, and it seems to work fine.

I flashed another RPi 4B8 GB using the new image
Linux patchbox 5.4.72-v7l+ #1356 SMP Thu Oct 22 13:57:51 BST 2020 armv7l GNU/Linux
I noticed it is using the 5.x kernel, when trying to switch to the RT kernel I got the warning:
Screen Shot 2020-12-03 at 10.31.16

so I decided to skip for now…
but am I getting this right, it used to work, but no longer works? What is the drawback of using a 4.x kernel?

I’m building boxes for low latency rehearsing together using jacktrip. milliseconds do matter. Do you have any idea of the potential benefit of using RT? or is this used in a different manner?

The 4.19.71-rt24 RT kernel was built before 8GB version was released, at the moment there’s been no further updates for the realtime branch, so you have to use it at your own risk.

What measurements do you get on 4.19.71-rt24 and 5.4.72?

I’ve been doing some measurements using pure data.
Pure data also has a buffer of 64 samples resulting in a in + out = 128 samples = 2.666ms latency @48Khz
when I start measuring in a simple setup, I cannot yet find big differences.
Pisound adds about 2ms latency adc and dac, so again about 4ms in total. Again, this is measured using my crude PureData techniques.
in a stresstest involving 3 RPi4Bs connected on a 2 gigabit switchesand sending the signal from PD out over the pisound and back in and then over jacktrip (L/R channels etc) and back I had a latency of only ±40ms for 11 hops. You can see my test setup in the screenshots below. This was with a mixture of RT 4.19 kernels and regular 5.4 kernels. I will do the test unmixed, but I need to get some more SD cards first. So far I think the effect is very small…
the patch setup:


the measurement patch

2 Likes

You have an interesting project going on :slight_smile: Is there more information somewhere available on what you’re doing?

1 Like

Yes, I’ll link to it soon.

Just finished the technical analysis on this. I’ll start a thread next week to document the findings! Very good results in the end!

3 Likes

This download always crashes on install onto SD card.
I use the Raspberry Pi imager and it tells me that the unzipped file is corrupted.
(I do this on a WIN 10 PC)

Do you get the same SHA256 value on the downloaded zip file? Running:

sha256 image_2020-11-23-Patchbox.zip

should print:

569c4687fa3ff9876c0c32aa1aeaaf7cd1dd869c993fab229ed1df52d939f716

congratulations @Giedrius and Patchbos OS team, this release works amazing. The last image I tried it worked so bad, and I had to switch to a non rt kernel and that made me so sad. But now I am very happy!!

1 Like

I ve checked SHA 256 in 7 Zip and no, it is totally different :frowning:

Try downloading it again, the download may have been interrupted due to network failure or something along those lines.

yes it works fine now, thx for your support.

Any ideas if your Arm AppImage of the Midihub Editor works on Patchbox?

Yes, it works. After downloading, Linux requires for ‘execute’ permission to be set on the file to be able to run it:

curl -JO https://blokas.io/midihub/downloads/latest/linux_arm/
chmod +x MidihubEditor-arm_1.11.7.AppImage
./MidihubEditor-arm_1.11.7.AppImage
1 Like

you guys helped me a lot, unfortunatly Midihub Editor seems not to run on a raspberry zero.
I switched it to executable but it does not open (not even in terminal: shortly terminal pops up but nothing happens)

We’ll look into it :slight_smile:

1 Like

any news on editor running on my zero?

We’re working on it, we’ll let you know once we have any news.

Looks like the crash itself occurs in the AppImage loader itself. It can take a while to get it fixed, but here’s a temporary workaround, for 1.11.7 version:

First set up a launcher script called MidihubEditorLauncher.sh, it must be placed in the same folder as MidihubEditor-arm_1.11.7.AppImage file is located in.

cd path/to/folder/containing/MidihubEditor-arm_1.11.7.AppImage
wget https://gist.githubusercontent.com/gtrainavicius/333458b2ac83477a0bc758e8f983a154/raw/3420e87b6f27da986c154f057f81879f92047057/MidihubEditorLauncher.sh
chmod +x MidihubEditorLauncher.sh

Then either double click it and choose ‘Execute’ or ‘Execute in Terminal’, and the editor should open up. Or simply run in a terminal:

./MidihubEditorLauncher.sh

Thx a lot for your help again, I can open up the editor now…on a zero…unbelievable…

The zero is very, very slow, hope I can tweak it a little bit.
It was actualy only intended to run a static USB MIDI routing on this device for which I thought it would have enough power to make this in seconds. Patchbox is still my favorite for this task, maybe I can shutdown certain services.
I still haven´t figured out to make this work, but I will make another thread for that issue as you suggested

1 Like

+1 sounds like an awesome project @Kasper_Jordaens, would love to see a walkthru / tutorial post, as I’d love to try hacking this too! :slight_smile: