MODEP and pd concurrently

I’m using the excellent MODEP image with my pisound - all worked out of the box no issues. I’m now looking to start experimenting with pd. Is it possible to run pd alongside MODEP, or willI need to ‘stop’ MODEP/ use a fresh install/distro?

For example, I plan to use ny pisound as a guitar preamp/FX unit plus run a synth in pd. Is that possible?

1 Like

I just posted about this in a reply to another post. I was considering purchasing a sonuus brand guitar to midi converter to play synths in modep… albeit with limitations like only being monophonic and having some latency. I think pure data could be used as an intermediary to accomplish this as well. But I think doing so is going to require more hardware (like a second pisound). It would be super cool if running Pd patches in modep could be accomplished in the future.

Theoretically that’s possible, though not within the MODEP UI, and can be a bit difficult to get it right.

You’d have to install pure data in the MODEP image and configure Pure Data to use JACK for the backend. Once PD is launched, you’d have to make appropriate Jack connections so it goes to the speakers (or it should even be possible to make it go to some effect in MODEP) using command line tools, or set up a GUI in the image and use qjackctl or patchage to do that.

Cool! Is there a way to open a command line while running MODEP? Or how would I go about modifying the disk image to include pure data?

Should just need to connect a monitor via HDMI? Think modep image boots straight to a command line

Hey, you may use a remote shell (ssh) to connect to it from your computer, you just need to know the IP of the device. (it’s if you’re connected to its hotspot)

ssh modep@

Use ‘blokaslabs’ for password.

Or you can use a HDMI monitor and keyboard as @martyclark said.

1 Like

@Giedrius thanks. Installed pd on the modep image and have installed pisound app. When attempting to launch a patch (arp odyssey), I’m getting ALSA input/output errors (‘device or resource busy’) - assume this is because modep is connected. Although I will experiment with running pd with jack, if I stop the modep instance would I be able to launch pd with ALSA?

Yes, it’s because of MODEP blocking audio for itself. To run PD using ALSA, stop MODEP by executing:

sudo systemctl stop mod-ui
sudo systemctl stop mod-host
sudo systemctl stop jack

To start it again, use start instead of stop and execute in reverse order.

1 Like

Cheers @Giedrius that works easy enough for now. Last thing, although I eventually want to run pisound headless, would be useful to look at the pd patches in the gui. I had though the modep image is based on a raspbian image with no desktop? Any recommended options for using pd with a gui?

It’s built on top of ‘Raspbian Lite’, so any guide on getting GUI installed for it should be good to go:

Cheers @Giedrius managed to install LXDE which I’ll test this weekend.

For info, I also triedto instsll RPD but failed - as in packages installed but x server failed to start. Perhaps missing dependencies.