Test with newly installed MODEP


I just got a spare RPi3+ to test MODEP and proceeded to flash the latest image on a SD.

Everything is ABSOLUTELY vanilla. Just the RPi. No addituonal soundcard or whatever.

I tried to power up and login with SSH. No problem.

I tried to connect to with various browsers and devices, just to see if the masid MOD interface was showing up, but I could not.

Do I have to start something more before even seeing the interface? Do I have to add / config a sound card? Does MODEP even work with just the onboard soundcard of the Pi?


Hello, yes, you have to configure the output audio card to use - the image is preconfigured for use with Pisound. See https://blokas.io/modep/docs/Sound-Card-Setup/

If you plan to use the analog output of Raspberry Pi, use hw:0, 44100 for sampling rate and you’ll have to increase the buffer size to at least 512.

1 Like


Of course I plan to get an external sound card after my first trials to get accustomed to the system.

I suspected I had to configure something in regards to audio, but I was surprised that the interface didn’t show up at all.

I tried changing the configuration file as suggested.

The reboot semed successful, and jack and all audio stuff seems loaded correctly.

I can see the MODEP wifi endpoint after boot and I can login via SSH.

Still I’m unable to connect to

What is the output of sudo systemctl status mod-ui? Did you connect to the MODEP WiFi before connecting? You may run ifconfig and try using other IPs listed for http:// address (especially ones that start with 192. for example)

Output is code=exited, status=1/failure

I guess there’s something wrong, maybe in the config. Is there a log I can check?

The essential services are ‘jack’, ‘mod-host’ and ‘mod-ui’. If one of them is not running, the web interface won’t work. See the following link for commands to query their status and access their logs: https://blokas.io/modep/docs/Troubleshooting/

Hit the ‘end’ key on your keyboard to go to the very latest log lines.

Thank you for you help.

I double checked my changes to the service and remembered that I did not change the -p parameter to 512 for the jackd command.

I thought the change was needed only to avoid xruns, but it seems it prevents the daemon to start altogether. After setting it to -p 512 everything starts up and I’m able to connect to the web UI, connect some plugins and get audio (from the HDMI port). That’s enough for me to play around a bit with MODEP.

If I may, I suggest to update the MODEP documentation to include the complete configuration for testing MODEP with just the onboard audio. It’s true that it’s no means enough, since it lacks inputs, but I think it would be great to attract new cpotential customers, since they may try the interface before buying a Pisound.

1 Like

There will be an update to MODEP which will make this easier. :slight_smile:

1 Like

Since the MODEP update is announced quite long time ago, may I ask you if there’s a fast and easy way to update the mod-ui of the actual 2018 MODEP to the newest version from GitHub? I’m interested in the advanced Midi functions. Thank you.

No, there’s no easy way to do that, if there was, the update wouldn’t be taking this long. :wink:

Anyway, some very good progress was made on the update, stay tuned for release, we want to make sure everything works smoothly out of the box.

Btw, which advanced MIDI functions do you have in mind?

Thanks for your super quick response:)

On the actual mod-ui version i can now choose between “Device/MIDI/Control Chain/CV” and in the “Advanced” section now you can edit the “Range”. Generally the whole interface has made a big step further.

I know it because I tried to get the latest versions of mod-host and mod-ui running on my headless Raspbian. But sadly I only can start the mod-ui server with a fake connection because I failed on the mod-host installation. With “make” “make install” I get a bunch of errors and I’ve no idea how to fix it! I must admit that I’m quite a bloody noob at the Linux ecosystem;)

So finally I’m afraid that I have to wait for the official update because of the lack of my very limited knowledge. :disappointed::wink:

Two more questions please!

  1. Is there a limitation of audio inputs/outputs that MODEP can recognize if a multichannel soundcard is used?

  2. Is there a multi soundcard workaround possible? E.g. Pisound and my USB-soundcard together in MODEP for more audio ins and outs?

Thanks in advance for your reply.

The MOD UI shows whatever inputs and outputs are available in the Jack backend. Multichannel cards can be used, check Jack documentation regarding multiple cards.

1 Like

Perfect! Thank’s for your help.

Hey, the updated MODEP is available via Patchbox OS img: [Beta] Patchbox OS image 2020-03-14 (and MODEP) - it now has the MIDI settings too.

1 Like

Wow fantastic! Thank you very much for the info!