[Release] MODEP 2018-04-03


#1

Hi guys, a new MODEP image is available:

Torrent link: https://blokas.io/modep/image_2018-04-03-MODEP.zip.torrent
Direct link: http://www.mediafire.com/file/ekfxsw4rwzfsiz7/image_2018-04-03-MODEP.zip
Keeping the torrent client running after the download is much appreciated to help us share the image! :slight_smile:

Login: modep
Password: blokaslabs

Changes since 2018-01-22

  • Support Raspberry Pi 3B+ out of the box.
  • --period argument for Jack changed to -p 128 from -p 256.
  • Based on latest Raspbian Stretch Lite OS

Please report any issues you find.

The build files for generating the image are available here: https://github.com/BlokasLabs/modep-gen. Most of the plugins get built in ‘stage5’, pull requests adding more plugins are welcome! Also if you happen to find a better way to configure the services, etc…, let us know!

You may be able to access the MODEP server using http://modep.local whether you’re connected directly to Pisound WiFi hotspot, or your home router. This is done using mDNS service, however, for it to work on Windows 10 I had to install https://support.apple.com/kb/DL999?locale=en_US (search the net for details why). Up-to-date Mac and Linux systems may be readily able to use mDNS.

Enjoy!


#2

#3

Btw, the documentation for MODEP was updated for this version of the image: https://blokas.io/pisound/docs/MODEP/

Thanks to @BoaThor for providing some additions, especially in the debugging tricks section.

In case you have any suggestions or changes you’d like to see, you can share them via https://github.com/BlokasLabs/pisound-docs/wiki/MODEP


#4

Hi, and thanks for the update.

I’ve been testing the previous Beta (2018-01-22) and had problems with glitches using it as a synth (FluidSynthLead + MOD Lowpass filter + Phaser II + Stereo Delay), but was able to reduce the glitching by changing JACK to -p 128, instead of -p 256.

I did a clean install of the new image, and setup the same exact pedalboard and had much more glitching.
I’ve also tried changing to -p 256 and even -p 512 plus I tried changing the sample rate to 32000 but nothing seemed to fix the glitches.

So in that case the previous version seems to be better (on my system at least (Raspberry Pi 3 w Pisound)).

I would also love to see some of the MIDI Utilities included in the MODEP image, especially splitting the MIDI input into different channels (i.e. filtering out unwanted channels).

cheers,


#5

That’s odd, I can’t think of anything significant that changed and would cause this right now. I will try to play around with the same pedalboard setup.


#6

Thanks @Giedrius, it will be interesting to see what is causing these small clicks and glitches
(I can hear them in the “factory” pedalboard Organ as well, but not quite so much)

cheers


#7

Hi, I have tried the combination as you have described on RPi3 (not B+), and it seems fine to me, no XRUNS occurred, using default settings for jack.

Btw, with Pisound you should use only one of 48000, 96000 or 192000 sampling rates, they are the natively supported ones, others would require software resampling which takes up resources.

ExecStart=/usr/bin/jackd -v -t 2000 -P 75 -d alsa -d hw:pisound -r 48000 -p 128 -n 2 -X seq -s -S


#8

Thanks @Giedrius for checking this out;
now that I knew that this should be possible I looked at what else could be different, and all I could think of was the SD card and the PSU.

Turns out I’d been using the wrong PSU; I was certain that the one I had had a high enough Ampere rating, but I pulled out the wrong one from the drawer - it only was capable of 1A @ 5V. So when I replaced it with a 2A PSU the clicks and pops seem to have disappeared.

Thanks again for your help,

cheers,


#9

Yeah, power supply is playing a big role here. 2.5A power supply should be a default for PiSound + RPi 3, so better get one to get non-distorted sound :slight_smile:


#10

Hi, is it possible to provide a non-torrent link to the release? Not everybody are into torrents…


#11

Here you go: http://www.mediafire.com/file/ekfxsw4rwzfsiz7/image_2018-04-03-MODEP.zip


#12

Thanks @Pranciskus!


#13

Hello, I’m a new french user.
All is very well working for me on MODEP 2018-04-03.
The only bug (so far) is “AMP VTS Caps” is not working. This LV2 plugin is broken in this version.
Thanks for all.
Julien.


#14

Is anybody can reply please ?
I can’t use ‘Amp VTS Caps Plugin’.
I just want to know if another person has the same problem.


#15

Hello @jujudusud I can try it tonight, but I remember there were some plugins which were not working for me either. I will confirm if AMP VTS Caps is among these ones


#16

Hello again! the plugin itself does work for me! maybe just try to reinstall to whole package and see if that fixes the error. :wink: