[Beta] MODEP 2018-01-22

Either method is fine. USB MIDI might require less wiring as the USB connection is already on the Arduino itself. Have you seen https://blokas.io/pisound/docs/Example-projects/#pisound-with-diy-midi-controller?

@Enkerli That’s awesome! :slight_smile:

Do you remember the plugins you had issues with? I’ll take a look at those.

Hmmm, for me the glitches that were apparent with, for instance, the vocoder and pitch shifter, ‘went away’ with this image.

using the -p 128 (period setting for jack) as Giedrius suggested worked for me. Maybe that’d help?

Total newbie here. How do I access jack settings? do I go to the terminal prompt and input some code to pull up Jack setting? Sorry for the lame question I just need a little guidance. Thanks in advance

Ok very sorry. I now see the Instructions above.:see_no_evil:

So I had some time to play around tonight. The am synth is crackling bad and creating lots of x runs. I attempted to change to p 128 as suggested but when I tried to ssh I I was met with a demand for a password. blokaslabs didnt do the trick! anybody any other suggestions? Im running the beta image modep

Is it the first time you’re ssh’ing to it? How your ssh invocation looked like? The default user should be ‘modep’ and the default password is ‘blokaslabs’ as noted in the modep-gen config: https://github.com/BlokasLabs/modep-gen/blob/modep/config

Thanks for the help and patience. I finally got some time to relook at this. I was able to change the settings as suggested. Initially this causes my unit to become very noisy but after a power cycle the issue seems to have gone away. I looked at the am synth again and it still crakles badly when used in conjunction with the x42 midi sequencer. Lots of xruns and very high cpu usage. Is this normal behaviour for poly synth like this? Other reverb and speaker emulation sounded good with no crackling

Just after typing the last post I went back to playing the unit and that nosie had come back.power cycle fixed it again…

Been playing on it for the last hour or so… no re-emergence of that noise issue. No latency problems .sounds very like the p 256 setting i really cant tell any difference

Hey, thank you for your feedback! I’ll add ‘amsynth’ and ‘x42 midi sequencer’ plugins to my todo to see if they can be improved.

Ha! Just tried my MODEP setup again in preparation for this weekend’s Raspberry Jam (at Canadian Museum of Science & Technology). Not getting any glitch. So it must have been some other part of my setup. Sorry about that. And thank you for that card!

1 Like

Noon question here… using the modep image how do you preform a controlled shutdown?

Hold the button down and release after 5 or 6 MIDI LED blinks. Holding for 7 or more blinks will do nothing, giving an opportunity to cancel the shutdown.

Thanks I wasn’t sure if that incorporated into the modep image. I’ve tried that with a raspbian image and it worked perfectly. I must have my timing slightly out on this. I haven’t run the config script with modep as I presumed that the pisound was configured with mkdep because the button works without havin to run the curl but now I know how to ssh I’ll try to run that script to config from terminal and see

Actually it’s not based on the number of blinks, but the seconds that have passed. The MIDI LEDs should be blinking once per second.

I have just noticed that 4.14 kernel introduces a timing issue for the MIDI LED blinking - there’s random delays happening when attempting to signal a blink to the kernel module. The very latest 4.9 version does not have this issue. (Opened an issue here: https://github.com/raspberrypi/linux/issues/2412)

The Beta MODEP image is based on 4.9 kernel, so the LEDs should be blinking consistently, unless you have manually updated the kernel using sudo rpi-update.

Guys, this is absolutely amazing, thanks!!
I already have a MOD Duo as Pedalboard, now I have one as Synth :wink: thank you!!


A post was merged into an existing topic: How to connect to pisound/raspberry pi after modep install

I don’t see this release published here https://github.com/BlokasLabs/modep/releases, should it be?

Please see the reply here: [Release] MODEP 2018-04-03

1 Like