MODEP not booting on RPi 2 and USB sound card issues [Solved]

Hi All,

I’m trying to run the latest (2018-09-11) MODEP release on my Raspberry Pi 2 Model B Rev 1.1 but it won’t boot. The power LED is lit, but the SD card LED only blinks a couple of times and then stays dark. The attached display shows the Raspberry symbol and below it a cursor that’s not blinking.

What I’ve tried so far:

Re-downloaded the image
Tried older image (2018-08-31)
Used Ubuntu disks instead of Etcher to flash the image
Used different SD card reader
Used 32 GB SD cards from different manufacturers
Tested if Raspberry Pi boots with another Raspian image (it does)

The boot process seems to get stuck right at the very start, so I have no way to do any debugging or check any log files.

Anyone ever also had this issue? Any help appreciated.

Kept on trying to get MODEP to run, but to no avail.

Today I made my own build as described here

As with the other two images I tried, I get to see the Raspbian icon and the boot process halts, before I get to see the “Started Show Plymouth Bootscreen” line.

Tried to boot the image on a Raspberry Model A. Same result.

Copied relevant boot files (.elf, kernel, etc.) from one of my working Raspbian images to the MODEP card. Nothing.

Interestingly enough I ran the image in QEMU and it booted flawlessly.

Just to make sure I’m not running into faulty hardware or bad power supply, I also booted both Raspberries with another image and both started up as expected.

Has anybody an idea, what to try next?

Hey, could you try running it on RPi 3 or newer? I attempted running it on RPi 2 myself, but unfortunately the board is broken and won’t boot anything.

Hi Giedrius. Thanks for your reply. Unfortunately the Pi 2 B is the best I can offer, but I’m more than happy to help any other way.

Today I borrowed an 8 GB SD card, just to make sure that it’s not the 32 GB cards that are causing trouble. But still no boot.

I had a look at the Raspbian boot process to get a better understanding at which point the error occurs, but couldn’t find an answer. Maybe you can tell me what component paints the Raspbian logo?

I assume it’s still before the config file is parsed, because when I compare it with the boot sequence of my default Raspbian image, I get the Logo, then content from the config file and then the line “Started Show Plymouth Bootscreen”, which I guess tells that the OS itself is booting?

Non of the MODEP images I tried were booting on the Pi 2 B, nor the Model A. So I’m not really sure, if the hardware is the problem Then again it was booting in Qemu using kernel-qemu-4.4.34-jessie

Please let me know, if there’s anything I can do to support the case. In the meantime I will try to understand the boot process a little better.

Couldn’t help myself and bought a Model 3 B+ today. The latest MODEP image is booting flawlessly.

Please let me know, if you are you still interested in finding the reason why it wasn’t working on Model 2 B and Model A. I’m happy to help.

BTW, I swapped the kernel that came with your image with the one I used with Qemu (simply renamed it accordingly), but ended up with the rainbow screen. Thought that it would’ve been worth a try. Power supply was sufficient (5V, 2500 mA) and is currently used with the Model 3 B+.

I’m currently experiencing some issues with the USB sound card I’m using and when trying to connect do MODEP with my phone. Would you want me to discuss it in this thread, or rather open new ones for each issue? Thanks.

Hey, since 2018-08-31, a real time kernel was added to the image, this is likely the cause for it failing on RPi2. Could you try running [Release] MODEP 2018-04-03 on RPi 2?

This would be the last thing for you to try out, I’ll try to get a RPi 2 myself some way to be able to fix the issue of latest images.

For USB sound cards you usually have to increase the buffer, try using -p 512 -n 3.

If that does not help, please start a new topic :slight_smile:

Well done. You were right about the real time kernel. The provided image loaded like a charm.

And thanks for the hint with the USB card. Your settings added quite a bit of delay so I went with -p 256 -n 3. I found this setting on this helpful site, which I will link to, in case someone else stumbles over this thread.

Thanks a lot for your help and this incredible piece of software. Keep up the good work.

1 Like

Just a quick follow up on the delayed sound of the external USB sound card.

Turned out that the pisound-ctl service is enabled by default. If the card isn’t installed, the service is constantly restarting, which adds quite a bit of load to the RPi.

After disabling (sudo systemctl disable pisound-ctl.service) it and a quick reboot MODEP is delivering stable sound even with setting -p as low as 128 and -n 3.

1 Like

Thanks for pointing this out! We have updated the “Sound Card Setup” documentation section. :slight_smile:

1 Like