Dual-boot MODEP

#1

Hi! I just received my Pisound and can’t wait to have time to dig in to it!

It is my understanding from all the documentation I’ve read thus far that it is not possible to install MODEP in normal Raspbian, as to use it alongside other programs. As such, I was just wondering if there was a way to dual boot the MODEP version of Raspbian lite with the full version of Raspbian, so I can use to use either the MODEP configuration or other apps such as Carla or pure data.

Does anyone have any experience with this? At first I was thinking of having two separate micro sd cards that I could switch out, but it would appear to be cumbersome to disassemble and reassemble the case every time that I want to have a different OS configuration running.

Thanks again for this awesome project!

0 Likes

#2

Don’t think it’s easy to do. It’s not too hard to making Raspbian Lite into a full version of Raspbian, but it sounds like some of the required packages break MODEP.
Adding any kind of GUI stuff to my MODEP install tends to stop MODEP from working. There might be a workaround but it’d require a bit of fiddling.
So, Carla might be difficult. Pd is probably a different story. If you can run it headless, it might work alongside the other stuff from MODEP.

Have yet to get a case. Been swapping cards all the time. Maybe if you could get a hole in the case to insert the SD card?

0 Likes

#3

Have you looked at using Berryboot either with a big SD card or a USB Hard Drive?

http://www.berryterminal.com/doku.php/berryboot

1 Like

#4

Thanks for the suggestions! I finally got some time to dig into setup this weekend.

I tried Berryboot, loading regular Raspbian through Berryboots menu worked well, I was able to load the repositories, download all the software and updates.

I then tried the premade modep image, converting it to squashfs as per Berryboot instructions, but I get an error on mount (re-mount?) and it won’t even load. “Failed to start remount boot and kernel files systems.”

I then tried using the version of Raspbian Lite from Berryboots installation process and manually installing modep with the install.sh script. It looked like it was installing everything fine with the one click process, but then the mod-services wouldn’t start, and jack services were hit or miss; It would keep saying directory doesn’t exist when I’d try to start the services manually. The hotspot and a few other services seemed to start normally though. I don’t know if any of this has to do with how berryboot sets up filesystems or the kernel sharing aspect, but I think I’m going to throw in the towel on Berryboot for now…great gui though, would’ve been nice to use.

I was thinking I might try the NOOBS or PINN multiboot methods, but for now I might just table it and mess around with one platform at a time.

I’ve decided to leave the usb power side off the case because mine seems to be cut too thick, the charging cable doesn’t stay in securely. So for now it’s a bit easier to swap out cards.

Thanks again for the help and suggestions!

1 Like