Pisound not detected

Hi I, have a Raspberry Pi 4 that I’ve used multiple HAT’s. I just received my PiSound, and it’s not being detected.

How can I debug whether the card is DOA?

pi@raspberrypi:~ $ arecord -l
arecord: device_list:272: no soundcards found…
pi@raspberrypi:~ $ amidi -l
no sound card found
pi@raspberrypi:~ $ aplay -l
aplay: device_list:272: no soundcards found…

Hey, make sure that the connection is well between the Pisound and the Raspberry Pi, you may try mounting without the extenders, just to check it’s not the issue.

After booting, run dmesg to get the kernel log and please post the output here, so we can take a look at it.

Hi Giedrius, I’ve tried reconnecting it a few times w/o the extenders, and still had no luck. I’ve attached the dmesg output.

One note is that I did have a hifiberry hat installed prior to the pisound. So that “driver” is still being shown in the dmesg output.

dmesg.log (42.6 KB)

That’s most likely the issue. You must have some HiFiBerry specific changes in /boot/config.txt applied that must be disabled in order to use Pisound.

Yep, that was it. I had a “dtoverlay=” assigned to hifiberry. Once I removed it pisound is showing up correctly with “arecord -l”.

I appreciate the help…and apologies as I’m new to PI.


1 Like

No need to apologize, good to hear you got it working! :slight_smile: