Trying to get Moode Audio Player running with PiSound

Hi, I’m trying to get Moode Audio Player to work.

In the config of Moode there is a DTOverlay option for PiSound in the settings. I’ve selected this but I get an Alsa error and when I ssh into Raspbian the PiSound is not listed under aplay -l

I’ve run Dmesg and noticed:

7.519824] pisound: Searching for spi device…
[ 7.519843] pisound: Found!
[ 7.596086] pisound: Reading card info failed: -22
[ 7.596186] pisound: pisnd_spi_init failed: -22
[ 7.596297] snd-rpi-pisound: probe of soc:sound failed with error -22
[ 7.712175] cfg80211: Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’
[ 7.856873] brcmfmac: F1 signature read @0x18000000=0x1541a9a6
[ 7.886762] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[ 7.887084] usbcore: registered new interface driver brcmfmac
[ 7.916379] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt failed with error -2
[ 8.153823] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[ 8.153948] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[ 8.154806] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Oct 22 2019 01:59:28 version (r723000 CY) FWID 01-3b33decd
[ 9.867285] random: crng init done
[ 9.867308] random: 7 urandom warning(s) missed due to ratelimiting

Does this mean anything? I’m sure it does!!

Is there an option to not set any DT overlay? Pisound has a built-in EEPROM that provides the necessary Device Tree information. The dtoverlay option was only necessary for a handful of beta-test version Pisounds. :slight_smile:

Well the config for Moode is here

It gives the option for either a number of named devices - PiSound isn’t included - or dtoverlay.

So I don’t think so - unless one of the other devices is compatible.

Moode Audio seems like a decent project, it would be good if I could get it to work!

I should add Moode comes as a pre compiled image based on Raspbian.

I tried installing PiSound but it failed.

I can’t find any simple location to add in a configuration for Pisound in the project, I’ll try contacting moOde developers.

Did they get in touch with you?

Hey, yes, unfortunately they didn’t code support for audio hats that get identified and loaded automatically via the ID EEPROM, and won’t disable autoloading either. The only way to use I²S audio cards seems to be to specify a .dtbo overlay to load.

There’s still probably ways to make it work though. Could you post the entire dmesg output?

Maybe we could give it a dummy .dtbo that would trick it into working. :slight_smile:

Oh right!
Here is the dmesg output.

Don’t stress too much though - I could always try a USB soundcard. I’m currently only using a streaming service through an average hifi with really poorly placed speakers in my living room.

I do want to improve this set up though!

So the PiSound DT overlay that I specified in the Moode interface - where is that loaded from? And why doesn’t it work? Always keen to learn!

It looks like the project is running a quite old kernel. The Pisound’s driver code had changed since then, could you try running this command and rebooting, and getting new dmesg output?

sudo rpi-update

This may break the system though, especially if the latest kernel depends on some deb packages which are not installed, you may want to backup first:

Make a copy of all of the files on the Boot partition of the SD card to your computer (that contains files like bcm2711-rpi-4-b.dtb, kernel7l.img). If after updating the kernel, the system won’t boot up, try copying all of the backed up files back to the Boot partition of the SD card.

Still boots up after rpi-update! Here is the dmesg output.

Looks better but pisound doesn’t show up in list of alsa devices. Or would it do that anyway?

Or do I need to install pisound drivers?

Does Pisound work when running a regular Raspberry Pi OS or Patchbox OS?

I’ve been running it with Volumio for a couple of years. I switched to Moode and it doesn’t work.

If I try to play music I get an alsa error. aplay -l does not return the pisound device.