Pisound - no sound/ no signal

Hi

I installed pisound and everything worked fine.
Even after installing fan-shim everything was ok.
But after some time I realized there is no audio output anymore.
I repeatedly checked the GPIO contacts, but nothing changed.
The device is properly recognized via aplay, arecord and amidi.
But the speaker-test returned with an error
speaker-test 1.1.8

Wiedergabe-Gerät ist sysdefault
Stream-Parameter sind 48000 Hz, S16_LE, 2 Kanäle
Verwende 16 Oktaven rosa Rauschen
Rate ist 48000 Hz (angefordert: 48000 Hz)
Puffergröße von 128 bis 131072
Periodengröße von 64 bis 65536
Verwende maximale Puffergröße 131072
Perioden = 4
gesetzt: period_size = 32768
gesetzt: buffer_size = 131072
0 - Vorne links
1 - Vorne rechts
Schreibfehler: -5, Eingabe-/Ausgabefehler
xrun_recovery fehlgeschlagen: -5, Eingabe-/Ausgabefehler
Schreibfehler: Eingabe-/Ausgabefehler

Moreover, the input channel on the pisound board should work
properly as I realized that the red led starts to flash when an input
overlaod occurs.

Using an osciloscope I can’t measure any signals between pin 39 and 40 of the GPIO pins.

Concerning the power supply I am using the standard power supply
which should yield 3A actually.

Any help or hints are greatly appreciated.

Hi, are there any errors reported in dmesg?

Hi, below the output of the filter dmesg

dmesg | grep pisound
[ 4.512071] pisound: Searching for spi device…
[ 4.512124] pisound: SPI device not found, deferring!
[ 4.512165] pisound: pisnd_spi_init failed: -517
[ 4.557775] pisound: Searching for spi device…
[ 4.557795] pisound: Found!
[ 4.686946] pisound: Detected Pisound card:
[ 4.686961] pisound: Serial: PS-0VCAZCN
[ 4.686973] pisound: Firmware Version: 1.03
[ 4.686985] pisound: Hardware Version: 1.1
[ 4.686996] pisound: Id: 1e9315385735333436112a06
[ 4.690515] snd-rpi-pisound soc:sound: snd-soc-dummy-dai <-> fe203000.i2s mapping ok

Thanks for your help

This output seems fine. How are you starting the speaker-test? Can you try starting it using this command line:

speaker-test -c2 -r48000 -Dhw:pisound

I get the same results as already mentioned.

Maybe some device is blocking the transfer?
In the output settings a webcam device USB 2.0 camera is to
be seen despite there is no camera connected anymore.
How can I remove this device?

In case it’s in use, you should get a ‘busy’ error instead of ‘I/O’.

Have you made any changes to your /boot/config.txt file that could interfere? Could you just in save the output of dmesg, and attach whole contents as a file?

no.
I found a section on /boot/config.txt which is presented below.
It should be automatically inserted while installing the usb-camera

[pi4]

Enable DRM VC4 V3D driver on top of the dispmanx display stack

dtoverlay=vc4-fkms-v3d
max_framebuffers=2

Here is the requested output

out.log (27.2 KB)

Could you try disabling these changes? Not sure if they could have an impact or not.

There’s an error reported in the log output:

[  691.430772] bcm2835-i2s fe203000.i2s: I2S SYNC error!

It means the I²S peripheral failed to establish sync with Pisound’s ADC and DAC. This could be impacted by PCM_FS and PCM_CLK GPIO lines. You may inspect those pins on your board, and see if there’s any damage or missing components around them.

Thank you very much for your help.
I checked the respective pins, checked and even improved the soldering.
I can’t find any damage on components in the vicinity of the pins.-
But nothing changed.

Is there a change to send the card to you once more again for maintainance
within the garanty time span?

After all I installed pisound on my Raspi 3.
And it worked. Therefore, the error is triggered from my
Raspi4 board. Maybe you can give any hints for testing
or approving the functionality of the board especially
the I2S.
Thank you very much for your support. I appreciate it.

Do you mean the Pisound works fine with your Raspberry Pi 3 board, and at the same time Raspberry Pi 4 board is having issues?

Yes, indeed.
Everything works fine with Pi3 board.

Interesting. It could be that actually your Raspberry Pi 4 has one or more of its GPIOs damaged. There are some utilities to test it, with no hat attached: https://elinux.org/R-Pi_Troubleshooting#Testing

Are you using the same SD card on both boards? If not, you may try a fresh install of the OS with Pi 4 as well, just in case it’s some software issue, but it looks more like a hardware one.

Thank you very much for your efforts.
I already made a fresh install but with the same results.
I agree that it may be that some of the GPIO ports are damaged.
I will test it as soon as possible and send the results to you.

1 Like

I did the test with gpiotest. Here are the results:
Skipped non-user gpios: 0 1 28 29 30 31
Tested user gpios: 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
Failed user gpios: None
Anything seems to be ok.

Here are some new findings.
Furthermore, I investigated the signals on the gpio pins with piscope
Pin 20: mosi shows a constant signal flow
After a reboot I select pisound as default device and
speaker-test -c2
Now signals are to be seen at Pin 21 clk.
But, when I issue the command the second time
both signals vanish and the same error message is issued as given above.

Pin 20 is ground :slight_smile: Or do you mean GPIO 20 pin PCM DIN (physical number 38)?

These I²S pins should be transmitting information while audio input or output is being produced:

The SPI pins are used for MIDI, if Pisound board is detected, then they are fine.