[Download] Midihub Editor 1.11.4 & Firmware 1.11.6

This update focuses on further fixing and improving stability and connectivity issues, reported in these threads:

Also, Transform pipe now has context-sensitive parameter name and values for Data Source 1 & 2 parameters which didn’t make it to the previous 1.11.3 update. :slight_smile: It should be pretty natural to use now.

Note for macOS users - the Midihub Editor->Preferences option moved to Device->Settings, to be consistent with Editor versions for other OSes.

1.11.4 Editor Downloads

1.11.6 1.11.7 Firmware Download

Firmware Upgrade Guide

See here: [Download] Midihub Firmware 1.11.4. Make sure to make the memory backup with the current editor version you have. We recommend flashing the new firmare with the updated editor, due to connectivity improvements. :slight_smile:

Detailed Changelog

  • Fixed incorrect dropping of Note Off messages when transforming Note On messages in Replace mode.
  • Fixed Sync Error 106 occurring when duplicating or undoing / redoing whole pipeline delete.
  • Fixed MIDI mapped parameter unmapping dropping all mappings for the CC control in some circumstances.
  • Fixed Randomizer pipe to handle Pitch Bend messages correctly.
  • Fixed Transform pipe default config to be Note Velocity to CC value.
  • Fixed undo & redo of pipeline delete causing a crash in some circumstances.
  • Improved connectivity between Midihub and the Editor on macOS and Windows.
  • Fixed selection tracking issues.
  • Moved Midihub Editor->Preferences to Device->Settings on macOS.

All good ! download, installed Editor, firmware…
On to the fun part; play, experiment :wink:


Updated the editor but now I get stuck when I try to connect the midihub. It prompts me to update to 1.11.6 but it doesn’t show as connected?


You have to update the firmware as well.

Ok now the device appears in firmware upgrade mode but when i flash i get the error: “Unexpected error occured while flashing the firmware, code -1, stage 6!”

Any ideas? Am I doing something wrong? I had firmware 1.11.3 and editor 1.11.2 before I started with updating the editor

And it seems stuck in firmware update mode… Any reset procedure i can try?

Which OS are you using? Please retry a couple of times.

I got the same error. I ended up reflashing 1.11.5 and then tried 1.11.6 again and it worked. I am on Win 10.

Worked after a while! On a win 10 device

Since backing up everything on the device is part of the instructions for updating firmware (and the firmware update wipes everything), it is very inconvenient that your post recommends updating the editor first, which then makes it impossible to connect to the hub to execute that backup without first wiping the device with the new firmware. Anyone who doesn’t want to lose their device contents will then have to reinstall the previous version of the editor.


Thank you for noting this, I didn’t think of that, sorry! :slight_smile:

Anyway, we plan to improve the firmware upgrade flow in a future version, but first we intend to iron out any serious issues reported.


Talking about what gets save when > “Export Everything”

  • Microtunnings don’t get saved, and so the Presets that have the Micro Scale pipe “reset to default”

Edit: Above is NOT true. Double checking and thanks for looking at it Giedrius.
Microtunnings get saved when “Export Everything”.


That’s great to hear, thanks!

No need to apologize, I didn’t mean my comment to come off as a complaint. :+1:

1 Like

That’s odd, it is supposed to get saved. These dumps should contain the 8 presets, all of the microtunings and the settings of Midihub. We’ll look into that, thank you for reporting it. :slight_smile:


Ok, @Keyman confirmed via PM that the memory import issue is fixed and it’s working properly now. :slight_smile:


Just wanted to thank you for also providing an appimage for Linux! It works like a charm. :+1:


Never mind. Got it.

1 Like

I get the same thing are we supposed to update the firmware before updating the editor?

how do I update the firmware when you have to do that via the flash firmware in the editor and I have tried both 11.2 and 11.4.
11.2 connects but the flash firmware is greyed out and 11.4 wont connect unless the new firmware is installed or is there another way to install the firmware without using the editor?

You must enter the bootloader mode - power the Midihub on while holding down its button.

1 Like