MODEP: problems with presets switching and midi program change

Hi, I’m new in Raspberry Pi and not very fond in programming; I’ve installed Patchbox OS to run MODEP as a multifx for my guitar: audio works with no problem. The issue concerns MIDI: I’ve made a 8-switches arduino foot controller to send midi bank and program change; the midi messages work (I’ve monitored them on windows with a MIDI viewer), but when I connect the controller to Rasberry pi and start MODEP nothing works as it should: my intentions is to change presets inside a bank (and in future add a function to change banks, too) but when I press the switch on MODEP nothing happens - the preset remains the same. I’ve tried to change on arduino sketch the midi channel from 16 to other values but nothing happened. I’ve no idea on how to make it works (probably due also to my poor programming skills).
I’m sorry to open up a new topic about this but I hope someone here may help me find a solution.

1 Like

Hey @gonzo.ganzo welcome to the forum.

It’s a known issue, it will be probably fixed with the next release which will include MOD 1.10. Please have a look at the following topicl: About Program Change (again) - #4 by Giedrius

1 Like

Hey @aFunkyBass thank you for the answer; I read the topic: I didn’t understand if by turning off the web interface the pc messages could work; anyway I tried this and still not working. then I suppose the only solution is to wait for the new realese, am I right?

The problem is that MOD software is not responding to PC messages, so the web GUI has nothing to do with that.

One solution could be to use the scripts provided by MODEP to control the pedalboard library. In particular the script /usr/modep/scripts/ lets you load the pedalboard number provided as a parameter or switch to the next/previous pedalboard set you saved.

I know it’s not the simplest solution as you have to do a little hacking and programming to capture PC messages and call a system script, but it’s the only workaround I can see at the moment.

1 Like

I’m sorry for taking so long to answer, but I’ve been busy these days.
I understand, as I said I’m not very confident with hacking, but I can learn. otherwise I’m afraid the only solution is to wait for the new realease.
Thank u very much :wink: