Issue in Pedalboard change using MIDI Program Change

Congrats for this amazing piece of software in the first place.

I would like some help from you guys if possible. Modep just does not respond to pedalboard changes using Midi program change on the specified channel.

I am aware of the midiChannelForPedalboardsNavigation under the /var/modep/profile5.json file
and I was even able to change snapshots and use control change messages for general purpose with success.

It seems that everything works but only pedalboard changes does not.

Does anyone has faced this issue or could help me troubleshoot this?

Thank you once again


I’m having the same problem, made a thread here:

How were you able to switch snapshots? I can’t get that working either.

I messed with the profile5.json file and this is what I discovered:
When I set it like this:

    "midiChannelForPedalboardsNavigation": 15,
    "midiChannelForSnapshotsNavigation": 14,

I can switch pedalboards from the pedalboard library (not from the banks) using a program change message sent on channel 15 (note that in the json file the midi channels are 1-16, not 0-15).
I can switch snapshots when I send a program change on channel 14.
It appears that you want to have these on separate channels so they don’t interfere with each other.

I tried to experiment with getting bank selection to work, but I had no luck…
Tried these combos:

  • CC0 0 and CC32 0
  • CC0 1 and CC32 1
  • CC0 1 and CC32 0
  • CC0 0 and CC32 1
  • CC0 1 and CC32 127

Is this functionality broken for now?


Well it took me some time to figure it out, but I think I understand how this works, thanks to Sendmidi which made it easy to try different things quickly. One minor problem is that if I use the graphical UI on localhost (the pi itself) or remote, pedalboard switching through midi is not working. Even if I close the session, it still doesn’t work. After restarting mod-ui (and no graphical interface) midi switching is working again. After some trial and error, this seems to work:
Selecting bank 2, first pedalboard:

cc 0 0 cc 32 1 pc 0

Selecting bank 2, second pedalboard:

cc 0 0 cc 32 1 pc 1

I have not made many pedalboards yet, so my test is a bit basic, but this seems to work. So you have to combine the two CC-messages with a PC-message.

Did you keep those parameters ? in profile5.json ?
(in my case by default it was 0 and 0)

Do you know where to find a tudo for this modep midi control ?

Thanks a lot.

Hi arno_b,

If the channel is 0, than the functionality is off. 15 and 14 are used by default in some setups. I don’t know why these defaults differ. Anyway, you have to choose two different midi channels and program your midi device you want to use for switching/navigation to use those exact two channels with the right PC- and CC-messages. I use 15 and 14 because it seems to be the most common, but in the end it depends on your own setup and preferences. If you have a lot of midi devices, it takes more structure/planning to do this correct.


Ok it is pretty much clear !! I have to play with those parameters until it works !
Do you also know if I can switch pedalboard using MIDI but with WEBUI connected or do I absolutly need to test this blindly ? :cold_sweat:

At the end, I still don’t understand why this is set like this (by default) and why it is so difficult to find out how to setup modep ! :sweat_smile:

Thanks a lot, it will be faster to find out with your information !

You’re welcome! Yes, it is not straight forward. Especially the fact that pedalboard switching is not working when the UI is active or even has been active. So after using the web interface you need to restart mod-UI to get midi switching of the pedalboards working again. You have to test it blindly as far as I know. That is why I used some software to test it (Sendmidi is freeware btw), with Sendmidi I can quickly test different midi messages. Selecting a pedalboard or snapshot is relatively easy, only a PC-message on the right midi channel. Selecting a bank and a pedalboard in a bank is more taunting. I hope to have some spare time this weekend to get it to work in a sensible way.


As you said, it is working if webUI is not connected !
It is not very convenient because it is a blind testing, BUT, it is working ! :slight_smile:

Here is my conf:

I am getting closer :sweat_smile:

Thanks and Thanks again !

1 Like