Change Patches in Bank with es-8


#1

Is there a way to change the patches via an external source? I’m using the boss ES-8, I can’t see where you might set the channel for the pisound using MODEP, basically, the hope is I could set the channel to let’s say 2 and then have the patch line up from within a bank just go in order pc1, pc2, etc so I can go directly to a patch without pressing the button


#2

Hi, see here: https://www.boss.info/us/support/knowledge_base/205975985/

Use program change messages on MIDI port 16. Looks like it opens the pedalboards in the order they appear in ‘Pedalboards Library’ section, and I had to restart MODEP after adding a couple of more pedalboards for the program change messages to open them.


#3

Strange I tried that, I will have to check my connections, so where you able to access directly threw to a patch or do you still have to click threw the library?


#4

Sorry I’m defenatly missing a step, I just did a fresh install of MOD and took out all the other midi devices, and go directly out from the es-8 to the in on the pisound card, did all the steps and not getting any results, could you break down all the setting you used, I’m a bit confused when it comes to midi, I tried a few different midi settings from the es-8 but not getting any results at all??


#5

Oh also shouldn’t it be changing the pedalboards from within then banks library ? The boards in the pedalboards library would be odd and you can’t reorder them in that library, just trying to make sure that’s not the issue, maybe some screen shots of what you did would be helpful, thanks for your time!


#6

I didn’t change any settings in MODEP - I just tried flashing the latest MODEP image into sd card, and it immediately was reacting to Program Change messages on the 16th channel.

I thought that’s going to be how it works, but looks like it changes to the pedalboard based on the order they appear in the ‘Pedalboards Library’, and new pedalboards can be switched to only after restarting…

Btw, you can use the Pisound App to switch between pedalboards in the first bank, or you can even come up with a custom solution, you can use the modep-ctrl.py script for that: https://github.com/BlokasLabs/modep-btn-scripts/blob/master/modep-ctrl.py


#7

I see, I was asking about the settings for the es-8. I still get no midi response, but just so I understand once I set the midi channel to 16 which is basically the device ID then can I directly select a board with a midi PC number like board 5 would be PC5 or how do I access a board directly, If I still need to step on a pedal 5 times to get to board 5 that would defeat the purpose of trying to control it with the es-8 altogether, are you using an es-8 when you are doing this or a different device?


#8

Ok got it working, not sure what went wrong but I put my old card back in with an eirlier version of MODEP and it works as expected, I’ll try re flashing that new card and see if I can figure it out. Thanks for the help non this!!


#9

So another issue, if I have multiple midi devices I run into problems with the midi data getting thru, setup I have tried are…

  1. ES-8 midi out > to Pisound > in > out to GT-100
    Pisound gets PC changes on channel 16 but nothing gets thru to the GT which is set to channel 1, omni on or off.

  2. ES-8 midi out > to GT-100 > in > out to Pisound
    Pisound is responding to channel 1 and channel 16 PC changes.

I’m guessing the Pisound omni midi is on, I can’t seam to find where I would change those settings, is that possible?


#10

In the first case you’ve tried, try connecting the MIDI connection in MODEP from left to right to get MIDI data flowing from Pisound’s input to the output.

In the 2nd case, do you mean Pisound reacted to program change messages on channel 1, or other kinds of messages on ch.1? When I’ve tried, MODEP only reacted to program changes on the 16th channel…


#11

Yes so I did not see the midi settings, so now going to MODEP first works, problem with that setup is when I restart the pisound those midi connection are not saved, the connected wires show up on the pedalboard after I reselect the midi in out setting from the bottom bar but they are not selected after restarting, this would be great but if I try to go headless this would be a concern.

On the second set up, I’ve tried any and all combinations of midi settings from the GT according to their documents, the signals are either triggered to both or ignored by the MODEP.

GT is on channel 1
MODEP is on 16 ( can this be changed? Just curious ).


#12

There’s ‘navigateChannel’ setting in /usr/local/modep/banks.json, you may try changing it from 16 to another channel (restart system or mod services afterwards), but it’s weird that it’s associated with a bank, while it opens pedalboards from ‘Pedalboard Library’ section regardless of their order in the bank.


#13

I don’t think it is bank related? Maybe, So it is receiving the midi like you said, the MODEP is connected and basically is channel 16 and the boards are like you said accessed in the pedalboards library and you can call them up directly using something like PC 5 to get to the board 5th on the list.

For some reason when I put the MODEP in line after the GT it is getting the midi changes also, so I set say peddle 1 on the ES-8 to go talk to channel 1(GT) and set PC 2, the GT goes to the assigned PC2 on its list but for some reason the MODEP joins in and pulls up the pedalboard 2, I’m wondering if maybe it’s Omni setting is set to receive all PC changes I know the GT you can change it which I’ve tried both ways and it seams to be doing as it supposed to.


#14

Hi so I was able to change and save the midi channel, I set it to 15, after connecting it back up it still responds to 16 and not at all to 15 any ideas why?


#15

Oh ya I get what your saying, that’s why I’m wondering what the Omni settings are, which is still strange because if I put the PS first in line it responds to 16 and aperently 15 but not 1 which I have the GT set to??


#16

The MIDI functions, including OMNI modes, are responsibility of the software, not all software implements the full MIDI specification, so, I’d guess that MOD DUO software does not support handling of the OMNI modes. Also, I guess there’s some bug with program change messages somewhere in MOD DUO software, because we can’t get it to listen to a different channel and it loads pedalboards from the library instead of the bank…

I think you might be able to get MIDI THRU capability in ES-8 midi out > to Pisound > in > out to GT-10 if you manually set up a script to run at startup to make the MIDI THRU connection using aconnect. You may manually try it out, first rung aconnect -lio to get the list of available MIDI ports, example output:

client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
client 20: 'pisound' [type=kernel,card=1]
    0 'pisound MIDI PS-2DES12E'

So to get MIDI IN on Pisound to go to the output, you have to run aconnect 20:0 20:0

Run man aconnect for detailed documentation of the command.


#17

I found on modep wiki in the fixed section of an update that they had a bug with the midi channel not displaying the correct channel in the banks midi selector, which is hidden for the pisound but it’s just hidden with display:none so you can expose it and see they are connected to the banks originally, I’m guessing in the build for the pisound they bipassed some of the code the mod pedal uses while hidding features that are not practical, I borrowed a friends pisound to test two pisound chain and we noticed the midi issue, I will try your suggestion, I’m a bit of a terminal noob but I’ll give it a shot thanks.