ARP behavior question

Hello everyone :slight_smile:

When I play a chord with ARP on, I first hear the chord and then the arpeggiator.
I’m wondering if there is a solution to make the arpeggiator play instantly.

Here’s a video to explain what I mean : Midihub Arp behavior - YouTube

Thanks for your help!

Hi, can you post your preset? The notes might be getting through without Arp applied through some other route.

@klutio Yes, If you’re using your ARP in conjunction with your PCtoCC patch, you need to filter out stuff on line 2 so you don’t get duplication

1 Like

It’s an interesting effect however. :smiley:

Here is my patch :slight_smile: Midi Arp Behavior.mhp (1.1 KB)

I tried to filter on line 2 but it didn’t work :frowning:

line2 IRIG>notes>BEATSQUEEZ (Chord)
line4&9 IRIG>notes>vA>(Arp pipes)>BEATSQUEEZ (Arp)

(the PCtoCC lines go to HX so assume they’re not going to affect any of this)

Is that your Kaoss KP1 in the vid?

2 Likes

thanks!! what is vA ?

it is my KP1 yes, I love it :slight_smile:

vA = Virtual A (sorry, slipped into abbreviations)

I have a KP2 from way back -though I have to confess the more recent times I’ve pulled it out I’ve used it more as X-Y ( & button state) input for Midihub than an FX unit

So you sorted out the Chord getting through?

It is working thanks a lot !!

Hmmm I’ve never thought of using it as a midi controller, thats a good idea :slight_smile:

1 Like

EDIT : added notes to patches

@klutio I took a look at it and was thinking I’d need to cut out everything not associated with the ARP and its mappings. As well as setting up a Midihub with your cabling.

Then it occurred to me…
…if your 104 is coming from the last line’s Transform_Replace then the Bypass_Off is not happening before the note hits it.
Might this explain your situation?
Try changing it to a Transform_Before, then Filter out the still-existing note.
Let us know whether that solves the problem.

(Useful test: I note that ARP Bypass is also mapped to MIDI HX Ch1 CC103; is ARP OK when unBypassed this way?)

Thanks for the solution, but it’s not working…
I don’t have that problem using MIDI HX Ch1 CC103 though…!

I don’t have that problem using MIDI HX Ch1 CC103

That would suggest to me it is related to the Transform. Just as test, try restricting the range that triggers the Transform_Replace–Bypass_off to just a few notes, then hit one of them just before you play your ARP chord of notes outside the Transform range. My bet is it’ll work!

If I’m right (and you want to just adapt your strategy) then one solution would be to Delay your played notes a few m/s so the (undelayed note>Transform_Replace–)Bypass_off has time to happen before the delayed note gets to the ARP. If this is acceptable, I’d suggest pinging JoeyButters as he’s done a lot with Delay recently; he’d be able to advise more quickly on the exact settings.