Arpeggiator not working as expected

I have a problem with the arpeggiator in that it doesn’t seem to work as expected. I am using a Keystep Pro going through MIDI A to Virtual MIDI A, I have a Clock also going to Virtual A and Virtual A going to MIDI out A to a Microfreak. When I set the Arpeggiator to “UP” it works fine, no problem. When I set the Arpeggiator to “DOWN” I get nothing at all. When I set it to combinations of UP and DOWN I just get the equivalent of “UP”. Setting the arpeggiator to “RANDOM” just results in an occasional note being played which seems to be totally independent of the Octave Range or Time Division.

I have tried putting a filter in and setting it to only keep Note On and Note Off events (from advice given in another post), that doesn’t work, I’ve tried disabling the clock out on the Keystep Pro, that doesn’t work either.

Any suggestions?

I have been doing some testing regarding my problem in the previous post and have now tried three different midi controllers all seem to have the same issue so I don’t think its a controller problem. I also managed to identify that the problem only occurs when I use MIDI channels 2 to 16. When the controller and the synth are set to MIDI channel 1, everything works fine, except Random Mode. Set to any other channel, the problem occurs. It is not only the Arpeggiator that doesn’t work on channels 2 to 16 either. I ran an LFO and that worked fine on Channel 1 but not at all on channels 2 to 16. This sort of defeats the object of the Midihub if I am unable to use it’s functionality on any other channel than channel 1.
I’m beginning to think I have a faulty unit.

Hi, please attach the preset saved as .mhp exactly as you have it and please describe what notes / controls do you operate on the MIDI controller that’s providing notes to ARP.

Ideally, it’d be great if you could record a raw MIDI clip of the controller input you produce into Ableton or similar software, and attach the exported .mid file here, so we can reproduce the same input easily on our end.

From what you describe, it’s very unlikely for the unit itself to be faulty, it’s either a software bug or some unobvious behavior, we’ll get to the bottom of it.


Thanks for the response. The preset is a very simple Arpeggiator. As I mentioned it works fine when sent through on Channel one (although Random doesn’t work as expected), but the down Arpeggiator doesn’t play at all on any other channel. As for attaching a Midi file, there isn’t much point as the Arp fails to play anything when set to down, even if I just play Middle C, E, and G.

I have attached the .mhp file as requested.

I could probably send a video of the problem in action if that would help.



Midihub 2020.06.07 17.24.27 (Preset 6).mhp (104 Bytes)

Ok, I have reproduced the issue, indeed it doesn’t work on other channels than 1. :slight_smile:

We’ll get it fixed!

1 Like

Ok, fixed it, get the new firmware containing the fix here: [Download] Midihub Firmware 1.11.2. Let us know how it goes. :slight_smile:

Hi there

Thanks for the super quick response to the problem. The Arpeggiator seems to work fine on all channels now, and the Random option also works fine. Still one more issue. I put an LFO in, to control the Cutoff on my Arturia Microfreak, and all the wafeforms work fine on Channel 1, but again the LFO doesn’t work at all on any of the other MIDI channels.

I hope this one problem as quick to fix as the arpeggiator one. Sorry to keep finding these issues!!



No worries, we’re happy you’re finding and reporting issues we’ve missed. :slight_smile: It’s a lot of functionality and cases to cover.

Please create a dedicated topic for the LFO issue with steps how to reproduce and share the .mhp file you’re using.

1 Like

Sorry if this is a silly question but I am still having issues with the arp. My issue is more related to timing. The arp does not consistently trigger when I hit a key and when it does, it does not always start on the first note of whichever arp mode its on (in the preset below its down). I tried triggering the clock to restart on each key I intend on pressing by mapping the clock on/off to the key but it still does not work as reliably as I would like. Thanks for the help and the great product.

Arp - Issue.mhp (198 Bytes)

Here is a screenshot of the resulting midi. Note that I had to edit the pipes a bit from what I uploaded in order to get the midi to come through from the Arp and Chord.

Hey, the notes are played on the quantization grid, if it happens that the playing position is already after the next beat, it will miss the first note, so the notes should be played slightly ahead of time.

We’ve received a good suggestion for playing the notes anyway as soon as they are played, and to correct the positioning along the way, until it fits the grid again. Once we do that, there shouldn’t be first missing note anymore.

Could the ‘note out of time’ situation be caused by swing parameter?

1 Like

Thanks. I’ll give that a try. Is there a sequence of pipes I can use to “quantize” my input to the clock?

I just tried it after receiving my MIDI Hub today. I can only get up and random to work. Everything else is just up. I also just upgraded the firmware. I’m on 1.11.4

There is a newer Firmware and Editor, please I suggest upgrade.

Thanks, I’ll check it out tomorrow.

OK, I’m still having the same problem, so maybe it is my misunderstanding of how this works. The only way I can get it to go down is to select a negative octave range. It doesn’t matter whether I select up or down at that point as it always goes down if I select a negative range and up if I set a positive range.

So maybe I’m missing something? Random seems to work.
Midihub 2020.07.24 07.58.55 (Preset 1).mhp (115 Bytes)

We’ll check it out. By the way, it might be a good idea to put a Filter pipe after FROM USB A pipe, to keep only ‘Note On’ and ‘Note Off’ messages, just in case there’s any interfering messages coming in from that input.

Yes, I will filter other uninteresting incoming messages. Still new to this so thanks for the reminder!

I just tried your preset, and it seems to work fine, also with Octave Range set to 0. Are you pushing down more than a single note? If not, it would just repeat the same note over and over, without any movement.

1 Like

Well of course with single octave it just plays one note.
When +1 Octaves it alternates between two notes, hard to tell in which direction but with re-trigger note it starts at base note.
With +2 octaves it starts at pressed note, goes up one, goes up another then goes back to starting. It doesn’t matter if I have it set to Up or Down
With -2 it starts at pressed not, goes down one, goes down another and then goes back to starting. It doesn’t matter if I have it set to Up or Down.

Maybe my confusion is what it does when only playing one note. With more than one note it seems quite different and probably is right.