[Release] MODEP Updates

This is the actual error - some apt properties changed on Raspberry Pi APT servers, run sudo apt-get update --allow-releaseinfo-change, then try to activate the module again.

@Giedrius I ran the apt-get command as instructed. When I then ran “patchbox module activate modep” command I still get the error below. One thought? I’m on Buster but do I need to be on Bullseye?

Manager: modep.module version mismatch 1.8.0 vs 1.12.0
State: /usr/local/patchbox-modules/modep/ module installed False → False (skip)
Manager: modep.module install script found: /usr/local/patchbox-modules/modep/install.sh
Hit:1 Index of /raspbian buster InRelease
Hit:2 Index of /debian buster InRelease
Hit:3 http://apt.blokas.io rpi InRelease
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
modep-btn-scripts is already the newest version (1.2.0-1).
modep-ctl-scripts is already the newest version (1.8.0-1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
modep : Depends: modep-mod-host (>= 1.12.0) but 1.8.0-2 is to be installed
Depends: modep-mod-ui (>= 1.12.0) but 1.8.1-1 is to be installed
E: Unable to correct problems, you have held broken packages.
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/patchbox/module.py”, line 622, in _install_module
‘Failed to install {}.module via {} script’.format(module.name, os.path.join(module.path, module.has_install)))
patchbox.module.ModuleError: Failed to install modep.module via /usr/local/patchbox-modules/modep/install.sh script

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/bin/patchbox”, line 33, in
sys.exit(load_entry_point(‘patchbox-cli==1.0’, ‘console_scripts’, ‘patchbox’)())
File “/usr/lib/python3/dist-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/lib/python3/dist-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/usr/lib/python3/dist-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/lib/python3/dist-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/lib/python3/dist-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/lib/python3/dist-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/usr/lib/python3/dist-packages/click/decorators.py”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/usr/lib/python3/dist-packages/patchbox/modules/module/cli.py”, line 136, in activate
ctx.obj.activate(module, autolaunch=False, autoinstall=autoinstall)
File “/usr/lib/python3/dist-packages/patchbox/module.py”, line 636, in activate
File “/usr/lib/python3/dist-packages/patchbox/module.py”, line 625, in _install_module
‘Failed to install {}.module via {} script’.format(module.name, os.path.join(module.path, module.has_install)))
patchbox.module.ModuleError: Failed to install modep.module via /usr/local/patchbox-modules/modep/install.sh script

Ah, your SD card image is based on Debian buster, MODEP seems to depend on some later packages from bullseye. You should use this OS image: [Beta] Patchbox OS image 2022-05-17

Done! I installed the new patchbox image and when I enabled MODEP it installed the new 1.12 version! Now time to copy my plugins and pedalboards from the old setup.

1 Like

When I configured Patchbox I set it to boot up to Desktop mode. However upon reboot with the my Pi4 plugged into a monitor via HDMI after the bootup sequence I’m not getting the desktop. Note that I do see the bootup sequence on the monitor but it goes on standby eventually. Any ideas?

Does it work if you set it to boot to console, then run startx to start the graphical environment?

Just tried that, still not getting a console.

What is the last thing you see during boot up? You may have to remove quiet from /boot/cmdline.txt to see them. Also try htting Ctrl+Alt+F1, and the rest of the F_ keys to see if anything happens.

I tried the Ctl+Atl+F_ keys and nothing. On a whim I unplugged/plugged in the HDMI to the same port and it came right up. Not sure why, I’ve always had weird issues with my Pi4 and HDMI so it’s probably not a Patchbox issue.

I was able to run startx and log into the desktop. I also brought over the LV2 plugins and pedal boards from the older version and it’s up an running! Now just have to plug in a bass and make sure the sound is working!

And MIDIZilla works just fine with the new version too!

Well at first the pedalboards weren’t saving when I made changes then I remembered I needed to change the ownership of the pedalboards. Fixed that.

Unfortunately…the Guitarix GxCabinet doesn’t seem to be working and that is a deal breaker for me. To get this working is it simply rebuilding the plugin?

Pedals need their ownership fixed too, if you havent already.

Good call. I forgot to do that. However after a reboot I still can’t use the Guitarix GxCabinet. Can anyone else confirm this plugin is working or not in the new version?

Hello, everyone!

We wanted to let you know that we have released a small update for MODEP (1.12.2-1).

This update includes a few changes to the Patchstorage section of the MOD-UI - a search feature and plugin data caching. From now you can easily find the plugins you want to install, and navigation is faster, even for older Raspberry Pi models.

Most notably, we have revamped the Patchstorage backend to support both LV2 bundles and multi-file uploads. Combined with patchstorage-lv2-builder and patchstorage-lv2-uploader, this update completes an essential toolkit necessary for LV2 plugin developers to start sharing their creations on the site.

In the coming weeks, we will be reaching out to developers to encourage them to host their plugins on Patchstorage, and we will be uploading more plugins ourselves - you can find a couple of new ones already!

To add, this update is required to continue using the MODEP Patchstorage integration, as the Patchstorage API schema has been changed.

To update to the latest version, simply run the following command:

sudo apt update && sudo apt install -y modep-mod-ui

As always, if you have any ideas or questions or encounter any issues, please let us know!



Good day, everyone!

A minor update for MODEP was published (1.12.4-4). With this update, we are dropping the BETA label for the 1.12 release. Few changes:

  • An automatic update check. Once a new version of MODEP is available, a tooltip will pop up at the bottom right corner of the UI.
  • Patchstorage integration fix when not all available plugins were displayed in the UI (Thanks to @jtemple967 for reporting this).
  • A Donate button is displayed in the Patchstorage plugin modal window for plugins whose authors accept donations. Let’s show them some love!

To update to the latest version, simply run the following command:
sudo apt update && sudo apt install -y modep-mod-ui

Also, there are two significant areas where we would like to ask for the community’s help.

One - plugin requests. If you don’t see a specific plugin on Patchstorage, please post a request here - [Patchstorage] Plugin Requests, and we will do our best to publish them on the site.

The other - is plugin testing. All newly uploaded plugins on Patchstorage are marked as work-in-progress. We invite you to share your testing results here - [Patchstorage] Plugin Updates & Testing. If a plugin works as expected, we will mark it as ready-to-go, and if not, we will investigate the issues.

With your help, we can ensure all of us have a delightful experience messing around with MODEP!

That’s it for today. Cheers!


Thank you for that voodoo that you do. I’m having a lot of fun messing around with MODEP.


Quick note - if anyone wants to get notified once there is a new plugin published for MODEP, you can subscribe here - LV2 Plugins | Patchstorage


Is there going to be support for 64-bit LV2 plugins going to be coming to Patchstorage in the future?

There is already support and 64bit plugin’s uploaded

Good news, everyone! MODEP 1.13 update is here!

The most noteworthy change - from now on, MODEP supports the Aida-X LV2 plugin!

In short, Aida-X is a neural model player developed by the Aida DSP team, capable of loading realistic amp, cab, dist, drive, fuzz, boost, and eq neural models! For more details about Aida-X, visit their official website at https://aida-x.cc/. Additionally, Leo Gibson has produced a comprehensive video showcasing the plugin - Aida-X and MOD Dwarf: is this a game changer solution? Better than NAM and ToneX? - YouTube. You can support the Aida-X development here.

You can download neural models to play around with here - List of shared models - Model Sharing - MOD Audio Forum.

To update MODEP, simply click on the update icon in the bottom right corner of the MODEP user interface. Alternatively, you can run the following command via the terminal: sudo apt update && sudo apt install -y modep-mod-ui.

To end with, I want to express tremendous gratitude to @jtemple967 and @deathbeard. @jtemple967 is responsible for the fast-growing plugin list on Patchstorage - more than 270 plugins already! And @deathbeard made this very update possible!

And as always, please let us know if you have any ideas, questions or encounter any issues.



This is amazing! Thank you.

1 Like