[Release] MODEP Updates

Good news, everyone!

After our letter to the MOD community and the MOD team’s suggestions that Blokas should try to add more value to the whole MOD ecosystem, we did dive into it. One thing led to another, and after 2 weeks, we have something to showcase! :blush:

MODEP 1.12 Update

First of all, MOD-UI for MODEP was updated to the latest version - 1.12. As James pointed out on the MOD forum, having the latest UI version should increase the perceived value of the MOD platform.

Second, the integration with Patchstorage! From now on, MODEP users can share and install different plugins easily. The integration is still quite basic and needs further polishing, but it is a great start, and we hope it will open broader participation in the MOD ecosystem from LV2 plugin developers to adventurous Raspberry Pi users.

The update is already live for Patchbox OS! SSH into your Pis and run:
patchbox update && patchbox module activate modep

Future Plans

The LV2 platform on Patchstorage is currently dedicated to 32-bit LV2 plugin builds for Raspberry Pi, and projects like Zynthian and part of the pi-Stomp devices (@drandaji) can already utilize it.

Having said that, as the MOD insolvency process can take more than a year and their cloud infrastructure question hasn’t been addressed yet, we are ready to expand Patchstorage API and UI to support multiple file uploads so that integration with Patchstorage would benefit different hardware platforms and owners of MOD devices directly. Once the integration is tested, we will start the discussion with the MOD team.

And regarding Pedalboard sharing - if there is an interest, we could implement that too! We will have to investigate a bit more on the best ways to handle missing plugins and user authentication, but if the interest is high, we will add this to our TODO, so let us know!

Help Wanted

From this MODEP release, we won’t be including already pre-built plugins with the MODEP package. From now on, all the plugins will have to be downloaded from Patchstorage or compiled by the users themselves.

That’s why we are looking for some assistance with the project - compiling, uploading, and maintaining plugins on Patchstorage, helping out with build and contribution guides, and community support aspects both here on the forum and on Patchstorage.

If you want to help out in one way or another, PM me or @Giedrius.

That’s it for today!

P.S. Some screens from the update!

2022-12-14 - [Release] MODEP Updates - #38 by Pranciskus
2023-02-22 - [Release] MODEP Updates - #43 by Pranciskus


@Pranciskus this is fantastic! So just to be clear:

  • We can run the update commands you cited on a current install of Patchbox OS & MODEP 1.10?
  • After running the update command will the installed plugins be wiped out and we’ll have to reinstall from Patchstorage?
  • Will our pedalboards from 1.10 be brought over during the upgrade?

For the record, I actually prefer to download the plugins. So many of the plugins in 1.10 don’t apply to my needs so it will be nice to just have the ones I need installed.

Thanks for the update and can’t wait to try out the new version!

Yes, you don’t need to flash a fresh Patchbox OS image, just run the command on your current setup.

Already installed plugins won’t be deleted.

All pedalboards should remain, but we haven’t tested this extensively. Proceed with caution.

We have uploaded only 75 plugins, so you won’t find all of those you are currently using. We hope our community will help us out with maintaining plugins on Patchstorage.

1 Like

Can I download the modep 1.8 lv2 plugins somewhere? I wast able to get the 1.12 to install on an older patchbox image and rewrote the sd card without backing up the lv2 plugins :frowning:

sudo apt install modep-lv2-*
sudo cp -r /usr/modep/lv2/* /var/modep/lv2
sudo chown -R modep:modep /var/modep/lv2
sudo chmod -R 775 /var/modep/lv2

Thanks a lot.

Unfortunately, I get the following error:

The following packages have unmet dependencies:
modep-lv2-calf-dbgsym : Depends: modep-lv2-calf (= 0.90.3-3) but 0.90.3-4 is to be installed

I’ve dropped the unnecessary dbgsym packages from our repo, please try the above again, but first do sudo apt update

Thanks, this fixed it and now I have all my pedal boards working. Thx again :smiley:


Great news. Thanks for all the work. Semi-stream of conciseness questions:

  • Is there any advantage to doing a 64-bit native build on a RPi4?
  • Is it possible to download source code and do a 64-bit native build?
  • Will 32-bit plugins work with a 64-bit build, or will all the plug-in need to be rebuilt too?

There is definitely a gain to 64bit os, but you’ll have to compile your own rt kernel…
The source code for modep should work on 64bit if you compile each part. No 32bit plugins won’t work on 64bit. Hope this helps


Thanks a lot!!!

Hi all, I am trying to switch between pedalboards using Program Change at CH16 without success.
I am using a touchOSC controller running on IPAD. It’s able to control pedals by CC but sending PC does not affect the pedalboard change. Is it possible that this issue could depend from the new UPDATE?

1 Like

I followed your steps but no plugins show up in modep. What can I have done wrong? The folder exists with all the plugins inside.
Thanks in advance

1 Like

I had the same issue and had to power cycle (unplug, replug) the Pi. Plugins now show up.

Thanks for your reply,
I was too impatient. cp command gave an error but i didnt notice.
Im a linux beginner :stuck_out_tongue:


Initially I have zero plugin show up, now I have all my plugins in the section “Other plugin” (cf. photo). Each one has the status “Installed”, but when I click ton the section “Installed”, there is no one (cf. photo) :confused: : any idea ?

Only the plugins installed from Patchstorage will show up in the Installed tab. The ones installed manually using Giedrius’s instructions above, will show up in the Other plugins tab.

Maybe you have suggestions on how we could rename the sections to make it more clear?

Sorry it took me a while to test the upgrade but I bit the bullet today. Before I did any of this I made a copy of my SD card and I’m running the update on the copy instead.

So I ran the two commands as directed. The “patchbox module activate modep” command crashed with the following:

Manager: modep.module version mismatch 1.8.0 vs 1.12.0
State: /usr/local/patchbox-modules/modep/ module installed False → False (skip)
Manager: modep.module install script found: /usr/local/patchbox-modules/modep/install.sh
Hit:1 Index of /raspbian buster InRelease
Get:2 Index of /debian buster InRelease [32.6 kB]
Hit:3 http://apt.blokas.io rpi InRelease
Reading package lists… Done
E: Repository ‘Index of /debian buster InRelease’ changed its ‘Suite’ value from ‘testing’ to ‘oldstable’
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/patchbox/module.py”, line 622, in _install_module
‘Failed to install {}.module via {} script’.format(module.name, os.path.join(module.path, module.has_install)))
patchbox.module.ModuleError: Failed to install modep.module via /usr/local/patchbox-modules/modep/install.sh script

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/bin/patchbox”, line 33, in
sys.exit(load_entry_point(‘patchbox-cli==1.0’, ‘console_scripts’, ‘patchbox’)())
File “/usr/lib/python3/dist-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/lib/python3/dist-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/usr/lib/python3/dist-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/lib/python3/dist-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/lib/python3/dist-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/lib/python3/dist-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/usr/lib/python3/dist-packages/click/decorators.py”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/usr/lib/python3/dist-packages/patchbox/modules/module/cli.py”, line 136, in activate
ctx.obj.activate(module, autolaunch=False, autoinstall=autoinstall)
File “/usr/lib/python3/dist-packages/patchbox/module.py”, line 636, in activate
File “/usr/lib/python3/dist-packages/patchbox/module.py”, line 625, in _install_module
‘Failed to install {}.module via {} script’.format(module.name, os.path.join(module.path, module.has_install)))
patchbox.module.ModuleError: Failed to install modep.module via /usr/local/patchbox-modules/modep/install.sh script

This sounds like the issue I had a while ago here: [Beta] Patchbox OS image 2022-05-17 - #7 by BoxOfSnoo

See the responses there, maybe that will get you past that.

1 Like