Orac 2.0 for the Raspberry PI

#1

Current release : Beta 2 (18 Apr 2019)

a quick overview of what’s possible with Orac

New features and overview of Orac 2.0

Getting Started with Orac 2.0

release video for the Raspberry PI including install instructions

Beta: so Im labelling this as a beta, but it could also be thought of as a pre-release.
the idea is to get your feedback whilst I have some time to focus on Orac.
so if you use Orac, I highly recommend you install it and help me refine it.
after the release, Im likely to take a bit of a break from it (its been very time-consuming lately) - so the beta is a bit of a time-limited opportunity.

as well as feedback I also really appreciate if we could build up some presets that I could include as part of the final release. I think this would be really cool for new users.

Once released this will become the main support/feedback thread for PiSound Orac 2.0

for users upgrading to a new version of orac/mec, you should do the following:

11 Likes

#2

Excellent work @thetechnobear! Can’t wait for the Raspberry video. :blush:

2 Likes

#3

Nice… thanks for all the hard work

1 Like

#4

Looks great!! Thanks for your efforts. Can’t wait…

1 Like

#5

in prep for tomorrow, here is what you can expect in 2.0

(moved video to top post for 'completeness ’ :slight_smile: )

6 Likes

#6

ok, its PI Day… top post has video showing you how to get hold of it :slight_smile:

other news…
once the releases are all out of the way, Im going to do a ‘getting started with Orac’ video, to help get new users ‘hit the ground running’ - as i think theres perhaps a few gaps in current videos.
(for now, Id recommend my first Orac 1.0 video, and loopops video, see my playlist… for more of an overview - its still very relevant, even though its for the Organelle)

8 Likes

#7

Done! Very thorough explanation, thanks!
Now I’m stuck here. I’ll have to watch and rewatch all other videos I guess :smiley:

2 Likes

#8

Hey Mark thanks so much for doing this.
I’ve gone through your setup video - everything should be kosher but i’m guessing the hostname needs to be changed in the PD patch.
I’ve tried “patch” and “patchbox” and that isn’t working so what could it be?
cheers
Lloyd

1 Like

#9

You can use the IP address of the Raspberry Pi. See: Raspberry Pi: Find Raspberry Pi's IP Address

1 Like

#10

Thanks Giedrius.
I found the IP address via my router however it’s still not connecting.
Might try again in the morning :confused:

0 Likes

#11

Yup I think I’m stuck at the same point. I’ve put the raspi’s IP in the Lemur client but nothing happens. Maybe I have to enter a port number? It currently says 0. No idea. Sorry for being a complete newbie. :slight_smile:

0 Likes

#12

To be able to connect, MEC has to be running. It’s off on startup.

If using Pisound, click the button once.

If not using Pisound, run sudo systemctl start mec

To check the currrent status, run:

sudo systemctl status mec

1 Like

#13

Mark, thank you for this! I’m playing a bit with it and it’s fantastic.

Really a milestone of open source audio software.

1 Like

#14

Hi @thetechnobear, I followed the video but I get an error when I try to connect my Push 2 to pisound/orac.

sudo systemctl status mec

mec-app[2835]: MecApi_Impl::init
Apr 11 16:57:23 patchbox mec-app[2835]: oscdisplay initialise
Apr 11 16:57:23 patchbox mec-app[2835]: listening for clients on 6100
Apr 11 16:57:23 patchbox mec-app[2835]: KontrolDevice initialise
Apr 11 16:57:23 patchbox mec-app[2835]: KontrolDevice::init
Apr 11 16:57:23 patchbox mec-app[2835]: kontrol device : listening on 6000
Apr 11 16:57:23 patchbox mec-app[2835]: KontrolDevice::init - complete
Apr 11 16:57:23 patchbox mec-app[2835]: KontrolDevice::new client 127.0.0.1 : 6001 KA = 5
Apr 11 17:07:03 patchbox pulseaudio[1471]: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
Apr 11 17:07:03 patchbox pulseaudio[1471]: [pulseaudio] module.c: Failed to load module “module-alsa-card” (argument: "device_id=“2” name=“usb-Ableton_AG_Ableton_Push_2-01” card_name=“alsa_card.usb-Ableton_AG_Ableton_Push_2-01” namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties=“module-udev-detect.discovered=1"”): initialization failed.

I’ve tried hotplugging it and stopping the service and restarting it.

Any tips?

0 Likes

#15

It seems the Pulse Audio backend may be interferring with Push. Try disabling pulseaudio backend:

echo "autospawn=no" >> ~/.config/pulse/client.conf
pulseaudio -k

and retry starting MEC. Show us the new output of the systemctl status.

0 Likes

#16

pulseaudio -k

E: [pulseaudio] main.c: Failed to kill daemon: No such process

0 Likes

#17

I haven’t still installed Orac, but yesterday I tried to use MODEP with touchOSC and it works only connecting the iPad directly to MODEP WiFi LAN

1 Like

#18

this happens when the osc address is not correct.

note: you need to reload the lemur project for it to pickup the new address !!
(this catches everyone out!)

the network name is
patchbox.

note: the full stop after patchbox, it won’t work without it.
(that or as @Giedrius pointed out you can use the ip address)

lemur template already has the port, its 6100.

(its just its defaulted to organelle as a hostname)

@Taubaland , odd , my push2 was ok a couple of days ago when I tried… (I’ll check it again)

@Makrotulpa, yes hostname needs changing in the msg box , where indicated.
(patchbox. works for me)
… make sure you have mec running
single click of button, and the leds will flash once to show its activated.

1 Like

#19

Thanks! I got it moving, but everything is empty :smiley:
What did I do wrong now? (Sorry, I’m such a PITA)

2 Likes

#20

Woohoo!
Thanks for all the good work, @thetechnobear! Nice rollout too!
Sorry for all my nagging over the past couple of years. I never meant to be a burden and I didn’t necessarily feel entitled to get answers. But I’ve been waiting for pretty much this.

The RasPi video gets me pretty excited. Wasn’t really clear on how easy it’d be to install and run. Also wasn’t so clear what kind of functionalities ORAC itself had. The softsynth sounds pretty good! Will be quite useful with my wind controller. And maybe even with MPE? That’d be just plain great!

So, the version of MEC included should work with my Eigenharp Pico? If so, that’d be just plain awesome.

What’s funny is that I’m on vacation, away from my main musicking setup. Thought about bringing one of my Pisound-HATted Pis, but ended up not doing so, for a variety of reasons. They say absence makes the heart grow fonder. I’ll be quite fond of my Patchbox Pisound by next Wednesday! :wink:

Again, Mark, thanks for all the good work!

2 Likes