ORAC - How to make it useful?

Orac 2.0 for the Raspberry PI does not explain how to access the user interface.

Currently it is useless. Just irritating drum sounds

sudo service orac stop is useful, but defeats the point!

Well it defeats the whole Orac too. :smiley:

You have to use a remote client: https://patchstorage.com/orac-remote-control-patches/

Watch TheTechnobear’s videos on how to set them up.

Thanks for the help. I did watch his videos, missed that aspect. Perhaps it was because I watched all the “introduction” videos… Perhaps I am stupid, who knows? How could I tell!


PD Client
the PD client will need routeOSC install, 
this is part of 'mrpeach', which can be installed via deken (see find externals in PD menu)

Lemur Client
install as normal for lemur patches
you will then need to setup the OSC connection on the project preferences

preferences -> Osc Targets

OSC 0 : host <insert hostname> : port 6100

if your using an organelle, hostname will be organelle, or organelle.local
for patchbox its usually patchbox.  (note the full stop) 
if this fails, use the ip address :) 

That is the README from the patch for controlling Orac.

It is not very helpful, I have Pd running, but I have no idea what routeOSC, mrpeach, or deken are. I looked up lemur and it is a hadoop client (!!?)

I will go looking, but it is a very difficult learing curve, and I cannot help thinking that a little bit of care on the part of the author would be very helpful.

For example installing the patches, and/or connecting any of the above mysteries is not part of the video on that page - for sure up to seven minutes as I let it play out whilst I type this. (Edit: I see lemur, as a application for a iPhone is mentioned at 10 minutes)

I appreciate that this is a labour of love, and I am not furious, but I do nthink it is worth pointing out that the barrier to entry here is much higher than necessary.

What is the host OS you’re using to run the remote patch? The Orac Remote Control patch itself comes with the necessary externals in the ‘externals’ folder, built for 32 bit Windows, Raspberry Pi, and mac OS.

Are you getting any errors after opening the patch? If not, just edit the hostname and click the bang button above.

I had no idea that Orac is supposed to be controlled remotely. Seems odd as all I need is on the PI. So the question: What is the host OS you’re using to run the remote patch? is one I can only just understand.

I am using Patchbox on Raspberry PI 4 with PIsound

When I install Orac from Patchbox->Modules I get the drum sound and nothing to indicate what else I should do.

Since then I have learnt how to use pure data and tried again installing Orac and loading various patches (sorry I did not keep notes - unsure what patches I tried to load) but nothing seems to work. I cannot get started.

I watched those introductory videos and they left me completely baffled and feeling rather stupid.

I am a computer programmer and musician, but until now have kept the two separate. Life changes etcetera and I have decided it is time to combine the two. I am looking for a system to use to go between midi controllers and the sound card. I am very early on a learning curve and everything seems so hard!

Thank you for your attention

In that case, run the remote control patch on Raspberry Pi itself, use for the IP.

  1. Download and extract the patch from https://patchstorage.com/orac-remote-control-patches/
  2. Open the file pd/main.pd from the extracted location in Pure Data
  3. Enable Edit Mode (Edit->Edit Mode)
  4. Change the hostname in the patch (organelle by default) to
  5. Disable Edit Mode (Edit->Edit Mode)
  6. Click the bang button [o] to the right of the [loadbang]
  7. The patch should retrieve the current state from ORAC and will let you work with it.

If that does not work, let us know what is printed in the main PD window’s log.

1 Like
LISTEN:: listen 6101
warning: 14 removed from poll list but not found
connecting to port 6100
SEND:: connect 6100
recv: Connection refused (111)

It took me a moment to find the hostname! A wee bit obscure but I found it.
But the load bang gives above output and no change in screen

Something is not listening on 6100?

orac is running:

service orac status

● orac.service - Run Orac at boot
   Loaded: loaded (/etc/systemd/system/orac.service; enabled; vendor preset: enabled)                          
   Active: active (running) since Mon 2020-12-28 21:13:46 GMT; 10min ago                                       
 Main PID: 21893 (pd)
    Tasks: 14 (limit: 4033)
   Memory: 4.7M
   CGroup: /system.slice/orac.service
           ├─21893 /usr/bin/pd -rt -alsamidi -nogui -audiobuf 4 mother.pd main.pd                              
           └─21904 /usr/lib/puredata/bin/pd-watchdog

Dec 28 21:17:33 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:17:35 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:17:41 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:17:43 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:21:40 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:21:42 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:21:44 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:21:46 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:21:48 patchbox pd[21893]: watchdog: signaling pd...                                                  
Dec 28 21:21:50 patchbox pd[21893]: watchdog: signaling pd...                                                  

MEC must be running too:

sudo systemctl enable mec
sudo systemctl start mec