Jack isn't registering USB interface audio inputs

Hi !

I’ve been using Patchbox OS with both ORAC and FoxDot (Supercollider) on my RPi 4 with great results, but I realised that for my ORAC setup, I’m not getting any audio in from my Focusrite Saffire 6USB. So, I ran startx and opened Patchage and I see this:

As you can see, the Saffire’s 4 outputs are connected (listed under “system” playback), but there are no capture channels registering under “system”. Why is this? Surely if it finds the soundcard and connects to the outputs, it should find the inputs too?

I’m not sure if it’s related or not, but it also looks like rather than the outputs of “Pure Data” linking to system playback, it shows the outputs of “PulseAudio JACK Sink” instead. But at least the output of ORAC is loud and clear.


Hi, what are the outputs of:

aplay -l
arecord -l


So, it looks like the Pi/OS isn’t finding the Capture input at all. Any idea why, or how to find out?

I have max_usb_current=1 in my /boot/config.txt which I believe is because this is a USB 1.1 soundcard, could that be affecting it? I also though that I changed the otg_speed but folks say that is supposed to be in cmdline.txt which it isn’t, so I must have removed that option. Weirdly also the Pi won’t respond to USB keyboards after boot which could be related.

Yes, you should first solve the USB issues. Are you using the regular kernel or realtime one? The latter is known to not work well with USB.

I’m using the realtime kernel I believe, as I read that the regular kernel wasn’t good for audio.

Any hints on how to solve unresponsive USB devices on RPi ? Any suggestions would be really appreciated as I basically have 0 leads on how to solve this

Use regular kernel, it’s ok for audio too. :slight_smile:

Ok, I will try that, thank you!

Edit: just as a final test, I tried my Zedi10FX as the interface instead, and now it picks up the audio inputs AND the other USB peripherals started working. So so weird. I guess my old interface doesn’t have a 2nd life after all!

Just as a double post update, I switched to the standard kernel, and it didn’t fix the USB keyboard issues, but I SSH in and arecord now lists the Saffire 6 inputs! Thank you @Giedrius :smiley_cat:

1 Like