Getting no sound output from Raspberry's built in analog output

I tried doing a fresh install and again have nothing. Frustrating as I was able to get the demos to run earlier and now I can’t even get that! Steps I have gone through (in case I am missing anything).

  1. Flashed Image on SD Card
  2. Went through initial setup (choose Orac, did my wifi, choose console environment, jack was set to the built in audio jack with sampling rate 44100, buffer 512 and period 3)
  3. Loaded updates with

sudo apt update

  1. Updated the patchbox software with

sudo apt install -y patchbox-cli

  1. Enable MEC on booth with

sudo systemctl enable mec

  1. Wanted to install the web interface (as I was using it earlier) so installed pip

sudo apt-get install python3-pip

  1. Installed the web interface through the curl command listed on that page
  2. Rebooted
  3. No sound

I checked the jack and MEC are both active.

journalctl -u orac
gives back (I just copied this from my previous post and deleted lines that are no longer in there which is why the times are off)
May 20 19:28:18 patchbox systemd[1]: Started Run Orac at boot.
May 20 19:28:19 patchbox pd[629]: opened alsa client 130 in:1 out:1
May 20 19:28:19 patchbox pd[629]: error: JACK: cannot connect input ports system
May 20 19:28:19 patchbox pd[629]: error: JACK: cannot connect input ports system
May 20 19:28:19 patchbox pd[629]: KontrolRack: device = midi
May 20 19:28:19 patchbox pd[629]: client connected pd.osc:127.0.0.1:6000

EDIT: I tried flashing a new SD card with patchbox os and tried one more time. I tried following everything in the tutorial and then this comment chain (which I wrote up in my notes below) and I’m still not getting any sound :confused: wish I knew what I had done this morning to get the demo working.

  1. Flash Image
  2. Go through setup (selected Console did not select orac)
  3. sudo apt update (load updates)
  4. sudo apt install -y patchbox-cli (update underlying patchbox software)
  5. Selected orac as module
  6. sudo systemctl enable mec (Sec orac to start automatically)
  7. Reboot
  8. sudo raspi-config (Changed keyboard layout)
  9. sudo systemctl start mec
  10. Choose puredata as module
  11. Reboot
  12. Selected orac as module
  13. sudo systemctl enable mec (Sec orac to start automatically)
  14. sudo systemctl start mec
  15. patchbox update
  16. select orac as module
  17. Reboot
  18. Nothing

Well… Seems like this isn’t an Orac issue but a patchbox os issue. I tried starting from scratch again, didn’t choose any modules or perform any updates and I am unable to hear anything! I’ll move this over to a discussion thread where this is more relevant.

Looks like occasionally the Jack service may end up starting after Orac has started on system boot - Jack should be running before Orac gets started. I think I can get this fixed in patchbox-cli.

Possible another issue, is that one the very first run when Orac gets installed, for some reason it does not load the demo preset.

In the mean time, both can be worked around by restarting orac:

sudo systemctl restart orac

It seems like this is a JACK issue. If I try launching puredata from the desktop without any module selected I get the same error I see when run journalctl -u orac which is

JACK: cannot connect input ports system:midi_capture_1 -> pure_data-01:input0
JACK: cannot connect input ports system:midi_capture_2 -> pure_data-01:input1

It seems like someone else had similar issues in October of last year. I am somewhat confused since I had this working yesterday morning for a brief period of time!

I tried loading a SD card with vanilla raspbian and was able to hear audio play.

I am new to Patchage but in that thread I linked it commented about the Patchage setting. When I open Patchage I see that midi_capture_1 is red in a box by itself labelled “system” and not connected to anything. midi_capture_2 is in a different box labelled system along with midi_playback_2, midi_playback_5, midi_capture_5, midi_capture_6 and none of those are connected to anything and all are red. If I try dragging a patch from midi_capture_1 or _2 to the pure_data input0 or input1 the connection is not made.

Just to be safe I will put on here that all of this is attempting to get sound from the onboard 3.5mm jack.

Let me know if there is a different thread I should move this too or start a new thread since this seems to be moving away from Orac.

I’ve moved the discussion to this new topic.

The system MIDI capture should correspond to the hardware MIDI devices. Do you have any connected? The message is just a warning and shouldn’t affect audio. Some part that is launching PD (or PD itself) is attempting to connect to the first 2 MIDI ports on the system, but it fails, because they are not attached.

The linked thread is about audio through HDMI. Are you trying to get audio out from analog jack or HDMI?

Started fresh just to make sure before testing this. Went through setup, choose no modules, choose desktop and setup on board sound as shown on website then rebooted. I hadn’t test HDMI before as the monitor I was using didn’t have speakers so moved over to a different setup.

Once I booted up I was able to get sound to play through HDMI over YouTube but not analog jack. I was able to use the sound controls to select between analog and HDMI. When analog was selected I did not hear sound through HDMI.

Next step I enabled Orac, rebooted and didn’t get any sound until I used the sudo systemctl restart orac command and now I hear drumbeats as I type this and can control playing through my MIDI Keyboard! But it is only though HDMI. Interestingly, if I choose to change the sound to analog using the desktop environment Orac continues to play via HDMI. Thoughts on next steps?

Try using the command I found here, it should force analog output. Also we stop orac and jack before it and start again after:

sudo systemctl stop orac
sudo systemctl stop jack
amixer cset numid=3 1
sudo systemctl start jack
sudo systemctl start orac

Bad news and good news. Bad news is that the commands you gave me did not work. After forcing the analog output and restarting jack/orac the sound still goes through the HDMI. Good news is that I found a workaround for now. If I start the raspberry pi disconnected from HDMI the analog jack functions appropriately. This explains why the analog jack was initially working for me, my micro HDMI to HDMI converter did not arrive until the afternoon and before that I had been ssh-ing into the pi. If you care to investigate further I am happy to complete testing on my end but I can live with having to start unplugged. Eventually I will run this headless anyways.

Not sure what else to try… As this system is based on Raspbian, any information on it applies also to this OS build, including sudo raspi-config which has a ‘force audio through 3.5mm’ somewhere in its advanced options, but it ends up doing the same amixer command. Maybe you could figure out if it’s possible to disable the HDMI audio interface completely, so the only possible output is the 3.5mm.

That is a good idea to look into completely disabling the HDMI audio interface! What is interesting is that vanilla Raspbian does not have this issue, I can launch with an HDMI connection and freely switch between analog and HDMI sound out. Perhaps some patchbox or orac function is hogging the ability to switch? Idk… I’m more of a mechanical engineer than a programmer but if I get bored this weekend I will start digging into it!

1 Like