[SOLVED] Distorted audio with usb soundcard

[SOLVED] I suppose that this is a bit of a noob problem to have, but I’ll leave the post up in the hope that it helps someone else in the future… I was able to to fix the issue by ignoring the recommended value of 128 and increasing the buffer size to at least 512 in the Jack configuration settings.


Hi all,

I just installed patchbox os (console only mode) for the first time, and I’m having some strange issues with the audio output. When I generate a 440 Hz sine tone in Pd and output it from a (cheap) usb interface, it comes out as what sounds like about 220 Hz square wave mixed with a noisy “zipper” sound. The same thing happens when I run the sine-module directly from patchbox. EDIT: sometimes the result is a 440 tone, but still mixed with the noisy zipper tone.

I’ve tried 3 different usb interfaces - one of the cheap white dongle ones, and two different multichannel (5.1 & 7.1) ones, I think they’re all made with the CMedia chipset - and they all make the same sound. I know that the sound cards work because I was able to verify all of the outputs using speaker-test -t wav -c6 -Dhw:1,0 on a standard version of raspberry os lite (but the doesn’t work on patchbox). I can also address the output individually from Pd by changing the arguments to [dac~], but the result always sounds garbled…

Does anyone have any idea what could be causing this, or what I could do to fix it? I had a look around the forum and didn’t see any mention of a similar problem.

EDIT: it may be worth noting that when i start Pd, I get the following message in the console:
opened alsa client 132 in:1 out:1


We do recommend 512 for USB audio cards. :slight_smile: https://blokas.io/patchbox-os/docs/setup-wizard/

Raspberry Pi 4 (4Gb) + USB sound card SSL2 + Patchbox, 44100, 512, 3, as recommended, which is unusable at all but wanted to try - sound distorted. Occasionally the sound cleans up for a couple of seconds and then goes distorted again. The sound is distorted no matter what I do. Tried also different buffers setting and it always distorted.

However, the same sound card works perfectly fine without any xruns on 32 samples buffer with Guitarix on Manjaro system (intel, not a Raspberry Pi).

Raspberry Pi + SSL2 + Manjaro + Guitarix plays without xruns on 128 samples.

Im having the same issue now with a MobilePre usb card .
Having a hard time guessing where does it come from , as it seems to come and go .

I tried the recommended settings for external USB audio card. Nothing gets rid of the clicking sounds. After a while it become a distorted sound.

I even tried the 1024 buffer and higher period settings.
Nothing works…

Any ideas what can I check? do?


So just for the community who stumble across this post, the cause for the distortion is lack of power. Even with an original Pi power supply, when I connect midi devices or other power consuming devices directly to the pi, it will start clicking and distorting the sound.
A work-around I did is to use the midi DIN5 I/O on my USB sound card for additional devices, and powering them with another USB source. The only issue is that the USB sound card is only powering through the USB and it’s still clicking… So now I’m a bit frustrated and thinking about giving up using modep.

For the record I’m using pi3b+, if anyone is having a similar setup with a pi4 and having no sound issues, please let us know!