USB keyboard/mouse not working?

Hi all!

First, I am super excited about the existence of this community and all the great hardware and docs that are now available for doing audio hacking. I’m trying to make a little bass amp and effects pedal with modep + Patchbox OS + PiSound and excited it’s even vaguely possible.

Onto the problem: I tried booting my RPi 4b (8gb ram) into the Patchbox OS image. It booted, and I was able to connect to the patchbox wifi and ssh in from my laptop. But it did not recognize any USB peripherals that were attached, including my USB class-compliant keyboard and mouse. And while the ssh-over-wifi option is very cool, it automatically rules out anything that would require the Pi itself to be connected to the internet to download things. (Did I write out the ifconfig commands to connect the Pi to my home wifi and then wonder why the ssh session hung? Why yes, of course I did. :cold_face:)

I wondered if my keyboard and mouse were not actually totally compliant, needed drivers, or needed non-standard power. They’ve worked with standard Raspian in the past, but maybe they wouldn’t work with a lite, command line-only system. So I flashed “Raspberry Pi OS (32-bit) Lite” onto a card and loaded it, and they worked fine. I also tried connecting them to other very-lightweight linux systems I have, and again they worked fine. I am assuming Patchbox is some modules on top of RPiOS Lite, so that it would have at least the the same driver and hardware support, but maybe that isn’t true.

Can anyone help me figure out how to debug this?

Thanks,
asolove

Ok so it looks like the issue here might be this one related to the 8gb system not being supported by the current release of PatchboxOS: Patchbox Gets Corrupted on First Boot (Raspberry Pi 4 8GB)

A second question: the instructions in that thread say:

Follow the config script as usual. If you are on Patchbox , you will need to switch to a wifi network that has internet access to download updates …

But the problem is that the RPi doesn’t recognize any USB devices and therefore can only accept IO via ssh’ing in from its wifi network. Connecting it my home wifi necessarily turns off its wifi network, so I can’t see a way to actually complete these steps in order. I essentially need a way to say “turn off your wifi access point, then connect to another one, then run these shell commands even though my ssh session is dead, and then reboot”

You may initiate the connection to your WiFi from within the Patchbox OS wizard - once the device turns off the hotspot, the ssh connection will get lost. If it successfully connected to your WiFi, the device will have a new IP assigned which you may use with ssh again. See https://blokas.io/patchbox-os/docs/find-the-ip-address/

Oh interesting, I’ll try that. Thanks!

1 Like

I also have the non-functioning USB issue on a Pi 4 8gb. I ssh’d into it and ran apt-get update & upgrade but that has not resolved the problem, am I missing a step?

Yes, sudo apt install raspberrypi-kernel (see Patchbox Gets Corrupted on First Boot (Raspberry Pi 4 8GB))

1 Like

Awesome, thank you! I don’t know how I missed that.

same here with a 8gb RPI4

I was surprised that patchbox was based on a whole linux distro

and now it fails to recon basic usb devices …

ssh also fails to connect with putty from windows… :frowning:

regards

Try this recent image version: [Beta] Patchbox OS image 2020-11-23, the release you’ve used was built before 8GB Pi version was released.

is it stable ? otherwise I’ll wait an official release

We’ve found no issues with it so far.

I just installed the 2020-11-23 image and switched to the rt kernel via patchbox. The USB ports are not working. Is it the case, that they are working with regular raspberrypi-kernel only, not with raspberrypi-kernel-rt?

1 Like

Are you using 8GB RaspberryPi? If so, keep in mind, that the Realtime kernel version was built before 8GB version was released (but after 4GB was already available), so it’s likely to hit issues like this if you decide to use it. At the moment the RT branch is still outdated.

Hey,

So I’m also running into this issue, and I specifically replaced the 8gb Pi4 with a 2gb Pi4, knowing that the 8gb wasn’t compatible with the RT kernel.

I actually started with the 2020-03-14 image and when USB didn’t work there with the RT kernel, I flashed the 2020-11-23 image, and USB was definitely working… until I switched to the RT kernel.

Switching the kernel back confirmed this was the issue. As soon as I put the kernel back to the regular one and did a reboot, my USB controllers fired right up again.

I’m surprised this isn’t a more common problem? Happy to help with whatever I can, but I’m not the most experienced linux guy.

Thanks!

It looks like some system updates break the compatibility with the 4.19-rt kernel, and there’s still no 5.10-rt kernel that’d work well across the various models of Pi’s.

I’d recommend using the stock kernel for highest system stability. Once the RT kernel situation is sorted, we’ll make it available through update & kernel switch mechanism in patchbox.

1 Like

Thanks!

When the issue is fixed do you think it will be fixed for the 8gb model as well, or is it still safer to use my 2gb model if I’m prioritizing the RT kernel?

I just want to make sure I’ve got the “right” Pi in the box for when a stable update is released. Thanks!

Both should work eventually.

1 Like

I had the same issue with a 4gb Pi4: no USB with RT kernel.
I have added “total_mem=3072” in /boot/config.txt
Now I have USB !