[Patchstorage] Plugin Updates & Testing

AudioToCVPitch plugin now available in Patchstorage!

3 Likes

Updated NAM to latest, includes some advanced options for background processing that adds a bit of latency, should help for 32bit patchbox. Also added the MOD convo cab and loader and OJD, which is an OCD neural clone that sounds incredible. Also added ChowCentaur, also amazing. Enjoy

5 Likes

@deathbeard I was just trying out NAM and can’t figure how to upload the .nam files. Where should those be placed in the file manager?

1 Like

Finally got around to creating the directory on my Pi for the NAM Models. The update that @deathbeard provided does indeed help with the performance of NAM on the Pi. On my 8GB Pi4 turning on the “Buffered” setting in NAM causes the CPU usage to drop from almost 70% to just over 20%. There is a very slight difference in the sound but hardly noticeable.

Once you get it set up head over to tonehunt.org and download some NAM models. You won’t be disappointed.

Thanks again @deathbeard !

Nice!! It really is a game changer! I have a few more plugins coming next too. The biggest hurdle for nam and Aida is 32bit. If we can get over to 64bit, then pi4 can run standard nam models without using buffered mode…

@jtemple967 @Giedrius for reference sake, pi-stomp using a pi4 with 64bit allows us to use standard models with just on 50% cpu usage. That’s a pedalboard with a drive, nam, ir cab and a reverb! Without buffered mode

1 Like

Hello there.
Sorry for the noob question but how can I download new lv2 pluggin ? I don’t understand how patchstorage worked.

First, you need to make sure you’re on the latest version of MODEP. After that, on the bottom left is an icon with a P in it. Click that and if you’re connected to the Internet it will list the plugins in patch storage. Click on a plugin and then click install.

The problem is : When my computer is connected to my raspberry to see my pedalboard in modep. I can’t connect my computer to my WIFI box to have internet, or I will lost Modep. That’s why I don’t understand how you use Patchstorage.

I have to choose on connected my computer to my raspberry or to the internet

Okay, that makes sense. So I’m assuming you’re turning on the hot spot and connecting your computer to the Pi via the hot spot. The other way to do that is to have the Pi connect to the Internet through wifi and connect your computer to the Pi by browsing to http://patchbox.local. This works well as long as the name can be resolved on your network. In my experience this works most of the time. If the name cannot be resolved you will have to get the ip address of the Pi and browse that way. For example http://192.168.2.1 or whatever the address is.

The challenge can be getting that address if you don’t have a monitor hooked up to the Pi. One way is to use the Blokas PiSound app and connect that to the Pi via Bluetooth. The ip address is displayed in the app once connected.

1 Like

Oh ! Ok thank you very much ! I have never used other method to access to Modep because this one worked well. I will try that :slight_smile:

1 Like

hi everybody,

not sure if it is the good place to this message.

it is about the plugin ALO LOOPER on rpi3b+ and modep.

for me it is not possible to work with it because lot of bug.

First i am sync with internal midi, and i can toggle stop/play transpose button.

I have mapped some midi button to it with a midi keybord MAUDIO oxygen 49 and i find the solution to get “toggleable” state from the midi keybord. (it is in his documentation)

When i insert the pluggin on the pedalboard, it seems to work, i can record one or more loop, and switch on and off. BUT when i try to change parameters OR change the input source (add a sound generator to the pedalboard and connect it to the looper) things goes wrong and the looper seems to do whatever he want (not recording or never stop sound) and i finish to remove the plugin and restart all the work.

This plugin is my principal goal with the use of pisound, maybe i can help in the project (i never code anything like this before but with clear doc i can learn).

Don’t know if the dev is always on it or no. Let me know.

Have a great day

@mfaure I’m the one who compiled and uploaded the ALO Looper to patchstorage. I honestly just compiled/uploaded and did a quick unit test to make sure it at least did something but I didn’t do much beyond that. Could you provide the exact steps needed to reproduce the error? I might not be able to fix the code but we could at least reach out to the developer if we can show there’s a bug in the plugin. I checked the rep and there hasn’t been much work on this plugin lately.

Another thought: have you tried any other looper besides this one? I’ve the MOD SooperLooper in the past and never had issues with that plugin.

@jtemple967 thanks for reply

I’m the one who compiled and uploaded the ALO Looper to patchstorage

and for that too :+1:

Another thought: have you tried any other looper besides this one? I’ve the MOD SooperLooper in the past and never had issues with that plugin.

I tried sooperlooper and it work well but it is only sync free, isn’t it ?

Could you provide the exact steps needed to reproduce the error?

I try to made it by memory, maybe tomorow i’ll have the time to do that exactly with screenshots.

context : rpi3b+; patchboxos +module modep, connected to wifi network; usb midikeyboard (oxygen 49) connected, accessing via the web interface

midi mode : agregate
midi keyboard enabled in midi menu
clock sync : internal

ALO pluggin installed via patchstorage in the web interface

1 : create new pedalboard via the web interface
2 : add a sound generator A (a synth)
3: add ALO plugin and keep default parameters
4: connect all together (IN → SYNTH → ALO → OUT)
5 : connect midi (IN → SYNTH ; IN → ALO )
6 or 7 : map some button to midi keyboard (loop1, loop2, loop3, loop4 … ; Start/Stop)
6 or 7 : configure midi keyboard to change the CC data value between 2 pressure on the button (000, 127)
8 : Start playing (the click track of plugin should run)
9 : Arm a loop
10 : start playing some note with the midikeyboard, it should record it and start playing the loop.
11 : Arm another loop and start playing some note again, it should record it and start playing this loop too.
12 : Same as 11.
13 : try to stop some loop but not all, and start them again, should work (at the end of the loop)
14 : add another sound generator B (drumkit) and connect it to the ALO and MIDI
15 : bypass sound generator A
----- Start to bug for me --------
16 : try to record an other loop now.
17 : try to reset a loop
18 : try to stop and start a loop.
19 : try to change parameters and test them (live loop and reset mode for exemple).

1 Like

My goodness that is some excellent detail! :slight_smile:

Let me try this on my setup and see if I can reproduce.

I tried to reproduce my own list of step… and i had no bug.

BUT i think i understood what happen, something with “midi base” parameter.

I think about that because I tried to use the control by note ON/OFF message, i watched midi message with plugin “midi display”.

And when i start to send some midi note ON/OFF message in the range [ MIDI_BASE; MIDI BASE + 5], now* for sure it start to bug.
I tried to stop playing a loop with note off message, it stop playing and i ear the CLICKtrack but the loop button still display green.
If i try to restart the sound with note on message or midi CC mapping or mouse click it never play again, and i can record any loop anymore until i reset the looper by fire general STOP button.

*[EDIT : i changed “know” by “now” … ]

@mfaure so does that mean your issue is resolved?

no it just mean my list of exact steps to reproduce the bug was not good.

It dosen’t work for me. Either blutooth or wi-fi, the only way I can connect to the modep interface is with the hotspot, connecting my computer to the raspberry :frowning: