[Download] Midihub Editor 1.15.3 & Firmware 1.15.1

Hey guys! We’re wrapping up the 1.14 Beta with a Public 1.15 release! :star2: You may find an overview of everything that’s happened since the last public release in our blog post.


Detailed Changelog

1.15.3 Editor

  • Fixed editing port names while not connected to Midihub.
  • Fixed firmware upgrade which was briefly affected in 1.15.2

1.15.1 Editor

  • Fixed Editor crash that could occur soon after editing the port names.

1.15.0 Editor

  • Fixed monitoring events on bypassed pipes.
  • Removed the preset number from main window title.
  • Fixed drag & drop with mappings between Editor instances on macOS.
  • Transform pipe tooltips fixed.
  • Added View → Show Tooltips menu option to enable/disable the pipe tooltips.
  • New quick link doc page for Midihub Editor.

1.15.1 Firmware

  • Arpeggiator sequences for some algorithm types fixed when playing on Channel other than 1.

1.15.0 Firmware

  • Synced LFOs playing at half of expected rate fixed.
  • Fixed bypassed BPM pipe in modifier position blocking off events.
  • Added ‘Any Id?’ and ‘Id’ parameters to Equalizer pipe.

nice one,will UD today

thank you

1 Like

Congrats again since it’s official now! Midihub is essential for reimagining my old and new midi hardware, it does things I never would have thinked of…


Job well done guys! The chord feature is intriguing; will update it today. Thanks!



here i found little gremlin in TRANSFORM pipe
when SET CHANNEL TO is ARG1 then ARGUMENT 1 is x8

it is working ,but in order to set desired channel you need to multiply your channel number by 8 and then set that number into ARGUMENT 1

channel 1 0…7 etc…


1 Like

First of all: congratulations for this update, friends!!

Unfortunately I have not yet been able to make it run.
I open the Editor — it recognizes my four MidiHub units — but then it gives me an error when I try to connect any of them.

Screenshot 2024-02-09 at 15.52.02
Screenshot 2024-02-09 at 15.52.07

Most likely something related to having multiple units, I guess?
It was working nicely until yesterday.
Already tried with and without USB hub, nothing changed.
I’ll appreciate any clue.

Thank you very much as always

1 Like

This is kind of by design - the Arguments 1 and 2 have the range 0 - 127, the Channel have the range 1-16, so the values must be linearly remapped between the ranges. Consider having mapped a CC knob to one of the Argument parameters, it would be quite difficult to select a channel only with CC values 0-15, with values 16-127 being a ‘dead zone’ for the highest channel.

That’s why there’s an additional “Channel Argument” that has the range 1-16 that is naturally useful for ‘Set Channel To’ property. If the Ch. Argument is used for one of the data bytes that have the full 0-127 range, it also gets automatically rescaled from 1-16.


It’s best to perform the firmware upgrades for each unit one by one. Keep the rest powered off or disconnected until all of the units are on 1.15.0 firmware.

I’ll send you a PM with some further troubleshooting instructions.

Thank You. This whole thing is awesome.

1 Like

quick question about CLOCK pipe and MANUAL START STOP CONTINUE

i have few CLOCK pipes for each port

when i press STOP button all of them stops,but when i press START only one i press START starts

so is global STOP action intended?

Screen Shot 2024-02-12 at 20.11.13


Please attach your preset so we can take a peek. :slight_smile:

of course


lfo4okta_v4_nanokontrol_v3.mhp (3.5 KB)

just for record ,comment pipe would be very helpfull

1 Like

ah damn it

its my bad

sory please disregard that


This was solved via PMs, it was caused by an early internal alpha test build, so it shouldn’t affect other users but if anyone hits any issues, do let us know. :slight_smile:


my midihub editor 1.15.0 crashes

when i enter TO MIDI OT#1 pipe (selected in the screenshot), go to EDIT button from PROPERTIES window,then i press ok,
and then when i want to change DESTINATION in TO MIDI OT#2 pipe ( one just below OT#1 selected in the screeenshot) it crashes.

EditorTelemetry.db.zip (363.0 KB)
lfo4okta_v4_nano_beat_divide_v5.mhp (4.0 KB)



Thank you, I could reproduce it, a fix will soon be released.


Fixed in 1.15.1 Editor.


Similar problem with 1.15.1?

Having tried port name change successfully yesterday on Screen Shot 2024-02-17 at 12.52.36

…was surprised to find when doing the same† on MacBook15

…resulted in a loop with this dialog:

I also did a restart on the MacBook. The issue persisted.

Given we’re talking about the same OS here, @Giedrius, please advise on what logs you might want to look into this further

† the same means the same simple patch attempting to revert to original names for MIDI A/B IN

renamed patch: VM0_now_renamed.mhp

original names: VM0_ABnames.mhp

1 Like

Thank you, fixed in 1.15.2. :slight_smile: