[Download] Midihub Editor 1.12.2 & Firmware 1.12.0

Hey guys! As the Midihub birthday is coming up this weekend, we’re releasing a new feature we’re sure everyone will appreciate :slight_smile:. Introducing the real-time MIDI Monitor!

The MIDI Monitor shows all the data being processed and produced by the currently selected pipe, as well as provides a BPM estimate based on the recent Clock events. Filters can be set up to hide irrelevant events.

Downloads

1.12.2 Editor Changelog:

  • Fixed connecting to Midihub in Bootloader mode in rare circumstances.

1.12.1 Editor Changelog:

  • Fixed memory contents export and import.

1.12.0 Editor Changelog:

  • MIDI Monitor pane added that displays MIDI data processed by the currently selected pipe.
  • Insert from another preset options added.
  • Insert Preview will mark Virtual inputs and outpus already used in the main preset with purple squares.

1.12.0 Firmware Changelog:

  • Added ‘Always Send Pitch Bend’ parameter to Micro Scale.
16 Likes

This is great news!!

Many thanks Giedrius!

Installed Windows version of the Editor. Can’t connect to my MidiHub which is of course running an older FW.

Is there a way to flash the new FW to the Hub without the Editor?

Ok, uninstalled Editor; Installed previous version; flashed FW to the Hub; uninstalled older version of the Editor; installed new version of the Editor.

Presets are gone.

Make sure to save your presets to files for later re-import.

1 Like

edit: Ok, this version is now publicly published and below info is no longer relevant. :slight_smile:

Ah, it’s because we haven’t published the update publicly just yet - it does not know where to get the new firmware from.

We’ll probably have to publish new builds to take account of that.

In the mean time, you could follow this update sequence:

  1. Save memory contents of the Midihub using Editor 1.11.10 (if you’d prefer not to lose the presets)
  2. Install Midihub Editor 1.12.0
  3. Flash the 1.12.0 firmware after starting Midihub in bootloader mode (hold down the button while powering on the device)
  4. Connect to Midihub, import the memory contents.
3 Likes

This is fantastic news :slight_smile: … Many thanks

1 Like

Great news x thanks @Giedrius

1 Like

That’s great! Thank you!

1 Like

There’s a confirmed issue with importing memory backups into Midihub, we’ll get it fixed soon. If you’ve encountered the issue, please send me the .mhd file via PM and I should be able to recover it for you. :slight_smile:

The firmware auto-update process works ok to move the memory contents to the new version.

1 Like

All the downloads on the site still point to the 1.11.10 version even though at the bottom of the Download box it says 1.12.0

2 Likes

Thank you, fixed :slight_smile:

1 Like

What a great improvement on an outstanding piece of gear…

1 Like

Brrrrwwwwaaaaaghghgh!! Thanks guys. This is awesome. I’m 100% certain this will make things so much easier for me. Cant wait to get stuck in this evening.

Happy Birthday MIDIhub and Blokas crew

4 Likes

And I LOVE that the monitor pane can be popped out to a separate window. Put on my second monitor and not sacrifice any screen real estate for pipelines and properties.

2 Likes

Great news, hope I can update that on my RPI too.
(but I am a little disapointed that there is still no chance to simply name the ports…)

Hi, the online update did not work (it never did so far in my Ubuntu). But neither works the link above Downloads - Blokas
it says “Oops!”

Hey, what error do you get when attempting the online upgrade?

What is the Ubuntu version you’re using?

Btw, FW link fixed :slight_smile:

With a simple patch installed to test the monitor USB A/B/C/D to OUTPUT A/B/C/D driven by 4 different clips from Ableton via USB - nothing appears on the monitor. In fact fiddling around for a couple of hours nothing has ever appeared on the monitor. Selected it on / off many times.

Any ideas?

Works here.
The monitor shows the messages flow throught selected pipe.

Check midi filtering for the monitor.

Do you have it working with MIDI-DIN inputs?

Hi - many thanks - I selected within the settings of the midi monitor, all off for both input and output and it worked. Even though they were all off anyway?

And yes didn’t get input monitoring initially, my default position, which I hadn’t tried until you suggested it - when above applied, all fine!

:grinning: