VNC Screen Resolution

Did you restart the system after changing the resolution? Do you have anything plugged into the HDMI port?

Yes I restarted and there was nothing plugged in to either of the HDMI ports.

Does this need to be set with something plugged in?

There’s a force_hdmi_hotplug flag in /boot/config.txt that should be set in case nothing is connected (on Patchbox OS it’s enabled by default). Could you post the entire contents of your /boot/config.txt here so we can see if everything is alright? :slight_smile:

I have checked and the force_hdmi_hotplug looks set.

Here’s the contents of the config.txt:

# For more options and information see
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable infrared communication.

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# Enable DRM VC4 V3D driver on top of the dispmanx display stack


If tried using this entire config, and it seems fine, I got 1920x1080. Maybe the issue is in the VNC client?

What diagnostics information do you get here:

At the bottom, it should show the resolution info.

When I try and open that on VNC I just see this:

There’s lot of windows where I can’t close or resize and not sure how to do that on Linux using the keyboard.

Go to Properties of this VNC entry in main window of VNC Viewer, check whether Scaling is set up correctly:

These are my VNC settings and they look almost same as yours:

I managed to get a screen shot of the VNC display settings:

What is the output of this command:

/opt/vc/bin/tvservice -s

Connecting via SSH I get this:

state 0x6 [DVI CUSTOM RGB full 16:9], 1920x1080 @ 60.00Hz, progressive

Hmm, the command seems to give ok output, but VNC still ends up using a low resolution.

I’ve found this thread: Set VNC resolution? - Raspberry Pi Forums

It suggests commenting out ‘dtoverlay=vc4-fkms-v3d’ in [pi4] section (add ‘#’ at the start of the line), as well as uncommenting and changing these lines:


None of those changes were necessary on the Pi4 I’m using though (and I did try your config directly in place over my one), but modifying those lines may help in your case.

Thanks for all the help I really appreciate it!

I will try this afternoon because I am stuck in meetings all morning.

1 Like

That has worked!

Thank you for the help :smile:

1 Like

Did you do both changes, commenting out the line, and setting fb width and height?

Yes, I made both the changes and then rebooted and when I connected to VNC it was at 1920 x 1080.

Thanks for the help again :smile:

1 Like

Yes, you can change the screen resolution in VNC but I found that my USB stick no longer mounted automatically, and I was unable to write to it. I had to revert to my original config.txt before it would work again. (I have my main.pd on a usb stick)

That’s odd - the changes in config.txt shouldn’t be related to USB at all…

So the patch could load OK from the USB, but it wasn’t writable by you?

Tried again this evening and it works now…Sorry for any confusion caused.

1 Like

I had the same problem as original poster. VNC resolution for me was locked at 1024x768.
I agree with the solution of editing boot.txt to set the desired framebuffer width and height.
The key change for me was also to comment out dtoverlay=vc4-fkms-v3d. This is GL driver support. I didn’t know I wanted it until I installed the Protokol MIDI Monitor so I could explore Touch OSC.
Protokol complains on open:
Your system appears to be running a software rendered graphics driver causing the application to run extremely slow. Please see the following link on how to enable the ‘GL (Full KMS)’ driver:
This led me to renable the Fake KMS GL option (Full is not available to me on Patchbox). What I noticed was, ZynAddSubFx seemed a little snappier to me with GL support enabled. I like ZynAddSubFX for my Pi4 but it is very slow to navigate the interface and adjust presets. Using the CPU tray indicator, I observe ~35% CPU with GL support, plus Carla and ZynAddSubFX GUI loaded, vs ~75% without GL support, and the same applications open.

If like me, you want to keep the GL driver loaded, there is still a way to change the resolution (after logging in). The command that worked for me inside the ‘small window with GL’ VNC session was “xrandr --output HDMI-1 --mode 1920x1080”. I have not figured out how to incorporate this into vnc startup at boot (please reply if you know how). I hope this helps someone who wants both GL support and higher VNC resolution(s).

1 Like