VNC Screen Resolution

Hi all,

Sorry for the basic question but how do I increase the screen resolution when I am using VNC?

The screen is really small and it makes it really hard to use PureData.

Thanks,

Karhide

Hey, there’s a couple of ways to do that, see this article: Setting the Screen Resolution of your Raspberry Pi - Pi My Life Up

I think another option not mentioned is via the SysMenu → Preferences → Raspberry Pi Configuration.

Hi Giedrius,

Thanks for the info and I am have tried those various things already but it does not seem to make much difference in VNC with each change. The Screen Resolution does not seem to be available from the Preferences as shown in the example, I have tried using raspi-config and editing the boot/config.txt.

Was the SysMenu → Preferences → Raspberry Pi Configuration option in the older versions of the OS and it’s now moved?

Did you restart the system after changing the resolution? Do you have anything plugged into the HDMI port?

Yes I restarted and there was nothing plugged in to either of the HDMI ports.

Does this need to be set with something plugged in?

There’s a force_hdmi_hotplug flag in /boot/config.txt that should be set in case nothing is connected (on Patchbox OS it’s enabled by default). Could you post the entire contents of your /boot/config.txt here so we can see if everything is alright? :slight_smile:

I have checked and the force_hdmi_hotplug looks set.

Here’s the contents of the config.txt:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=16

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

If tried using this entire config, and it seems fine, I got 1920x1080. Maybe the issue is in the VNC client?

What diagnostics information do you get here:

At the bottom, it should show the resolution info.

When I try and open that on VNC I just see this:

There’s lot of windows where I can’t close or resize and not sure how to do that on Linux using the keyboard.

Go to Properties of this VNC entry in main window of VNC Viewer, check whether Scaling is set up correctly:

These are my VNC settings and they look almost same as yours:

I managed to get a screen shot of the VNC display settings:

What is the output of this command:

/opt/vc/bin/tvservice -s

Connecting via SSH I get this:

state 0x6 [DVI CUSTOM RGB full 16:9], 1920x1080 @ 60.00Hz, progressive

Hmm, the command seems to give ok output, but VNC still ends up using a low resolution.

I’ve found this thread: Set VNC resolution? - Raspberry Pi Forums

It suggests commenting out ‘dtoverlay=vc4-fkms-v3d’ in [pi4] section (add ‘#’ at the start of the line), as well as uncommenting and changing these lines:

framebuffer_width=1920
framebuffer_height=1080

None of those changes were necessary on the Pi4 I’m using though (and I did try your config directly in place over my one), but modifying those lines may help in your case.

Thanks for all the help I really appreciate it!

I will try this afternoon because I am stuck in meetings all morning.

1 Like

That has worked!

Thank you for the help :smile:

1 Like

Did you do both changes, commenting out the line, and setting fb width and height?

Yes, I made both the changes and then rebooted and when I connected to VNC it was at 1920 x 1080.

Thanks for the help again :smile:

1 Like

Yes, you can change the screen resolution in VNC but I found that my USB stick no longer mounted automatically, and I was unable to write to it. I had to revert to my original config.txt before it would work again. (I have my main.pd on a usb stick)