USB Device Not Recognised

Hi All.
I’ve just assembled my new MidiBoy and powered it on in bootloader mode (Blokas logo appears fine), but my Windows 10 PC keeps giving me the error message “USB Device Not Recognised”.

The device appears as “Unknown USB Device (Device Descriptor Request Failed)” in Device Manager. I’ve tried uninstalling the device / reinstalling drivers / powering on & off, etc but nothing helps.

I have installed Arduino IDE 1.8.13, which included various USB drivers.

I’ve also tried a few other things:

  • different USB cables
  • different Windows 10 PC (gives same error)
  • tested other Arduino boards on my PC (these work fine)
  • re-soldered components
  • tested solder joints with multimeter
  • attempted with and without 9v battery power

… but nothing I do seems to work. I’m about to throw this thing out the window!

Has anyone got any suggestions please?!

Hi, check if all of the components are in the right place and the polarized ones are the right way round. This issue could be caused by some soldering mistake somewhere on the board, especially in the rectangular area covering the MIDI ports and the main ATmega328P chip, but not necessarily limited to it.

Compare your board with this picture:

Thanks for the quick reply Giedrius. I have compared my board with your image and it seems identical. I have attached a photo of my board, if that helps?

And here’s the other side of my board…

Thank you for providing the pictures. Unfortunately I didn’t spot anything obviously wrong. Just in case, check this picture out:

The components enclosed within the orange outline are critical for USB communication, as well as the 3 pins marked with light green dots. Please double check whether the solder joints on theses components are indeed fine (they do look fine from the picture, but maybe looking at them at an angle could reveal something). Also, double check if the microcontroller pins didn’t get bent when inserting, to remove it from the socket, use some slim long-nose pliers or long tweezers to slide underneath and lift the whole body at once. Removing the optocoupler first is a good idea. :slight_smile:

Another thing to try is to keep the B button held down for a few seconds during and after plugging in the USB cable, or powering on the device with cable already inserted.

By the way, you mentioned other Arduino boards - do you have a tool that could flash the memory of ATmega328P? We haven’t seen this occur before, but maybe the chip itself is flashed incorrectly - if it’s fuse settings were not set correctly, the USB won’t work, but the bootloader logo would still show up. This could be checked and fixed using a programmer or another Arduino board set up for In System Programming (ISP) and avrdude.

Do you have the original Arduino UNO board by any chance? If so, I think you could pop the ATmega328P in it and inspect it.

I’ve triple-checked the component soldering and IC pins for bends and all seems ok.

I’ve also checked for shorts and the continuity of connections (e.g. from IC pins to diodes, resistors, etc) using a multimeter and everything seems fine.

Unfortunately I don’t have an UNO board to test the ATmega328P, only Leonardo boards. But I have just ordered an UNO dev board off eBay; I should receive it next week. Hopefully that helps shed some light on the problem… I’ll report back soon…

1 Like