Raspotify output on pisound to play along

I want to use my Pisound to play along to tracks on my bass. How can i get raspotify to output he music on the pisound? I read the raspotify documentation, but can only find the solution for usb soundcard. That doesnt work with the pisound.

Does anybody get an idea?

Hi, looks like Raspotify requires software resampling to be set up in order to work. Here’s what I had to do:

(including this step for completeness :slight_smile: ) Install Raspotify:

curl -sL https://dtcooper.github.io/raspotify/install.sh | sh

Run sudo nano /etc/asound.conf, paste these contents (this is the entire file):

pcm.!default {
  type asym
  playback.pcm {
    type plug
    slave.pcm "output"
  capture.pcm {
    type plug
    slave.pcm "input"

pcm.input {
  type hw
  card 2 # Might have to be '1', check with arecord -l

pcm.output {
  type hw
  card 2 # Might have to be '1', check with aplay -l

ctl.!default {
  type hw
  card 2

Hit Ctrl+X, then Y to save and exit. Then:

patchbox module deactivate
systemctl --user disable pulseaudio
systemctl --user stop pulseaudio
systemctl --user disable pulseaudio.socket
systemctl --user stop pulseaudio.socket
sudo systemctl disable jack
sudo systemctl stop jack
sudo systemctl restart raspotify.service

Let me know how it goes, I hope I didn’t miss any step :slight_smile: