Pisound Android App Public Beta!

Now it works! Thank you!
Needed a couple of reboots. Did not work form the beginning. Deactivated vnc. But i dont really know what change made the trick.

I found out, i have to open the terminal, to get the GUI to open.

You mean that you have to start lxterminal for the GUIs to appear after launching via the app?

Yes, i opened lxterminal then launched a patch from the app and PD opened with the GUI

Ok, thank you for pointing this out, I didn’t notice that at first. :slight_smile:

I have updated the Pure Data launch scripts to work as follows:

  1. If there is HDMI connected, use that. (using DISPLAY=:0)
  2. Otherwise search for any other DISPLAY to use, like a VNC server.
  3. If nothing has been found (HDMI unconnected, no VNC running), specify -nogui for Pure Data.

This way you no longer have to launch a terminal manually to get GUIs to show up. :slight_smile:

You can get these changes now by running sudo pisound-config and running “Update Pisound” (The changes are only in the /usr/local/pisound git repository, since apt-get packages didn’t change, the “Update Pisound” in the config will update it)

im getting an error when i try to import a patch from usb: cp: cannot overwrite directory ‘usr/local/puredata-patches…’ with non-directory.

i have tried to resolve this myself and read about root access being denied to user profiles but im not sure how to avoid this as i really don’t want to set myself as a root user. the reason i want to avoid is this i haven’t really got a clue what im up to and i can see re-flashing the SD in my future if i go down that road.
Any help would be appreciated

i have updated the pisound by running sudo pisound-config and running “Update Pisound" the result of this is pisound-btn and pisound-ctrl are the newest versions 1.05-5 and 1.02-2 respectively but i still have to open the terminal to see the patches when they launch.
using VNC on headless pi

Maybe the Pisound’s repository didn’t get updated. What is the output of:

cd /usr/local/pisound
git status

Do you still have the issue with importing from USB?

Output of git status
On branch master
Your branch is up-to-date with ‘origin/master’.
nothing to commit, working tree clean

Hmm, the repo should be up to date based on the output. You could try to manually update it too, just in case:

cd /usr/local/pisound
sudo git pull

What VNC server are you using? I was using tightvncserver and it worked fine for me without having to open the terminal, I’ll try with the one you are using.

On USB import - it looks like /usr/local/puredata-patches/mainreverb.pd is a directory, and on your USB it’s a file. Try to move mainreverb.pd file on your USB drive to puredata-patches/my_reverb/main.pd and remove /usr/local/puredata-patches/mainreverb.pd from your system.

The my_reverb would then be used as the display name in the app and should get copied correctly, the main.pd would get launched when starting it. blokas.yml file can be used to customize the appearance and which pd file gets started.

Thanks for all your help much appreciated

I’m using RealVNC

Little question, since I ditched the google Android from my phone and now have the open source one (which does not support the Play store). Is there some way to get the app without going through Yalp Store?

Would a downloadable .apk package work for you? What OS are you running on your phone?

FP Open, which is basically a de-googlized Android for the Fairphone2. So yes I guess an apk would work, of course I’d have to update manually each time an update comes up, but I’m ok with that.
I can’t remember if the Pisound app is open source, but if it is, you might want to check F-Droid, that seems to be the most trusted alternate app store for open source apps on Adroid.


Ok, I’ve uploaded the apk here: https://blokas.io/pisound/app/com.blokas.pisoundctl.v1.02.apk

Also updated the documentation here: https://blokas.io/pisound/docs/Pisound-App/#android

1 Like

thanks a lot!!!

Install worked perfectly! Thanks again!


9 posts were split to a new topic: Pisound Android App Public Beta Feedback