Lost, unknown pipe

Midihub 1.11.7, Editor 1.11.4, Win10.

It looks easy to lost pipe, ctrl+Z doesn’t work also after the issue occurs:

Is it known issue?
Or user error?
Now trying to reproduce…

Edit: no need to be connected to Midihub.
I found user’s notification meeting above symptoms in other post:

Hey, do you know what was the sequence of actions that lead to this state? Maybe you could share the .mhp with which it’s easy to reproduce?

1 Like

Hey, yes I probably worked it out.
I will write full description this evening.

Windows 10 users please try.

Basic example

New preset.
Add any input pipe, any filter pipe, any other pipe (let’s make them filters), any output pipe.

Rearrange order, drag filter pipe and place too much left, onto Input pipe.
/can’t be done without Output pipe at the end of pipeline/

The pipe disappears. “Unknown pipe” message in properties window appears.

After undo /ctrl+Z/ command whole pipeline is removed.

Tip: Talking about grey pipes - I also cannot move pipe to be the last one from any other position. First need to drag&drop to the right to the second to last, then the last one to the left… :thinking:
Like you can move pipes too much to the left and too little to the right.

Now you can develope more issues.

Next example

New preset.
Create the same pipeline as above and duplicate it.
In the second pipeline: lost pipe by dropping it over input pipe as above.
In the first pipeline: do the same.
Now Undo.
You should end with:

When you try to save this state and open it again:

Create more pipelines, combine “lost” and undo and you will catch more results.

As I now know what not to do to start this issue and how superb Midihub is bacause I have already made rich music and had a lot of fun with it… I feel great :wink:

1 Like

Solved in Editor latest update:

1 Like