Can't connect to midi hub


I have a Midihub and it worked fine when I first connected and installed the editor, now it does not.

I’ve installed other midi software since installing the editor but I’ve uninstalled all of those to try and get the midihub working but it just will not connect.

When I connect the USB cable the midihub lights up and I get the Windows sound that the USB is connected.

I’ve done the latest Win 10 updates, uninstalled and reinstalled the editor. In device manager the midi hub is showing set to COM3 and there are no errors, so I’m at a loss what to do next.

Also, because I’ve not been able to connect via my laptop I have been using my desktop PC, however today that has also stopped working and will not connect. But, if I switch the hub off and then back on again while it is trying to connect to the hub, I get a message saying that a mandatory firmware update is needed, so I click update but I just get an error saying couldn’t open Midihub’s serial port. Error code: -1

I hope you can help!


Hey, we’ll ask you to produce some logs so we can better understand what goes wrong. Here are the steps to produce a log file for us:

  1. Open ‘Command Prompt’ (from the Start menu)
  2. Type in this command and hit enter:
  3. Then start the Editor using this command:
    "C:\Program Files (x86)\Blokas\Midihub Editor\midihub_editor.exe" > mh.log 2>&1
  4. Try to connect to the device using Device->Connect
  5. Wait for a few seconds
  6. Close the Editor
  7. The produced log will be in your User folder, named mh.log. (The path can be seen on the Command line before the > symbol, in my case it’d be C:\Users\Giedrius)

Please zip the log and send it to us here or by e-mail :slight_smile:

Thank you!

Hello, many thanks. Here is the log (9.8 KB)

Looks like the Windows API for opening the COM port returns this error:

Port CreateFile() failed: The semaphore timeout period has expired..

Could you check if the settings you have for Midihub’s COM port in Device Manager is different from what I have? Here’s the default settings I have:

Also, does the driver information of the device match this:


They all seem to match what I have…




Does the Midihub Editor connect to the device if you turn it on in bootloader mode? (keep the button down while powering it on, all LEDs should be lit up in that mode)

I’m guessing it does connect? It doesn’t say connecting but I get a disconnet icon in the top left and the screen goes Grey.
EDIT, It tells me the firmware version in the bottom right so that must mean it has connected ok.

Please try flashing the firmware when connected when it’s in bootloader mode, get the firmware file from [Download] Midihub Editor 1.11.10 & Firmware 1.11.11 and do Device → Flash Firmware.

When starting the flashing procedure while the device is in bootloader mode, it won’t save the memory contents, but I you should be able to find the last backup on one of your machines that you used to perform the firmware upgrade before here:

C:\Users\Giedrius\AppData\Local\Blokas\Midihub Editor

(Change Giedrius to your user name, or just do Start → Run, and enter %LOCALAPPDATA%\Blokas\Midihub Editor and hit OK)

After the firmware flash procedure, if it connects well, you should be able to import the backup file using Device → Import Everything…

I flashed the firmware but I still cannot connect to the hub normally, it just hangs while trying to connect as per the below screenshot.

I tried again on my other computer and after a reboot I did manage to get past the error that appears when it says a new firmware was required, so it is connecting fine on that computer, but I have to disconnect everything and move the midihub to that computer to actially do anything so it’s not ideal.

Do you have any other ideas on how to get it working on my laptop again?

IGNORE the above, it is now working :slight_smile: I rebooted my laptop after doing the firmware update and it connected instantly. I need to re-install my other midi device software now though so let’s hope it wasn’t something form that causing the issue.

Thanks for your help!

1 Like

Good to hear it’s working again! :slight_smile:

1 Like

Hello, unfortunately it has stopped working again. I haven’t changed anything on my laptop since I last connected and I tried the method I did before by reflashing the hub, rebooting my laptop and trying again, but this time it did not work :frowning:

Do you have any other suggestions?

Could you please repeat the steps to get the log as in my initial reply to this thread, so we can see what’s going on.

Does the editor connect to Midihub when it’s started in bootloader mode?

Thanks for the reply. I’ve followed the debug steps again and attached the mh file.

Yes it connects perfectly fine in bootloader mode.

mh.log (7.6 KB)

Could you try switching the preset before connecting using a few clicks of the button, and see if it manages to connect to the device?

That does npot seeem to work unfortunately. Switching profiles works before and during connection though.

If you switch to say preset #7, indicated by OUT C LED (or any other preset different from the one loaded initially), then attempt to connect to Midihub, does it change back to the original preset after attempting connection?

I currently only have 2 presets, but if I put it on preset 2 and try to connect, it remains on preset 2.

1 Like