Trouble integrating into Logic Pro X setup

Hey!

I have problems setting up Midihub into my DAW setup. I have two hardware synthesizers (Deepmind 12 and Neutron), both connected via USB MIDI. Both are assigned dedicated tracks in Logic.
Midihub is connected via USB only (no MIDI cables needed, I guess) and shown as online in MIDI Studio. I haven’t made any virtual connections in MIDI Studio (or do I need to?).
I use the Deepmind keyboard for MIDI input (the Neutron doesn’t come with a keyboard).
I tested with a very simple pipeline : USB From A -> Transpose +24 -> USB To A.
What have I got to use in the Logic MIDI tracks as Port? The only setting that appears to make a difference is picking “All” for port, I can then hear both the transposed note and the originally played one. All other selected ports don’t make a difference, i.e. I always hear notes as played. Obviously I only want to hear the transposed note. Also, I do seem to get into MIDI feedback loops, probably due to my lack of understanding how to correctly route things. The MIDI led on MIDIHUB keeps blinking like mad. Can someone share any pointers what my fault is and how to correctly set this up? Sorry for the newb questions.

Cheers,
blakarrhok

Hey, the USB A should correspond to ‘Midihub MH-… (Port1)’, see how the port names look like on different OSes here.

The LED close to the ‘midihub’ text and USB port indicates MIDI activity on all of the virtual USB ports (A, B, C, D), if it’s blinking a lot, that means a lot of events are going through.

I don’t have experience with Logic Pro, but at least in Ableton, Midihub is seen as sort of 4 individual MIDI devices / ports. I’d expect Logic to treat Midihub as 4 independent MIDI ports too, so you can route the data through it according to your needs.

Hopefully someone who knows Logic Pro may be able to help set this up correctly. :slight_smile:

No experience over Logic, but like Giedrius said, it also is true in Cubase as well as in Maschine: 4 ports (over USB-MIDI) and no extra setup needed. One thing though, some DAWs don’t actively listen new MIDI-connections as a default, so if you haven’t turned on the MidiHub BEFORE you’ll launch your DAW, that can in some cases make a difference, i.e. your DAW does not see the device, but firing out with “All” might still send the data into the device.

Thanks go to the two of you for your advices
.
I am one and a half steps further now. The original key pitch sounding along with the transposed one was my stupidity, I switched off “Panel Local” in my synth instead of “Local”. Doh, but that makes sense.

MIDIHUB now appears to work as expected when using MIDI cables only, however I’d prefer getting rid of even more cables in the way, so I’d be glad to get this to work with USB somehow.

I also got Logic out of the equation, and am using direct audio out for now to simplify things.

Any pointers what the problem may be? Both MIDIHUB and my Synth(s) are connected to my iMac (using a USB hub). The LED close to the midihub text is constantly on (not blinking). The IN A LED is constantly on as well. No activity on any OUT LEDs.

It’s indicating its ON! with power

Its indicating Preset 1 (you can change presets with the button on the back, do try that, go to preset 2 and what LED you get?

When pressing the Midihub button, the IN A LED blinks three times. I don’t have presets set up yet, apart from the first one.

By the way, I got one more thing working now, which is the USB Input. So USB FROM A -> MIDI TO A works fine, but none of the USB TO A/B/C/D work. No out LEDs light up when playing notes in that case. The IN LED blinks (together with the upper status LED) on note on and off.

In Logic, I have Port “Midihub MH-08JC8 XQ Port 1” selected for my synth (DM-12) MIDI track. MIDI channel is set to All. Very frustrating, really would like USB to work for both IN and OUT.

The MIDI OUT LEDs indicate activity on DIN-5 MIDI ports.

You should put TO USB A or such output pipe, and get data into it, then configure Logic Pro to use the incoming data from the Midihub MH-08JC8 XQ Port 1.

In Ableton, you have to arm a track for recording, or turn on monitoring of MIDI input in order to make use of the incoming MIDI data from MIDI devices, a similar step may be necessary for Logic Pro. :slight_smile: Ableton also has at least visual MIDI activity indicators here and there, useful to see if there’s data coming through, even if you’re not actively making use of it.

Thank you Giedrius!
I am another step further to solving this mystery. I downloaded a MIDI monitor APP to track what is going on. When using solely MIDI cables (where it works fine) I get this result after pressing and releasing the C1 key (note that the transpose is set to one octave up):

(Anschluss 1 is Midihub Port 1)

With USB:

This clearly looks like it is bouncing events internally, leading to a MIDI loop.

Any ideas how to circumvent this?

When I disable “record enable” in the Logic MIDI track (the red R turns black) I can see in MIDI monitor that played notes are not looped. But I cannot hear what I am playing. I am sure this is a common problem I just don’t have the experience to solve it. And why is this behavior only occurring for USB MIDI but not cable MIDI…

Okay I gave up trying to get it to work with USB. I’ll use MIDI cables for now.
Next problem. All works fine when playing live on the keyboard, but when recording a MIDI track with Logic and then playing it back, the MIDI events are not routed back to the synth, so no sound at all.
I have selected MIDIHUB Port 1 in the tracks’s port setting. MIDI Channel is set to all. Anyone with an idea?

USB must be involved if you want Logic Pro to send and receive MIDI through Midihub. Unfortunately I don’t know how Logic Pro works, so I can’t help much on that side, but I could help you get your preset right, could you post here what you currently have? You should have at least one USB IN, sending to MIDI OUT as needed, and make Logic Pro send data to that port.

1 Like

@blakarrhok: I do use Midihub with Logic Pro 10.5, but my setup is a little different from yours. Anyway, if you want to use USB only I think you’ll need to set this up in Logic’s “MIDI Environment”, but I tend to avoid that, since it is a whole new chapter for the use of Logic.
I would personally set it up with “External instruments” (without using the MIDI Environment of Logic). “External Instrument” is a built-in Logic Plug-In that let’s you control external gear and has the advantage that you can add FX-Plugins in the channel strip.

As far as I understood your needs:
Basically you want MIDI from your D12 to Logic (using D12 as your Masterkeyboard). Then you want the MIDI played via Midihub to go back to D12 or to the Neutron. Is that correct?

If that is the case I would set it up as follows:

MIDI Settings Synths:

  • MIDI OUT of D12= CH1
  • MIDI IN of D12= CH2
  • MIDI IN of Neutron= CH3

Cables:

  • Connect D12 MIDI OUT to Midihub DIN IN A
  • Connect Midihub DIN OUT A to D12 MIDI IN
  • Connect Midihub DIN OUT B to Neutron MIDI IN
  • Connect USB of Midihub to your Mac

Logic:

  • Set MIDI input under "Settings -> MIDI -> Inputs”: Activate MIDIhub Port A
  • Create new Software Instrument Track: Load a Software Instrument: Utility -> External Instrument
  • On this external instrument choose Port: Midihub Port A
  • On the external instrument choose MIDI Channel 2 to play the D12 or CH3 to play Neutron
  • If necessary choose the according Audio Input Channel for the Synth you want to play

Midihub Pipelines:

  • MIDI DIN A -> USB A (for sending D12 keyboard to logic)
  • USB A-> Channel Filter (only let CH2 through) -> DIN A (for sending the notes from Logic to D12)
  • USB A-> Channel Filter (only let CH3 through) -> DIN B (for sending the notes from Logic to Neutron)

I hope that helps…

2 Likes

@hherz thank you very much, this does sound extremely promising. I will test this setup and report back as soon as I will be able to get back to my studio in about one weeks time.

Following this thread.

I got it working with a few changes.
Your Midihub Pipelines did not work for me. It seems I need to have a From USB A to DIN A, otherwise I do not get Audio in Logic.

Thanks again, I did not know the external instrument plugin. It appears you can also access it when you add an external midi instrument track by clicking the respective checkbox.

1 Like

Glad to hear it worked!!! :partying_face:

Have fun exploring!!!

1 Like