Trouble importing PD patches from usb


#1

Hi everyone, first post here.

I’ve had no problem running the 14 PD patches from the Pisound collection using my Android app. But I can’t seem to get the app to recognize any patches via USB. I’ve tried a “puredata-patches” subfolder on the thumb drive, as well as just placing patch as “main.pd” in the main folder of the drive.

I’ve updated Pisound and confirmed that PD was installed. Could it be an issue of formatting the drive? I’m running Raspbian on the Pi, but pulled PD patches onto the usb via my Mac desktop.

I’m sure it’s something simple, but I couldn’t figure it out based on related posts. Thanks in advance for any help!


#2

Hey, can you browse the USB disk manually on Raspberry Pi? If so, the file system on the drive probably is not the problem.

Could you post the output of running this command on Raspberry Pi in a terminal here?

/usr/local/pisound-ctl/usb_import.sh

#3

I am able to view the drive’s contents on the pi. Will try this when I get home. Thanks!


#4

Ok, here’s what I got back:

pi@raspberrypi:~ $ /usr/local/pisound-ctl/usb_import.sh

Starting USB import at /media…

Found “EFI”…

Looking for Pure Data patches in /media/EFI/puredata-patches…

/media/EFI does not contain puredata-patches…

Found “Mac OS X Install DVD”…

Looking for Pure Data patches in /media/Mac OS X Install DVD/puredata-patches…

/media/Mac OS X Install DVD does not contain puredata-patches…

Found “pi”…

Looking for Pure Data patches in /media/pi/puredata-patches…

/media/pi does not contain puredata-patches…

Done! Thank you!

The connected drive is named “My Cube” and the terminal response didn’t mention it.

Thoughts?


#5

Are the files reachable inside /media directory when you manually browse it? Are they under /media/pi/… ?


#6

Yes, that’s where they are located, and i can see them by browsing the Pi


#7

Are they available in /media/pi/puredata-patches, or is there more folders inside ‘pi’ (as in /media/pi/…/puredata-patches)? In other words, what’s the full path to puredata-patches on your usb drive?


#8

I tried this path and other variations with no luck.

Ended up reflashing my SD card, this time using the Mod Duo image. I was able to begin configuring the Pi, but I’m stuck with a Warranty message.
Unfortunately I know of no good way to copy and paste the msg from the Pi without leaving terminal…


#9

Use ssh to run terminal commands on Raspberry Pi from your own computer: Raspberry Pi: Remote Control Raspberry Pi via SSH

Then you may easily copy the screen output as needed.

Sorry, I meant to find out what was the full path to puredata-patches on your system, I suspected the USB storage was getting mounted to a place where our usb_import.sh script does not expect it, and therefore fails to import the patches.