SysEx sending problem with Prophet 12 synth + Prophet 12k pro(sound editor)

Hey guys, I have a simple configuration where a Prophet 12 synth with MIDI in/out connected to MidiHub. And I create 2 pipes, 1 from MIDI to USB, the other from USB to MIDI.

Everything seems to work fine except when I wanted to save the settings from the editor to the synth. The LED of MIDI out only flashed like 1 sec. The LCD on the synth said it was receiving the SysEx data but never ended and the connection was lost. I need to stop receiving the data to get back the connections. And the change wasn’t made. The same steps work fine with pure USB-USB connection.

Any suggestions on this issue?

Does this happen 100% of the time? What is the host OS you are using?

Yes it is 100% happening.
The host OS is macOS Catalina 10.15.5

I also tried to update the editor and the firmware but still the same.

And I tried Roland UM-ONE mk2. It also worked.

We’ll look into this issue, thank you for reporting it. :slight_smile:

1 Like

Thanks fo the quick response!

firmware 1.11.6 introduces another issue.
The editor will hang once midihub is turned on.

Have flashed back to 1.11.5

The Prophet editor hangs? Does it try to open the MIDI ports as soon as the system detects Midihub, or do you have to manually click ‘open’ in the software?

I should have been more accurate.

The app itself wasn’t hang but almost all the buttons in the task bar didn’t response while clicking them. As long as I switch off midihub the issue was gone immediately. Seems something unsynced or occupied which caused the editor not able to move forward.