Sunvox on Patchbox OS?

Hi there!

I’m wondering if anyone has managed to have Sunvox (the modular synth and tracker tool) running on Patchbox OS?

I’m on a Raspberry Pi 4. If I use the default Raspian OS, Sunvox works fine. But on Patchbox, when I launch it by double-clicking the file, it doesn’t do anything.

I tried to launch it via the console and got this error:

patch@patchbox:~/Downloads/sunvox/sunvox/linux_arm_armhf_raspberry_pi $ ./sunvox
./sunvox: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

What’s that libSDL2 thing and how do I get it?
Is that something I can install via the apt thing? If so, what would be the command?

(I’m fairly new to Linux. Sorry if it’s a very basic question.)

Trying to launch miRack (a VCV Rack fork for Raspberry Pi and other platforms) causes a similar error message but with a different library?

$ /opt/miRack/Rack 
/opt/miRack/Rack: error while loading shared libraries: libGLESv2.so: cannot open shared object file: No such file or directory

How do I install this libGLESv2.so thing?

(if you prefer, I can ask this question in a separate post)

Hey, see https://warmplace.ru/forum/viewtopic.php?f=16&t=4454 (found it by digging through SunVox manual)

Looks like you have to install libsdl by doing:

sudo apt install libsdl2-2.0

or using the GUI tool as shown in the link.

For miRack, see: https://github.com/miRackModular/Rack#raspberry-pi-notes

Looks like you have to enable the GL driver using sudo raspi-config

1 Like

It worked for Sunvox. Thanks a lot!

As for miRack, I think it might be incompatible with the RPi 4. I tried it on regular Raspbian (not Patchbox) and have the same error. I will try to contact their developer.

Update: I managed to have miRack running. I installed a bunch of packages until it worked. I’m not sure which one made it working. I’m just glad miRack is working on Patchbox.
The one command that made it work was this one: sudo apt install libgles2-mesa-dev
I don’t know which of its multiple dependencies was actually the one required.

The following additional packages will be installed:
  libegl-dev libgl-dev libgles-dev libgles1 libglx-dev libpthread-stubs0-dev
  libx11-dev libxau-dev libxcb1-dev libxdmcp-dev x11proto-core-dev
  x11proto-dev xorg-sgml-doctools xtrans-dev
1 Like

Might be this one :slight_smile: The -dev packages install also the files required for compiling software. That was the single non-dev, and non-docs package.

1 Like

Nope, just libgles1 is not enough. After a few more trial and error, it seems libgles-dev is the required one to get miRack working. So, for anyone reading this, you need sudo apt install libgles-dev

I’m still waiting on a reply from miRack’s dev for a better answer, but it seem the project has been abandonned :frowning:

So, for anyone reading this in the future, here’s the recap answer:

For Sunvox, you need to install libsdl by doing this:

For miRack, you need to install libgles. The basic package is not enough, it seems we need the dev package. So you need to do this: sudo apt install libgles-dev

Enjoy your new toys!