Sound being Distorted

Hi guys, all Sounds that I send trough my pisound sound badly distorted. It isn’t an input-level issue - I send audio from my octatrack to pisound and use modep. Is there anything, I can do? Cheers, Thomas

Pi output sounds good but all signals that I send through the input sound horribly distorted… why?

Hi, did you try connecting something other than Octatrack?

On MODEP, did you connect the left and right side directly?

Hi @Giedrius I also tried out my guitar and another synth, both signals distort very badly. Connecting left and ride side on modep directly also turns the signal into distortion… I don’t know what to do.

I had this after I re-imaged with the newest MODEP. However, I just rebooted the Pi and unplugged everything. It went away after that. It was definitely not a guitar cord/amp issue. And everything was connected, just an annoying distorted buzz; not the kind any player seeks from an effect either.

Did it work well before? Did you change something on the system that could have an impact?

I baked an SD card with your MODEP-Image and tried at first the stereo output of pisound. The output works fine but the input crunches all signals I send in it… I don’t know how to get rid of the issue.

Thanks to @bears34egc - I’ve also tried the latest MODEP image but there is the same issue.

I’m trying to use pisound as an effects unit and it isn’t working for me at all. Please don’t let me down guys.

Im using the latest modep image (beta) and seems fine, as long as I get my gain levels correct for both input and output.
Ive noticed its pretty sensitive to input gain on the PiSound, I usually have to turn it down. (or perhaps this is because my input signal is pretty hot)

note: generally digital devices can be sensitive to input levels… and if you push them, you will get crunch digital distortion which is not particular nice.

how did you test this?

heres a test i did, to help me check gain levels required etc - and it showed no distortion:

  • use an Axoloti to generate a pure sine tone, connect it to my computer , ensure the gain levels from Axoloti and my audio interface did not clip . ( I used a VST Oscilliscope to look for clipping) - maximise gain levels on both, but without clipping
    (important to know the things you are using to measuring is properly gain staged)
  • connect the Axo to PiSound, and piSound to audio interface, have modep just pass audio thru.
  • adjust input gain on modep to ensure no clipping, then again can maximise output level on modep
    (of course, this is for testing, in normal use I back it all off a bit to give me some spare headroom)

obviously you could substitute the Axo with anything that can generate a sine tone, which I find is for me the easiest to both see and hear clipping with.

(note: I did a bit of a frequency sweep too, and seemed ok still)


Don’t worry, your Pisound is covered by warranty, if it is necessary, it will get replaced with another unit.

But before that, we have to confirm that this is a hardware failure.

thetechnobear posted some useful instructions on how to debug this. I would add to his response that there’s a clip LED for input available on Pisound. Please check if it is lit up, and reduce the input gain knob until it is no longer lit (use as loud input signal as you can, while still keeping the clip LED unlit). Let us know how it goes.

In general, you should always try to keep the Input Gain on the lowest position as you can, and use the controls of the device you have connected to the Input to adjust its output volume.

1 Like

Thank you so much! I’ll try it out in the afternoon! Cheers, Thomas

I’m also now having the same issue. I have tried tweaking the GAIN down to absolute minimal. But it’s still very much buzz/feedback laden…?

Did it work well before? What changed since then?

Nothing has changed. The manner in which I am using it, and the equipment is the same. I just put it away and then every time I’ve brought it out to reuse, it’s uncontrollable noise in the signal as soon as it’s included. I’ve tried to see if everything is on tight still and it appears to be so.

Is the Clip LED lit up when this is happening?

Is this the RED LED just off above and to the left of the Gain POT?. If so, yes this is Red and Solid. As is the raspberry pi Solid Red

Yes, that’s the one. It should be normally off to get distortionless sound.

Could you please describe the behavior of the LED you’re seeing, like is it always on, regardless of whether something is connected to the input and the Gain pot value?

It goes red as soon as I put the 1/4 jack into the IN jack. It doesn’t stay solid red until I start playing. When I cover my pickups it turns off. I think it detects any audio in the signal and then goes solid red? And then of course, while it’s solid red, it sounds awful tinny distorted, Even with no “virtual” effects

It lights up as soon as it detects a too loud (clipping) input signal. The gain pot and/or the output volume of the device which was connected should be reduced until the LED does not light up anymore, even when playing louder sounds to the input.

Also, try checking if you can get the LED to stay off when you have some other device connected.

i think this might be the best place for this question. Is it possible to adjust the gain settings? is the gain setting linked to the software running in my case the latest Modep image released on this site or is it native to the hardware (pisound)?
Im trying a new layout; an analogue drum machine ( drum brute) into the pisound. I have the gain turn down to minimal but i have to reduce the master volume of drum machine in half to avoid clipping but this leaves me with a quite output signal from the pi sound. the same issue with another piece of synth gear i have ( deluge ) approx 3/4 volume out is required to reduce clipping.
BTW if i can get a decent volume out of this without re amping the signal after the pisound it will be sweet. The drum machine has separate mono outs, that means using one pisound i can effect two voices of the drum machine independently by setting up a left and right pedal board in Modep and panning outputs of drum machine hard left and right… delayed stereo hats and distorted kick , yes please :slight_smile:

I tried another guitar. Same effect. I’d be interested in @Randomaztec’s comment about Gain being linked to software? B/c in the time I used the original MODEP I had no issues with this undesirable clipping.