Problem MODEP RP4

I have problem installing MODEP on RP4.I got a lot of messages like this

ome packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

Depends: modep-mod-ui (>= 1.8.1-1) but it is not going to be installed

For some reason all messages can’t be posted here.
Patch box image is latest, also tried reflash the sd card.Tried install manualy wit sudo apt install but same result.

What output do you get from these commands:

lsb_release -a
cat /etc/apt/sources.list.d/blokas.list

I’ve just tried uninstalling and reinstalling modep, it seems to be ok.

Here is the result of the commands.I don’t unerstand what they mean.I’m linux newbie :slight_smile:
patch@patchbox:~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster
patch@patchbox:~ $ cat /etc/apt/sources.list.d/blokas.list
deb rpi main

You’re using an older PBOS image, based on Buster. Get the Bullseye one from here: [Beta] Patchbox OS image 2022-05-17, or if you want to stick to Buster, do the change in the latest comment in that thread.

Thank you!Now it’s installed.I downloaded patchbox image some 2 months ago from hackster site link and didn’t pay attention that it’s from 2020.

1 Like