Pisound installation/compilation error on Aarch64

#1

Hi there !
I have a Raspberry Pi 3B+ and I needed a 64 bit compatibility for one of my projects.
So I installed Aarch64 on my Pi and it works all fine after a bit of work. Here is a screen of the present uname -a return :

Linux rpi 5.1.14-1-ARCH #1 SMP Sat Jun 22 20:03:35 UTC 2019 aarch64 GNU/Linux

Now I tried to install the Pisound software manually, I saw in this post that there should be no compatibility problems.
I cloned the pisound repo to my /home directory, changed gcc-4.9 to gcc in /pisound-btn/Makefile, did cd pisound and ran make
It didn’t work and returned this error message:

I tried to replace dirname by ttyname as suggested by the compiler but this was followed by another error and I didn’t wanted to go down that road :stuck_out_tongue:

I have absolutely no idea what to do as I don’t understand much about the Pisound source code and don’t know this bug.
Thanks a lot in advance for your help guys :slight_smile:

0 Likes

#2

Try adding #include <libgen.h> at the end of all includes in pisound-btn.c:

...
#include <poll.h>
#include <time.h>
#include <assert.h>
#include <libgen.h> // <--
0 Likes

#3

Thanks ! It worked !

1 Like