Pisound after first installation

Hello together,

I bought a RPi4 and a Pisound (v1.1) and installed the Patchbox OS.
Pisound did not show up as a hotspot but the setup worked fine via Ethernet cable.

Actually using the Pisound after 1st installation was not possible up to now(headless mode with MacBook).
It is not reachable with a plug in Ethernet cable nor via WiFi.
Pressing the button does nothing, no leds blinking etc. to me the shield looks inactive.

I am not sure how the RPi4 and the Pisound should react after providing power (how should the leds react etc.)

Has anyone an idea or can provide a meaningful link or something?

Thanks in advance!

P.s. another newbie one: does the SDcard needs to stay in place or is it only necessary for installation?

Try running this command:

aplay -l

If it’s recognized, you’ll see it listed.

If it’s not, run this command:


It will print the kernel output. Either copy the contents and paste it here for us to see, or run dmesg > dmesg.log to get it into a file and upload it here. Use scp to copy it over to the host computer.

Btw, the WiFi should run without Pisound attached at all if running Patchbox OS image - if no ‘Patchbox’ WiFi is showing up after booting up, maybe there’s something up with the Pi4 board itself.

Hi and thanks for the reply.

aplay -l

is not working.

Here is the dsmeg output …

fed by entitlement for pid 27422sb_user_approval: kTCCServiceSystemPolicyAllFiles for Spotlight [27422]sb_user_approval: kTCCServiceSystemPolicyAllFiles satisifed by entitlement for pid ...

EDIT: after I got the solution I erased rest of dmsg output for better readability of post, because was only from my computer and not from the Pi.

Oh, looks like I misunderstood something, I thought you had access to the Pi itself. :slight_smile:

Does the ethernet LEDs blink when the ethernet cable is connected? If not, then it seems like the SD card may have been prepared incorrectly. Could you try flashing it again? What method did you use for it? Try using this image:

1 Like


I run the same process described under First Run Options - Patchbox OS Documentation but now with your img.
1st try with the “old” img with option 02 with Ethernet cable, now with option 03.

Thanks a lot!

Using “startx” in the terminal window does not start the desktop, I can see it only via VNC. Is this correct?

Best regards,

1 Like

Which terminal window?

The one from my laptop computer, the one I also initialized the patchbox os installation via ssh.

The startx command starts the GUI on the system, it’d be visible if a monitor is attached to it, or via remote desktop software VNC.

1 Like

Thanks. Understood!

1 Like