Patchbox OS image 2020-03-14 (and MODEP)

Yes, it’s possible to install MODEP on Raspbian:

  1. Set up our apt server:

    curl https://blokas.io/apt-setup.sh | sh
    
  2. sudo apt install modep -y.

    While the Jack backend is being installed, answer ‘yes’ to the realtime priority question asked (‘no’ works too, the answer you give doesn’t really matter for MODEP, as it’s started using systemd services)

  3. Edit /etc/jackdrc to set the command line for Jack backend, if you are using a different card than Pisound.

  4. Ensure that all the critical services are running, if one of them failed, the UI won’t be accessible. Start fixing from the jack service errors, then modep-mod-host and finally modep-mod-ui. Most likely cause of issues is Jack misconfiguration.

    sudo systemctl status jack
    sudo systemctl status modep-mod-host
    sudo systemctl status modep-mod-ui
    

    Use start or restart instead of status in above commands to start the services. Use sudo journalctl -u jack and similar to see the full output logs.

  5. To get MODEP to autorun on startup run:

    sudo systemctl enable modep-mod-ui
    
1 Like

Perfect - thanks for the detailed response!

Lovin’ it.
Got it up and running with a Pisound 1.0 and RPI 4.
Everything seems to be good, except BOTH kernels, stock/realtime, disconnects the bluetooth/app.
Is there another workaround, or do we have to wait for a bluetooth bug fix?

Right after I posted that last one about a bug fix I did an apt upgrade it found some bluetooth updates. I reboot and re-paired it and NO MORE CONNECTIVITY DROPS.

patch@patchbox:~ $ sudo apt-get upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages will be upgraded:
bluez libbluetooth3
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 857 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y

1 Like

Thank you for reporting this, did BT connections work well even when using the realtime version of the kernel?

This is what I’m seeing now. I burned a fresh image, updated patchbox, and configured jack to use pisound: 48000, 128, 2

After I power-on the jack service is dead, but it runs if I start it.

How to debug?

hey @joebowbeer,
don’t think this is a bug.

There is the concept of modules:

After I activated the Pure Data Module and restarted the Pi,
Jack was starting up automatically, and works fine at many different settings …didn’t try all combinations :wink:

Hey, yes, it get started when a module that depends on it is started, but it makes sense to keep it running even if no module is selected, I will release a fix for this today, in the mean time, you may run this manually:

sudo systemctl enable jack
sudo systemctl start jack

Thanks @Giedrius and @tob_har

“systemctl enable jack” did the trick.

I was expecting that selecting puredata in modules and then selecting a patch to launch would make it so that this patch was loaded on reboot, but that is not happening. I still need to run patchbox or use the app, or I guess another option is to copy the patch to a thumb drive and click once to load it.

Yes, it should open automatically, there was a bug which I just fixed - patchbox-init.service was missing. Run patchbox update to get this resolved. :slight_smile: Thank you for reporting it.

Problems solved! After updating, my selected patch loads automatically after reboot, and jack is running, too.

2 Likes

Hello,

From my side, I#d like to say I also experienced the bluetooth problem mentioned by @Giedrius and, before taking the drastic decision of updating the kernel, I ran sudo apt-get update, after verifying that patchbox update was already at the latest state. In my case, there were a bunch of libraries that got updated and, similarly to @mistymountainblow, libbluetooth3 was among them (though not bluez). That seem to have done the trick for me: no drops so far. I get now:

patch@patchbox:~ $ apt-cache policy libbluetooth3
libbluetooth3:
  Installed: 5.50-1.2~deb10u1+rpt1
  Candidate: 5.50-1.2~deb10u1+rpt1
  Version table:
 *** 5.50-1.2~deb10u1+rpt1 500
        500 http://archive.raspberrypi.org/debian buster/main armhf Packages
        100 /var/lib/dpkg/status
     5.50-1.2~deb10u1 500
        500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
1 Like

Hi, I have installed the new update but had several errors.
Now I cant open patchbox-config now.
As a version I get:
Linux patchbox 4.14.91-rt49-v7+ #1 SMP PREEMPT RT Tue Feb 19 15:51:26 EET 2019 armv7l

patch@patchbox:~ $ sudo patchbox-config
Traceback (most recent call last):
  File "/usr/local/patchbox-cli/patchbox/cli.py", line 2, in <module>
from patchbox.utils import PatchboxHomeGroup, PatchboxChoice, do_group_menu
  File "/usr/local/patchbox-cli/patchbox/utils.py", line 10, in <module>
from dotenv import load_dotenv
ImportError: No module named dotenv
patch@patchbox:~ $

Edit:
I can access the Pi through startx though, so I see the graphical env, hmmm any ideas what I could do? Reinstall Patchbox?

Hey, see my latest reply this thread: No module submenu?

Oh thanks for the quick answer! I guess then I can simply Download the new Image, and make a fresh install? Thanks a lot!

Yes, you have to flash the 2020-03-14 version image.

Hi, i used to use th last patchbox os with pisound board on rpi3b+, and since i burn a new sd with the new image, the system as often unexpective bug that force me to unplung the power; do you know something about that? (i hadn’t that kinde of probleme with the last version, so i charged a old version of patchboxos but when i updated the system to load orac bridge, patchbox parameters in ssh is not availaible…)

We didn’t see anything like that, we’ll need more information to know what’s going on.

You’ll have to enable persistent logging, so after the system crashes, the logs are still available:

sudo nano /etc/systemd/journald.conf

Edit the file, so that #Storage=auto line looks like this:

Storage=persistent

Hit Ctrl+X, to exit, press Y to confirm saving your changes.

Then restart the system (sudo reboot), and once the crash occurs, on the very next boot after the crash occurred, you can access the log of that session by running:

journalctl -b 1

It can be saved to a file by doing:

journalctl -b 1 > crash.log

Then you may share the crash log here for us to investigate what’s going on.

thank you, i juste made it, so… wait and see!

Hi,
What a great job you have done here ! :+1:
Have build a Modep pedal with a Pi 3B + Pisound + the case + the the last Patchbox image => it works fine on the first start… - Thank you for all !

Just find this issue while loading a pedalboard : as saving a pedalwork, it is ok, no error message - but when loading it, Modep refuse and display an error => can’t load the pedalboard because plugin missing
My Patchbox is 100% stock, no change

If the pedalboard is empty (no modification on the defalt empty pedalboard), error is still the same
Only the 4 default pedalboard can be loaded, not a modified and saved one

Thank you - Marc