No sound from pisound?

pisound arrived the other day, but so far I can’t get any sound out of it.

I’m running a fresh raspbian install. I installed the software without incident, and aplay -l shows the expected output.

speakertest -Dsysdefault -c2 shows audio is being generated, but i cant hear anything from the output, even with volume turned up full.

speakertest on the normal rpi output works fine.

(aplay -L shows sysdefault points to pisound)

the audio test in puredata doesn’t fare any better (though turning up the gain does show something on the audio inputs).

What should I look at? The alsamixer just shows PCM channel for the pisound, and it seems to be locked at 100%


Hi, first thing would be to make sure that all the pins are making good contact. You may try unmounting Pisound while RPi is off, mounting it again with applying slight pressure on the header pins, and testing again.

If that does not help, pin 40 on Raspberry Pi is the one responsible for transfering PCM data to Pisound. Would you be able to measure using oscilloscope or multimeter whether there’s any digital signal flowing on the pin while aplay or speakertest is sending output data?

Hi, I have the same problem here, I’ll see what the scope tells. Meanwhile, as this topic is marked to have been solved, what did the trick ? :slight_smile: Cheers, Jeroen

It was solved by taking Pisound off and putting it back on again as described above. :slight_smile:

1 Like

Ok, alas that doesn’t work here. Scope time!

What command or software are you running to get audio output? Does it successfully start up?

Audio software on Linux usually takes exclusive access to audio devices, so if some other audio software is running in the background, it may be blocking the audio.


#/> speaker-test -Dsysdefault -c2

gives no sound.

#/> aplay -L
shows pisound as default sound card.

#/> aplay -V=mono -Dsysdefault lxa.wav
keeps playing for the duration of the file but gives no sound

jackd is installed and seems to function when called, and scsynth is working in software (it shows up, and can be addressed), but gives no sound either.
But with jackd running or not running does not make a diff for speaker-test.

This is on headless Raspbian Stretch with a

Linux RT_PI_SOUND 4.9.43-rt30-v7+ #1 SMP PREEMPT RT


Does dmesg report any errors?

What is the RT_PI_SOUND in the version? :slight_smile:

After a power cycle (a sudo reboot actually gives me a closed ssh port), dmesg shows a warning::

[ 13.241610] WARNING: CPU: 1 PID: 66 at kernel/irq/handle.c:149 __handle_irq_event_percpu+0x2a4/0x2c4
[ 13.241622] irq 183 handler irq_default_primary_handler+0x0/0x1c enabled interrupts
[ 13.241629] Modules linked in: spidev brcmfmac brcmutil cfg80211 snd_soc_pisound snd_rawmidi snd_seq_device snd_soc_bcm2835_i2s snd_bcm2835 snd_soc_core snd_pcm_dmaengine snd_pcm snd_timer snd bcm2835_gpiomem spi_bcm2835 uio_pdrv_genirq uio fixed ip_tables x_tables ipv6
[ 13.241708] CPU: 1 PID: 66 Comm: irq/79-3f200000 Not tainted 4.9.43-rt30-v7+ #1
[ 13.241712] Hardware name: BCM2835
[ 13.241738] [<8010f6b4>] (unwind_backtrace) from [<8010bbbc>] (show_stack+0x20/0x24)
[ 13.241753] [<8010bbbc>] (show_stack) from [<80472d84>] (dump_stack+0xbc/0x108)
[ 13.241775] [<80472d84>] (dump_stack) from [<8011cc34>] (__warn+0xe8/0x114)
[ 13.241792] [<8011cc34>] (__warn) from [<8011cca8>] (warn_slowpath_fmt+0x48/0x50)
[ 13.241807] [<8011cca8>] (warn_slowpath_fmt) from [<8017529c>] (__handle_irq_event_percpu+0x2a4/0x2c4)
[ 13.241822] [<8017529c>] (__handle_irq_event_percpu) from [<80175310>] (handle_irq_event_percpu+0x54/0x94)
[ 13.241834] [<80175310>] (handle_irq_event_percpu) from [<801753c4>] (handle_irq_event+0x74/0xb8)
[ 13.241847] [<801753c4>] (handle_irq_event) from [<80178fe4>] (handle_edge_irq+0x138/0x220)
[ 13.241861] [<80178fe4>] (handle_edge_irq) from [<801741d8>] (generic_handle_irq+0x30/0x44)
[ 13.241877] [<801741d8>] (generic_handle_irq) from [<804a0fcc>] (bcm2835_gpio_irq_handle_bank+0x88/0xb8)
[ 13.241894] [<804a0fcc>] (bcm2835_gpio_irq_handle_bank) from [<804a1048>] (bcm2835_gpio_irq_handler+0x4c/0xa8)
[ 13.241908] [<804a1048>] (bcm2835_gpio_irq_handler) from [<8017653c>] (irq_forced_thread_fn+0x30/0x64)
[ 13.241921] [<8017653c>] (irq_forced_thread_fn) from [<80176810>] (irq_thread+0x118/0x1e8)
[ 13.241936] [<80176810>] (irq_thread) from [<8013c6ec>] (kthread+0x108/0x124)
[ 13.241952] [<8013c6ec>] (kthread) from [<80107cf0>] (ret_from_fork+0x14/0x24)
[ 13.241958] —[ end trace 0000000000000002 ]—

No change after running speaker-test. RT_PI_SOUND describes the realtime patches in the stretch kernel.

Please try testing audio using regular kernel. The kernel shouldn’t be throwing warnings, there may be some issue in the patched kernel.

will try and keep you posted. tx

A post was split to a new topic: No sound in MODEP