No reboot on shutdown

I got Patchbox OS installed today and things were great. Love the new WiFi capability that wasn’t available the last time I tried MODEP on its own.

When my device shuts down, however it will never restart. I had things up and working and then moved the device and once I plugged it back in, I see the red light, then nothing. It never moves on.

Any fixes for this? Sound like a known issue? Using a Pi 3B with PiSound and Patchbox OS, downloaded the day of this posting.

Sometimes the SD card simply gets corrupted, and it seems to happen in relation to power supply connects / disconnects or in case you get undervoltage / yellow lightning icon warnings. A lot of times this situation can be recovered from by inserting the SD card to a Windows system, and once it gets recognized and the drive volume appears, safely ejecting it and putting it back into the Raspberry Pi. Raspberry Pi’s bootloader does not seem to be able to resolve the issue on its own.

If this doesn’t help, you’ll have to reflash the sd card.

Appreciate the reply. So - do folks generally leave it on? Or is this something folks need to do often, and it’s just - that’s the way it is sort of thing?

This happens very rarely, also make sure to use a decent power supply. Also, prefer unplugging the system from the electrical socket side, it should cause less transients than disconnecting the connector on Raspberry Pi side. It’s safe to disconnect on RPi’s side once all of the LEDs go dark.

I’m having this issue, too. Deleting the .lib files that are created by the system in the “boot” partition lets me restart Patchbox, but this requires me to take the SD card out of the PI and put it into my Windows PC every time I shutdown, which can’t be good for the card.

Probably just putting it into a Windows computer and safely removing it is enough, as it does a quick file system fix if necessary during that time. I never had to remove any files to restore the SD card to a working state.

Make sure that you are safely shutting down the Pi and you unplug it after the green LED is done flashing. Also make sure the power supply provides adequate current, >= 2.0A.

Thank you for your quick reply! :slight_smile: I will try with a different SD card and see if that fixes anything.

At first I thought it was a temperature issue, but even leaving it all night didn’t let it boot back up (it hung on solid red light). This is regardless of whichever module is activated.

So far the only thing that has worked is removing the microsd card and removing recovery.bin via Windows.

I am loving my time with patchboxOS and pisound… It really is opening up entire new worlds of music joy for me… I just need to work out the no boot issue here.

Thank you again!

EDIT: Oh happy day! Updating to the beta version of Pisound via sudo apt etc seems to have fixed this (as described here). Thank you for keeping up with the development of patchbox. I’m sure you know already how revolutionary this is for people like me who enjoy dabbling with the Raspberry Pi but don’t want to compile our own kernels or whatever.


When my Rpi3B+ and Pisound were brand new I didn’t have this issue as long as I shut it down correctly, but now I am running into the same problem: In spite of using a 2.5A power supply, and cutting power after the Rpi is fully shut down, either by using halt or holding the button, my USB stick(s) will almost always fail to boot back up. Plugging the stick into a windows machine won’t always work either.

I’m not doing anything unique besides trying to run modep with the suggested hardware settings, and I’ve been using the 2020-11-23 release of patchbox OS.

I’ve booted the Rpi from SD cards before but I’ve had two get permanently write-protected and figured USB sticks would be more robust… Currently I’m using either a usb 2.0 kingston 16gb stick, or a kingston 3.0 64gb stick, both lightly used.

Any ideas what could be wrong?

Do you get any errors on boot up in the monitor? You have to look for whatever diagnostic information you can get out of the system.

When it fails to boot nothing at all shows up on the monitor.

As for any error messages during boot-up after I’m able to recover the USB stick image I’ll have to get back to you - it may take me a few re-flash tries to get a working image, then a failed boot, and then a successful recovery.

I’ve browsed the Rpi forums and saw that booting from a USB stick can cause issues if there are other devices plugged into the usb ports. I’ve been plugging in my midi controller via the usb so I tried booting without it plugged in and it worked :smiley:

Since this did seem to fix my problem it appears that my issue is totally different from the OP…

Not sure if there’s any way to have both a USB stick image and other USB devices plugged in but for this reason I’m switching back to microSD cards, at least for now. Thanks Giedrius

1 Like