No module submenu?

Hi there, trying to get set-up using orac+pisound on RaspberryPi 3 - I’ve installed patchbox and can ssh in (incidentally the pisound app on my samsung is working fine) … but basically there is no “module” submenu? So I’m at a loss how to even get started - might be being dumb as been at it too long… I had some errors when running apt update too - maybe that has something to do with it?

Thanks for any help - looking forward to getting into this…

Got a feeling problem is pi not connected to internet, tho i thought it was from wifi status… will have a dig but any advice in meantime appreciated.

No idea. Still no modules submenu?

However, using apt-get install orac I have at least installed orac and have the default drum sounds coming out… will try to sort a remote/ctls out.

Well, I do need some help it seems… I’ll try @thetechnobear - I don’t want to bother anyone but I’m kind of stuck.

So I installed directly using “apt-get install orac”

I couldn’t seem to connect the pd remote from my desktop (tried both “patchbox.” & ip address: connection refused 61), so I tried it on the pi thinking that would be fool proof (“patchbox.local” & connection refused 111)

So I thought there might be an issue with MEC, used systemctl to make sure it was running, and check status… so it seems to be running fine - and then when I tried from my macbook, using pi’s IP as hostname - pure data asked me to confirm connection - so thought it was all good…

But the remote client still just shows “serial” up top, nothing I do there makes any difference.

Hope someone can help, if not I’ll just have to design some completely idiosyncratic seeqosynthesisystem that works for me but no-one elfs, which is sort of what i was up to before :slight_smile:


After running Patchbox OS, you must first do ‘update’ in the patchbox config utility, after that the ‘modules’ section should be present.

Also, after ORAC is installed through the patchbox config utility, make sure that MEC is running, as noted here: Orac 2.0 for the Raspberry PI

Hi @Giedrius thank you for your reply.

I see no “update” option in the patchbox-config. So I try “apt update” instead, which gives me the suggestion to follow up with “apt list --upgradeable”… So what I have done is try “apt upgrade” - this seems to be working! Maybe we got the word/command wrong?

Please note if this is the case it’s “upgrade” & not “update”.

If this works I swear I’ll make a happy song. It will be so happy millions will flock to pisound their oracs.

It worked! Or enough for me. I still don’t have a “modules” section in “patchbox-config” - not sure what the issue is there? I tried rebooting to see if that made a difference but no… Anyway now I can connect to orac via the pure data remote from my laptop, so I’m happy, thus next time I have some time to kill I shall endeavour to kill it with a happy song, indeed.

Any progress on this thread?

I have the same issue. I run “sudo apt update” no problems.
Then when I run “sudo apt install -y patchbox-cli” I get this message:

Hey, looks like you’re running the old version of Patchbox OS, please use the OS image from this thread: [Beta] Patchbox OS image 2020-03-14 (and MODEP)

Unfortunately a soft upgrade is not possible, same as when Raspbian changed from ‘stretch’ to ‘buster’ distribution.