MODEP on raspi5

Is there a way to install MODEP on a raspi5/ 64bit (bookworm)? If so, is there a simple guide to do so? Also, how am I to access the modep UI? Please, I really need advice here as I am a total newbie :-)…

@ELEN_ELEN Welcome to the Blokas community!

There is no “official” support for MODEP yet on a RPi5/Bookworm but some have done this successfully. See the topic post here that contains steps to set up MODEP for RPi5/Bookwoom:

Once you have that installed you should be able to point your browser to https://patchbox.local to access the UI.

1 Like

Thank you for the reply!! I just followed the steps in the post you mentioned. Modep installs successfully but I cannot find a way to access the pedalboard UI. or or patchbox.local seems not to work… any suggestions?

@ELEN_ELEN you will likely need to get the IP address of your RPi, assuming it’s on your local network (cable or wifi). Then browse to that address.

It’s convenient to just browse to patchbox.local but I’ve found in my experience that does not always work.

The strange thing is that I am trying to get it to work on my pi5 connected display. I use the integrated chromium browser, and still no access to the pedalboard UI…

What is the output of the following commands?

sudo systemctl status jack
sudo systemctl status modep-mod-host
sudo systemctl status modep-mod-ui
1 Like

So, I did all the tests and it seems that it asks for the pisound hardware. I did borrow a pisound from a friend. Once the pisound hat is installed, MODEP runs smoothly and with remarkable performance. So, the question is, what have I to do in order to make it work with my Scarlet Solo? Is there a way to configure MODEP to work with other soundcards?

And also, how can I change the buffer or sample rate with or without the pisound?

@ELEN_ELEN I have this exact same situation. I actually have 2 MODEP setups, one is on my pedalboard that I use for playing live (my “production” setup). I also have another MODEP setup that uses a Behringer USB guitar interface that I use for practicing (my “practice” setup) so I don’t have to break out the full pedalboard.

With your Scarlet plugged into the Pi, run the aplay -l and arecord -l commands. If your Scarlet is recognized somewhere in the output of those commands you should see the interface mentioned. For example, here’s the output on my practice setup:

**** List of PLAYBACK Hardware Devices ****
card 0: vc4hdmi0 [vc4-hdmi-0], device 0: MAI PCM i2s-hifi-0 [MAI PCM i2s-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: vc4hdmi1 [vc4-hdmi-1], device 0: MAI PCM i2s-hifi-0 [MAI PCM i2s-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 3: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

arecord -l:

**** List of CAPTURE Hardware Devices ****
card 3: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

The output doesn’t specifically say “Behringer” but you can see the CODEC hardware devices listed, which is probably what you want to look for. Once you see the number listed above, you will want to edit the following file:


and replace hw:pisound with hw:3,0 (or whatever number your interface shows above). Once that has been updated restart jack with the following command:

sudo systemctl restart jack

Then restart MODEP with the following command:

sudo systemctl restart modep-mod-ui

That is also done in the /etc/jackdrc file. Be aware that changing the sample rate will change the way many plugins react on the sound. I use these settings with a sample rate of 48 kHz (-r) and only varying buffer size (-p) and number of periods (-n).

exec /usr/bin/jackd -t 2000 -R -P 95 -d alsa -d hw:pisound -r 48000 -p 64 -n 3 -X seq -s

I omitted the -S switch so 32 bit is activated instead of 16 bit.

Thank you. You mean you deleted the -s at the end of the line? Also I wonder if it is possible to use hat type soundcards like the hifiberrys. By now I can verify ghat Scarlett works just fine with the configuration of jackdrc. Next test will be with my hifiberry adc dac pro. I ll report back as soon as I have some results.

1 Like

I assume you are going to plug your guitar into hifiberry. just take in notice that afaik the input impedance of hifiberry(22kOhm) will be significantly lower than desired (millions of Ohm) and will result in a reduction of high/bass spectrum of guitar tone. and you may not like the outcome

Please forgive me in advance if I say anything stupid. I’m really enjoying the process of getting MODEP up and running on a pi 5 and here’s where I’ve gotten so far:

Raspberry pi 5 with a lite command line install
Installed patchbox from the command line
Started out with a very very basic USB DAC for input and output

The DAC doesn’t like the way stereo in and out is handled and swaps the input and output channels at random. Which just means it needs to be rewired in the MODEP GUI but it’s a bit annoying.

The input from a guitar with active pickups at max volume is HOT and distorts. Ironically, it’s not an awful distortion but not what I want in a clean amp channel. Cutting the guitar output cleans it up. Next step is an attenuator pot to control that so I don’t need to mess with the guitar. It’ll eventually be mounted on a panel and I’ll be able to mark spots for the sweet spot for different guitars. To be continued.

I have an iqaudio codec zero that is going to be dropped in to take the place of the USB DAC. I’m guessing it’ll work and sound better and properly handle stereo audio for better left and right channel routing. I do not have a pisound module but it’s awfully tempting. To be continued.

Output sounds fine through the clean channel of an amp. Slightly anemic, maybe a bit staticky. Impedance mismatch is probably the culprit. Once everything above is locked in and running, I’m going to throw a reamp box between output from the codec zero and the amp. To be continued.

This WHOLE thing started when I got it into my head to control pi effects with an old line 6 longboard through an Arduino Mega to convert its proprietary signal into midi. I’m deep in the rabbit hole and there’s no way out until the project is done. But to the developers who made MODEP: y’all are AMAZING and I’m grateful you exist :pray:t2:

To answer the original question, the easiest way now is to use Patchbox OS 64 bit image and install MODEP through the patchbox utility: