Pisound for Raspberry Pi 5?

If you run the sudo rpi-update you get:

sudo rpi-update
patchbox@patchbox:~ $ sudo rpi-update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** We're running for the first time
 *** Backing up files (this will take a few minutes)
 *** Backing up firmware
 *** Backing up modules 6.1.0-rpi7-rpi-2712
WARNING: This update bumps to rpi-6.6.y linux tree
See: https://forums.raspberrypi.com/viewtopic.php?p=2191175

'rpi-update' should only be used if there is a specific
reason to do so - for example, a request by a Raspberry Pi
engineer or if you want to help the testing effort
and are comfortable with restoring if there are regressions.

DO NOT use 'rpi-update' as part of a regular update process.
Would you like to proceed? (y/N)
Downloading bootloader tools
Downloading bootloader images

 *** Downloading specific firmware revision (this will take a few minutes)
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100  142M  100  142M    0     0  2750k      0  0:00:52  0:00:52 --:--:-- 3019k
BOOTLOADER: up to date
   CURRENT: Fri 16 Feb 15:28:41 UTC 2024 (1708097321)
    LATEST: Fri 16 Feb 15:28:41 UTC 2024 (1708097321)
   RELEASE: latest (/lib/firmware/raspberrypi/bootloader-2712/latest)
            Use raspi-config to change the release.
 *** Updating firmware
 *** Updating kernel modules
 *** depmod 6.6.18-v8+
 *** depmod 6.6.18-v8-16k+
 *** Updating VideoCore libraries
 *** Running ldconfig
 *** Storing current firmware revision
 *** Deleting downloaded files
 *** Syncing changes to disk
 *** If no errors appeared, your firmware was successfully updated to a31776f0abb4bee5b79a3334bf748c99a813c084
 *** A reboot is needed to activate the new firmware

If you run the script again after updating you get this as output:

patchbox@patchbox:~ $ curl https://blokas.io/pisound/install.sh | sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1656  100  1656    0     0   3972      0 --:--:-- --:--:-- --:--:--  3980
Checking if the kernel version is 6.1.74 or newer... It is.
Importing Blokas GPG public key...
Adding Blokas APT (bookworm) repository...
Updating package list...
Hit:1 http://deb.debian.org/debian bookworm InRelease
Hit:2 http://deb.debian.org/debian-security bookworm-security InRelease        
Hit:3 http://deb.debian.org/debian bookworm-updates InRelease                  
Hit:4 http://archive.raspberrypi.com/debian bookworm InRelease                 
Get:5 http://apt.blokas.io bookworm InRelease [7,166 B]
Get:6 http://apt.blokas.io bookworm/main arm64 Packages [8,687 B]
Get:7 http://apt.blokas.io bookworm/main armhf Packages [8,677 B]
Fetched 24.5 kB in 1s (23.1 kB/s)   
Reading package lists... Done
Installing Pisound software...
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  blokas-puredata-patches blokas-telemetry libportaudio2 mec-blokas
  node-html5shiv osc2midi patchbox-wifi pd-blokas pd-creb pd-cyclone
  pd-gendyflext pd-ggee pd-iemlib pd-moonlib pd-zexy pisound-btn pisound-ctl
  pisound-ctl-scripts-common pisound-ctl-scripts-puredata
  pisound-ctl-scripts-system puredata puredata-core puredata-dev puredata-doc
  puredata-extra puredata-gui puredata-gui-l10n puredata-utils python3-urwid
  tcl tcl8.6 tk tk8.6
Suggested packages:
  nodejs pd-libdir gem multimedia-puredata pd-aubio pd-csound pd-pdp
  python-urwid-doc tcl-tclreadline
The following NEW packages will be installed:
  blokas-puredata-patches blokas-telemetry libportaudio2 mec-blokas
  node-html5shiv osc2midi patchbox-wifi pd-blokas pd-creb pd-cyclone
  pd-gendyflext pd-ggee pd-iemlib pd-moonlib pd-zexy pisound pisound-btn
  pisound-ctl pisound-ctl-scripts-common pisound-ctl-scripts-puredata
  pisound-ctl-scripts-system puredata puredata-core puredata-dev puredata-doc
  puredata-extra puredata-gui puredata-gui-l10n puredata-utils python3-urwid
  tcl tcl8.6 tk tk8.6
0 upgraded, 34 newly installed, 0 to remove and 169 not upgraded.
Need to get 20.8 MB of archives.
After this operation, 82.2 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian bookworm/main arm64 libportaudio2 arm64 19.6.0-1.2 [61.2 kB]
Get:3 http://deb.debian.org/debian bookworm/main arm64 puredata-core arm64 0.53.1+ds-2 [747 kB]
Get:2 http://apt.blokas.io bookworm/main arm64 patchbox-wifi all 1.3.0-1 [3,876 B]
Get:13 http://deb.debian.org/debian bookworm/main arm64 puredata-dev all 0.53.1+ds-2 [40.1 kB]
Get:4 http://apt.blokas.io bookworm/main arm64 pd-blokas arm64 0.1.1-4 [228 kB]
Get:14 http://deb.debian.org/debian bookworm/main arm64 puredata-doc all 0.53.1+ds-2 [1,484 kB]
Get:18 http://deb.debian.org/debian bookworm/main arm64 puredata-extra arm64 0.53.1+ds-2 [101 kB]
Get:19 http://deb.debian.org/debian bookworm/main arm64 tcl8.6 arm64 8.6.13+dfsg-2 [120 kB]
Get:20 http://deb.debian.org/debian bookworm/main arm64 tcl arm64 8.6.13 [4,016 B]
Get:21 http://deb.debian.org/debian bookworm/main arm64 tk8.6 arm64 8.6.13-2 [69.5 kB]
Get:22 http://deb.debian.org/debian bookworm/main arm64 tk arm64 8.6.13 [4,052 B]
Get:23 http://deb.debian.org/debian bookworm/main arm64 puredata-gui all 0.53.1+ds-2 [129 kB]
Get:24 http://deb.debian.org/debian bookworm/main arm64 puredata-utils arm64 0.53.1+ds-2 [22.5 kB]
Get:25 http://deb.debian.org/debian bookworm/main arm64 puredata all 0.53.1+ds-2 [13.0 kB]
Get:26 http://deb.debian.org/debian bookworm/main arm64 pd-iemlib arm64 1.22.2-3 [311 kB]
Get:27 http://deb.debian.org/debian bookworm/main arm64 pd-zexy arm64 2.4.1-4 [127 kB]
Get:28 http://deb.debian.org/debian bookworm/main arm64 pd-moonlib arm64 0.5-3 [81.3 kB]
Get:29 http://deb.debian.org/debian bookworm/main arm64 pd-ggee arm64 0.28-3 [84.8 kB]
Get:30 http://deb.debian.org/debian bookworm/main arm64 pd-creb arm64 0.9.2+darcs20151027-7 [89.2 kB]
Get:31 http://deb.debian.org/debian bookworm/main arm64 pd-cyclone arm64 0.6.1-2 [1,288 kB]
Get:32 http://deb.debian.org/debian bookworm/main arm64 node-html5shiv all 3.7.3+dfsg-5 [13.2 kB]
Get:33 http://deb.debian.org/debian bookworm/main arm64 python3-urwid arm64 2.1.2-4+b1 [181 kB]
Get:34 http://deb.debian.org/debian bookworm/main arm64 puredata-gui-l10n all 0.53.1+ds-2 [82.2 kB]
Get:5 http://apt.blokas.io bookworm/main arm64 pd-gendyflext arm64 1.0.0-1 [54.4 kB]
Get:6 http://apt.blokas.io bookworm/main arm64 blokas-puredata-patches all 1.02-1 [14.9 MB]
Get:7 http://apt.blokas.io bookworm/main arm64 blokas-telemetry arm64 1.0.2-1 [72.8 kB]
Get:8 http://apt.blokas.io bookworm/main arm64 mec-blokas arm64 0.1.1-3 [194 kB]
Get:9 http://apt.blokas.io bookworm/main arm64 osc2midi arm64 1.01-2 [13.8 kB] 
Get:10 http://apt.blokas.io bookworm/main arm64 pisound-btn arm64 1.16-1 [19.6 kB]
Get:11 http://apt.blokas.io bookworm/main arm64 pisound-ctl-scripts-common all 1.03-7 [2,600 B]
Get:12 http://apt.blokas.io bookworm/main arm64 pisound-ctl arm64 1.03-12 [286 kB]
Get:15 http://apt.blokas.io bookworm/main arm64 pisound all 1.05-1 [1,156 B]   
Get:16 http://apt.blokas.io bookworm/main arm64 pisound-ctl-scripts-puredata all 1.03-7 [2,560 B]
Get:17 http://apt.blokas.io bookworm/main arm64 pisound-ctl-scripts-system all 1.03-7 [2,232 B]
Fetched 20.8 MB in 15s (1,359 kB/s)                                            
Extracting templates from packages: 100%
Selecting previously unselected package patchbox-wifi.
(Reading database ... 125261 files and directories currently installed.)
Preparing to unpack .../00-patchbox-wifi_1.3.0-1_all.deb ...
Unpacking patchbox-wifi (1.3.0-1) ...
Selecting previously unselected package pd-blokas.
Preparing to unpack .../01-pd-blokas_0.1.1-4_arm64.deb ...
Unpacking pd-blokas (0.1.1-4) ...
Selecting previously unselected package libportaudio2:arm64.
Preparing to unpack .../02-libportaudio2_19.6.0-1.2_arm64.deb ...
Unpacking libportaudio2:arm64 (19.6.0-1.2) ...
Selecting previously unselected package puredata-core.
Preparing to unpack .../03-puredata-core_0.53.1+ds-2_arm64.deb ...
Unpacking puredata-core (0.53.1+ds-2) ...
Selecting previously unselected package puredata-dev.
Preparing to unpack .../04-puredata-dev_0.53.1+ds-2_all.deb ...
Unpacking puredata-dev (0.53.1+ds-2) ...
Selecting previously unselected package puredata-doc.
Preparing to unpack .../05-puredata-doc_0.53.1+ds-2_all.deb ...
Unpacking puredata-doc (0.53.1+ds-2) ...
Selecting previously unselected package puredata-extra.
Preparing to unpack .../06-puredata-extra_0.53.1+ds-2_arm64.deb ...
Unpacking puredata-extra (0.53.1+ds-2) ...
Selecting previously unselected package tcl8.6.
Preparing to unpack .../07-tcl8.6_8.6.13+dfsg-2_arm64.deb ...
Unpacking tcl8.6 (8.6.13+dfsg-2) ...
Selecting previously unselected package tcl.
Preparing to unpack .../08-tcl_8.6.13_arm64.deb ...
Unpacking tcl (8.6.13) ...
Selecting previously unselected package tk8.6.
Preparing to unpack .../09-tk8.6_8.6.13-2_arm64.deb ...
Unpacking tk8.6 (8.6.13-2) ...
Selecting previously unselected package tk.
Preparing to unpack .../10-tk_8.6.13_arm64.deb ...
Unpacking tk (8.6.13) ...
Selecting previously unselected package puredata-gui.
Preparing to unpack .../11-puredata-gui_0.53.1+ds-2_all.deb ...
Unpacking puredata-gui (0.53.1+ds-2) ...
Selecting previously unselected package puredata-utils.
Preparing to unpack .../12-puredata-utils_0.53.1+ds-2_arm64.deb ...
Unpacking puredata-utils (0.53.1+ds-2) ...
Selecting previously unselected package puredata.
Preparing to unpack .../13-puredata_0.53.1+ds-2_all.deb ...
Unpacking puredata (0.53.1+ds-2) ...
Selecting previously unselected package pd-iemlib.
Preparing to unpack .../14-pd-iemlib_1.22.2-3_arm64.deb ...
Unpacking pd-iemlib (1.22.2-3) ...
Selecting previously unselected package pd-gendyflext.
Preparing to unpack .../15-pd-gendyflext_1.0.0-1_arm64.deb ...
Unpacking pd-gendyflext (1.0.0-1) ...
Selecting previously unselected package pd-zexy.
Preparing to unpack .../16-pd-zexy_2.4.1-4_arm64.deb ...
Unpacking pd-zexy (2.4.1-4) ...
Selecting previously unselected package pd-moonlib.
Preparing to unpack .../17-pd-moonlib_0.5-3_arm64.deb ...
Unpacking pd-moonlib (0.5-3) ...
Selecting previously unselected package pd-ggee.
Preparing to unpack .../18-pd-ggee_0.28-3_arm64.deb ...
Unpacking pd-ggee (0.28-3) ...
Selecting previously unselected package pd-creb.
Preparing to unpack .../19-pd-creb_0.9.2+darcs20151027-7_arm64.deb ...
Unpacking pd-creb (0.9.2+darcs20151027-7) ...
Selecting previously unselected package pd-cyclone.
Preparing to unpack .../20-pd-cyclone_0.6.1-2_arm64.deb ...
Unpacking pd-cyclone (0.6.1-2) ...
Selecting previously unselected package blokas-puredata-patches.
Preparing to unpack .../21-blokas-puredata-patches_1.02-1_all.deb ...
Unpacking blokas-puredata-patches (1.02-1) ...
Selecting previously unselected package blokas-telemetry.
Preparing to unpack .../22-blokas-telemetry_1.0.2-1_arm64.deb ...
Blokas Telemetry - https://blokas.io/patchbox-os/docs/telemetry/
Unpacking blokas-telemetry (1.0.2-1) ...
Selecting previously unselected package mec-blokas.
Preparing to unpack .../23-mec-blokas_0.1.1-3_arm64.deb ...
Unpacking mec-blokas (0.1.1-3) ...
Selecting previously unselected package node-html5shiv.
Preparing to unpack .../24-node-html5shiv_3.7.3+dfsg-5_all.deb ...
Unpacking node-html5shiv (3.7.3+dfsg-5) ...
Selecting previously unselected package osc2midi.
Preparing to unpack .../25-osc2midi_1.01-2_arm64.deb ...
Unpacking osc2midi (1.01-2) ...
Selecting previously unselected package python3-urwid.
Preparing to unpack .../26-python3-urwid_2.1.2-4+b1_arm64.deb ...
Unpacking python3-urwid (2.1.2-4+b1) ...
Selecting previously unselected package pisound-btn.
Preparing to unpack .../27-pisound-btn_1.16-1_arm64.deb ...
Unpacking pisound-btn (1.16-1) ...
Selecting previously unselected package pisound-ctl-scripts-common.
Preparing to unpack .../28-pisound-ctl-scripts-common_1.03-7_all.deb ...
Unpacking pisound-ctl-scripts-common (1.03-7) ...
Selecting previously unselected package pisound-ctl.
Preparing to unpack .../29-pisound-ctl_1.03-12_arm64.deb ...
Backing up /usr/local/pisound-ctl to /usr/local/pisound-ctl-backups/2024-02-28.11:37:07
Unpacking pisound-ctl (1.03-12) ...
Selecting previously unselected package pisound.
Preparing to unpack .../30-pisound_1.05-1_all.deb ...
Unpacking pisound (1.05-1) ...
Selecting previously unselected package pisound-ctl-scripts-puredata.
Preparing to unpack .../31-pisound-ctl-scripts-puredata_1.03-7_all.deb ...
Unpacking pisound-ctl-scripts-puredata (1.03-7) ...
Selecting previously unselected package pisound-ctl-scripts-system.
Preparing to unpack .../32-pisound-ctl-scripts-system_1.03-7_all.deb ...
Unpacking pisound-ctl-scripts-system (1.03-7) ...
Selecting previously unselected package puredata-gui-l10n.
Preparing to unpack .../33-puredata-gui-l10n_0.53.1+ds-2_all.deb ...
Unpacking puredata-gui-l10n (0.53.1+ds-2) ...
Setting up tk8.6 (8.6.13-2) ...
Setting up pd-blokas (0.1.1-4) ...
Setting up libportaudio2:arm64 (19.6.0-1.2) ...
Setting up tcl8.6 (8.6.13+dfsg-2) ...
Setting up puredata-doc (0.53.1+ds-2) ...
Setting up osc2midi (1.01-2) ...
Setting up node-html5shiv (3.7.3+dfsg-5) ...
Setting up python3-urwid (2.1.2-4+b1) ...
Setting up puredata-utils (0.53.1+ds-2) ...
Setting up blokas-telemetry (1.0.2-1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/blokas-telemetry.target → /lib/systemd/system/blokas-telemetry.target.
Setting up tcl (8.6.13) ...
Setting up patchbox-wifi (1.3.0-1) ...

Creating the Hotspot Network with ssid 'patchbox'... WiFi connection may be interrupted. Will use IP while the hotspot is enabled.
Once done, use the command `sudo systemctl enable --now wifi-hotspot` to turn it on. Use 'disable' in place of 'enable' to turn it off.

The default password is 'blokaslabs'. Run `change_wifi_hotspot_password.sh` to change it.
Setting up pd-gendyflext (1.0.0-1) ...
Setting up tk (8.6.13) ...
Setting up puredata-core (0.53.1+ds-2) ...
update-alternatives: using /usr/bin/puredata to provide /usr/bin/pd (pd) in auto mode
Setting up puredata-dev (0.53.1+ds-2) ...
Setting up mec-blokas (0.1.1-3) ...
Setting up puredata-extra (0.53.1+ds-2) ...
Setting up pd-zexy (2.4.1-4) ...
Setting up pd-iemlib (1.22.2-3) ...
Setting up pd-ggee (0.28-3) ...
Setting up pd-creb (0.9.2+darcs20151027-7) ...
Setting up pd-moonlib (0.5-3) ...
Setting up pisound-btn (1.16-1) ...
Cloning pisound repository from https://github.com/BlokasLabs/pisound...
Cloning into '/usr/local/pisound'...
fatal: unable to access 'https://github.com/BlokasLabs/pisound.git/': Could not resolve host: github.com
Created symlink /etc/systemd/system/multi-user.target.wants/pisound-btn.service → /lib/systemd/system/pisound-btn.service.
Setting up pd-cyclone (0.6.1-2) ...
Setting up puredata-gui (0.53.1+ds-2) ...
Setting up pisound-ctl-scripts-common (1.03-7) ...
Setting up blokas-puredata-patches (1.02-1) ...
Setting up pisound-ctl (1.03-12) ...
Cloning pisound repository from https://github.com/BlokasLabs/pisound...
Cloning into '/usr/local/pisound'...
fatal: unable to access 'https://github.com/BlokasLabs/pisound.git/': Could not resolve host: github.com
Created symlink /etc/systemd/system/multi-user.target.wants/pisound-ctl.service → /lib/systemd/system/pisound-ctl.service.
Setting up puredata-gui-l10n (0.53.1+ds-2) ...
Setting up pisound-ctl-scripts-puredata (1.03-7) ...
Setting up pisound-ctl-scripts-system (1.03-7) ...
Setting up puredata (0.53.1+ds-2) ...
Setting up pisound (1.05-1) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1.1) ...
Processing triggers for libc-bin (2.36-9+rpt2+deb12u3) ...
Processing triggers for man-db (2.11.2-2) ...
Processing triggers for shared-mime-info (2.2-1) ...
Processing triggers for mailcap (3.70+nmu1) ...
Updating /usr/local/pisound...
sh: 1: cd: can't cd to /usr/local/pisound

ow you may run 'sudo pisound-config' to customize your installation!
patchbox@patchbox:~ $ 

The real problem on your system is this:

fatal: unable to access 'https://github.com/BlokasLabs/pisound.git/': Could not resolve host: github.com

You have to figure out why github.com or GitHub - BlokasLabs/pisound: pisound kernel module and user-mode button is not accessible for your system, it seems to be a network problem, or a git client problem.

Ohh snap. Yah I totaly missed that. I wonder what is happening.

Thanks for being my second pair of eyes and sorrry for any inconvenience. I see if I can find out why.


Figured it out. The OS image I have automatically sets up the default user settings (ex. Wifi) so at the point in the script it does its hotspot stuff it drops any wifi connection. Any connections at that point are refused. Causing the errors we see above. I just plugged it in via network cable and disabled wifi and have had no issues with this thus far.

I noticed it seemed like mod is missing in the config program? Also when trying to edit the hotspot it ends failing with the following trace:

patchbox@patchbox:~ $ sudo pisound-config
Traceback (most recent call last):
  File "/usr/local/pisound/pisound-config/main.py", line 177, in <module>
  File "/usr/lib/python3/dist-packages/urwid/main_loop.py", line 287, in run
  File "/usr/lib/python3/dist-packages/urwid/main_loop.py", line 385, in _run
  File "/usr/lib/python3/dist-packages/urwid/main_loop.py", line 790, in run
  File "/usr/lib/python3/dist-packages/urwid/main_loop.py", line 827, in _loop
  File "/usr/lib/python3/dist-packages/urwid/raw_display.py", line 416, in <lambda>
    wrapper = lambda: self.parse_input(
  File "/usr/lib/python3/dist-packages/urwid/raw_display.py", line 515, in parse_input
    callback(processed, processed_codes)
  File "/usr/lib/python3/dist-packages/urwid/main_loop.py", line 412, in _update
  File "/usr/lib/python3/dist-packages/urwid/main_loop.py", line 513, in process_input
    k = self._topmost_widget.keypress(self.screen_size, k)
  File "/usr/lib/python3/dist-packages/urwid/decoration.py", line 840, in keypress
    return self._original_widget.keypress((maxcol,maxrow-top-bottom), key)
  File "/usr/lib/python3/dist-packages/urwid/decoration.py", line 622, in keypress
    return self._original_widget.keypress(maxvals, key)
  File "/usr/lib/python3/dist-packages/urwid/container.py", line 1135, in keypress
    return self.body.keypress( (maxcol, remaining), key )
  File "/usr/lib/python3/dist-packages/urwid/listbox.py", line 968, in keypress
    key = focus_widget.keypress((maxcol,),key)
  File "/usr/lib/python3/dist-packages/urwid/wimp.py", line 543, in keypress
  File "/usr/lib/python3/dist-packages/urwid/widget.py", line 461, in _emit
    signals.emit_signal(self, name, self, *args)
  File "/usr/lib/python3/dist-packages/urwid/signals.py", line 265, in emit
    result |= self._call_callback(callback, user_arg, user_args, args)
  File "/usr/lib/python3/dist-packages/urwid/signals.py", line 295, in _call_callback
    return bool(callback(*args_to_pass))
  File "/usr/local/pisound/pisound-config/main.py", line 82, in hs_menu
    items = values.get_hs_config()
  File "/usr/local/pisound/pisound-config/values.py", line 90, in get_hs_config
    with open(settings.HS_CFG, 'r') as f:
FileNotFoundError: [Errno 2] No such file or directory: '/etc/hostapd/hostapd.conf'

More progress…

Thnx, I had the same issue, tried to install it while using WiFi. So plugged in the Ethernet cable and installation went flawless in my case.

I am not sure how you use your pisound but did the Mod web UI work for you ?

Yes, all works fine for me, really love this setup with Modep and Pisound. Screwed it up two times when fiddling around with all kinds of settings.
I just checked your message from 10 days ago. I have the py-files in /usr/lib/python3/dist-packages/urwid/ but my system also has no /etc/hostapd/hostapd.conf. Never tried to use the hotspot. I just have the Pi connected to my WiFi router (after setting it up over the LAN). I did not disable WiFi by the way, plugging in the LAN-cable was enough. My advice is to do a fresh install again with a plugged in LAN-cable if you still have issues.

I will give it another go and see what happens. I must have messed something up and not relised it.


By the way, this is the version of Pi I have installed:

Raspberry Pi OS with desktop

  • Release date: December 5th 2023
  • System: 64-bit
  • Kernel version: 6.1
  • Debian version: 12 (bookworm)
  • Size: 1,108MB

Since my last fresh install everything is working as expected, midi, buttons, changing the sample rate. Really happy with this setup now.

Hi folks. First post. I got a pi5 and pisound because, although I knew it’d be trickier, I’m hoping to use multiple instances of Neural Amp Modeller with convolution reverb for my guitar rig and I reckoned I needed all the horsepower I could get.

Please tell me if this is asking too much but could someone tell me the steps to getting MODEP running on my device? I’m new to Linux although I have some terminal experience on Mac.

Which operating system do I choose for running MODEP (since I understand Patchbox OS is not yet compatible with the pi5)? What do I then need to run to get pisound and MODEP running fully. I’ve been reading through these recent posts but I can’t quite figure it out.

Thanks for any answers or advice on where to look to figure this out.

1 Like

The pi5 works great with modep. I installed the 64-bit version of the Pi OS with desktop, so I can use the UI locally. Using the UI locally, by the way, is not advisable if you want to run multiple instances of the NAM and have a low latency setup as well. I also like the desktop environment for downloading content and some basic file management. So these are the steps:

  1. Make an image (Raspberry Pi OS 64-bit bookworm with desktop in my case) on the SD-card.
  2. Install the SD-card and let the basic setup complete.
  3. Install the Pisound and modep software (first time you run the Pisound installation it asks for a system update, you must perform that extra action):
sudo curl https://blokas.io/pisound/install.sh | sh
sudo curl https://blokas.io/apt-setup.sh | sh
sudo apt install modep

Be sure to connect your Pi to a LAN (cabled) network, because installation of the pisound (to be exact, initialising the WiFi hotspot function) will cripple your WiFi connection resulting in an incomplete installation of the Pisound software.

After this you can configure your setup. Be aware that ‘normal’ NAM-profiles use a lot of resources. If you use more instances of NAM, use Tonehunt NAM-profiles with the #light-mdl an #nano-mdl if you want to use the standard sound settings (low latency).


Thank you so much! I’ll let you know how I got on.

Thanks so much again. I got it up and running. The results were better than I could have expected. With my baseline rig - NAM fuzz full sized profile → 5 sec long convolution spring reverb IR → NAM amp full sized profile → cabinet IR - the CPU peaked at 45%.

This means it’s totally plausible to have a dual NAM rig with convolution reverb and still build an entire special effects chain with compression, modulation, eq, etc. into a rig without running into the CPU limit. I play in a surf band as one of my projects and I can’t tell you what it meant to hear that full on Fender tank drip coming out of a tiny, portable, digital multi-fx.

One thing I struggle with was loading NAM profiles. Luckily I have a friend who’s a bit of a Linux wizard who guided me on setting up a folder called ‘NAM Models’ in the file manager and granting it the requisit permisions and NAM did recognise it. They didn’t show up if I put them in ‘Amplifier Profiles’. I couldn’t figure out what I was missing.

After some time, the pi did overheat, so it’s obviously essential to run the fan, so I’ll need the fan and a pin extender to fit the pisound over it for sure.

But the concept is proven. This inexpensive pi5 rig can run the highest fidelity amp and dirt pedal sims it’s possible to get in 2024 and run the highest quality digital reverb sims available in 2024 with processor to spare. I feel like I’ve uncovered an incredible secret.

Edit: To be clear I installed Pi OS 64bit Lite and did everything remotely from my laptop.

1 Like

Nice! Yes, it is an amazing piece of equipment, it sounds so good with so little latency. You figured it out pretty quickly considering your lack of knowledge about Linux. To be honest, to run the Lite version is the best option if you use it headless. I am still experimenting with my setup and I have got a touch screen near my equipment. So I can switch everything on and start playing right away. Luckily I can strip down the Linux version with desktop (or just close the desktop environment). Indeed, forgot to tell you about the NAM-folder. You have to set it up like you did (with a little help). The other /standard folder works for the AIDAX modeller. A nice one too which uses less resources, but lesser free profiles.
The pi5 gets hot, that’s for sure. I have used a GPIO male/female cable to separate the Pisound from the pi5 to get enough room for cooling. I only use a big heatsink (I don’t like fans in audio equipment, it can degrade your audio quality), but it needed some modification (cutting aluminium) to make it fit using the GPIO cable. If you really push the limits, it is better to use smaller heatsinks and an additional fan for cooling. In my current setup, I put the Pisound on its side and there is a big space between the pi5 and the Pisound. Heat or EMI/RFI will have as little as possible effect on the Pisound. The downside is, there is no case for my solution, so I am experimenting with a home made solution. It is almost done, but it is not a final solution yet and far from a case that is sturdy enough for a live setup.

1 Like

Hi there!! I think I have missed out something. I have just completed the installation of MODEP on my raspi5 64bit/bookworm, but I cannot find a way to load the MODEP UI pedalboard. I tried or as well as patchbox.local with no luck at all. Any suggestions??

On which device are you trying to load the UI? If it is on the Pi, you need to have some kind of dekstop environment to access a browser with the UI. If it is on another device, you need to connect that device to the local hotspot if the Pi or the Pi and your device need to be on the same network. If you have the desktop environment on the Pi, than it depends on the settings. In my case, works and http://localhost works. If they do not work, check if the services are running (Troubleshooting - MODEP Documentation)
Hope this helps.

1 Like

Finally, I managed to resolve the issue somehow. MODEP is asking for the pisound in order to load. I borrowed one from a friend and so far it runs remarkably smoothly. So, is there a way to make it work with other soundcards except pisound? How can I configure the hardware, the sample rate or the buffer size?

@ELEN_ELEN I answered this question on the following post: